Flat responsive Layout stellt Abstände und falsch dar

  • Hallo,

    die Website funktioniert unter Chrome, Safari und Internet Explorer/ Edge einwandfrei. Unter Safari allerdings stellt sie Abstände zwischen Textblöcken und Bildern garnicht oder falsch dar. Demzufolge schieben sich Textblöcke unter einander und Bilder teilweise über den kompletten Text. Das Problem tritt sowohl unter OSX als auch unter IOS auf. Des weiteren benutzt Safari eine andere Schrift als die in Zeta Producer eingestellte. Beispiele dazu in den Anhängen. Benutzt wurde ein Flat Responsive Layout mit der Vorlage Slate. Die benutzte Zeta Producer Version ist 14.2.1.0.

    Link: http://www.fleischerei-bley.de/


    Danke im Voraus für jegliche Hilfe

  • Hallo,


    würden Sie mit zur Überprüfung bitte Ihr Projekt senden? Das geht folgendermaßen:


    1. Öffnen Sie Ihr Projekt in Zeta Producer
    2. Gehen Sie auf das Menü "Extras"
    3. Klicken Sie auf den Button "Optionen"
    4. Klicken Sie auf "Aktionen"
    5. Klicken Sie rechts auf die Aktion "Projekt Senden" damit diese Markiert ist
    6. Klicken Sie unten auf den Button "Ausführen"
    7. Geben Sie im 1. Feld Ihre E-Mail-Adresse ein, damit wir Sie für Rückfragen kontaktieren können
    8. Geben Sie als Referenz ins Feld Bemerkungen den Link zu diesem Forum-Artikel ein (per Kopieren und Einfügen)
    9. Klicken Sie auf den Button "Senden"

    Während wir an Ihrem Projekt arbeiten, sollten Sie bei sich keine Änderungen durchführen, denn sonst müssten Sie das ggf. nochmals im von uns modifizierten Projekt durchführen.

  • hallo Kroetephil & Stefan S ,


    auf der Seite wird ja der Google-Fonts "Roboto" verwendet. Unter IOS gibt es öfters Probleme mit der Einbindung von Google-Fonts. Eventuell einfach mal auf eine Standardschriftart wechseln.

  • Hallo,


    Fonts sind hier nicht das Problem. So viel kann ich sagen. Ursächlich hier scheint die Kombination von Artikel- und Absatzabständen zu sein, die unterschiedliche Maßeinheiten nutzen. Genaueres sehe ich aber erst im Projekt.

  • Hallo,

    Hanabi im Projekt an sich wurde größtenteils Arial verwendet, viel mehr Standardschrift geht glaube ich nicht. Das dass die Ursache ist glaube ich auch nicht, das war lediglich ein Hinweis auf einen möglichen Fehler. Danke allerdings für die Hilfe.

  • Hallo Kroetephil ,

    Sie haben mir nicht das Projekt gesendet, sondern Protokolldaten (die benötige ich nicht). Bitte lesen Sie die Anweisungen oben nochmals genau durch und senden Sie mir das Projekt, wie darin beschrieben.

  • Hallo Stefan S ,

    haben Sie das Projekt dieses mal bekommen? Ich möchte dies nur nochmal sicherstellen, da das Programm sich leider direkt nach dem Fertigstellen aufgehängt hat und generell sehr lange gebraucht hat um zu senden, trotz guter Internetverbindung und einigermaßen schneller Festplatte.

    Mit freundlichen Grüßen Kroetephil

  • Hallo,


    ich habe den Fehler behoben und ein Online-update ist raus. Bitte auf "Extras > Updates suchen" klicken und nachdem ZP dann Daten vom Server geladen hat einmalig die Tastenkombination "STRG-SHIFT-T" drücken, um die aktualisierten Layout-Daten anzuwenden. Danach ggf. veröffentlichen.

  • Hallo Herr Seiz,


    ich habe beim Flat Responsive Layout und der Darstellung in Safari auch Probleme. Selbst kann ich Safari nicht testen, aber ausgerechnet mein Kunde hat die Website auf dem MAC mit Safari angeschaut. http://www.hzmed.de ... es wird unter der Menüleiste der Seitentitel nur halb angezeigt.


    Besten Dank im Voraus für Ihre Hilfe.

    Dagmar Schmidt

  • Hallo Zeta-Team,


    ich habe am Wochenende meine Webseite online gestellt und es gibt immer noch Schwierigkeiten mit den Abständen zwischen den Containern bzw. die Container überlappen auf dem Iphone bzw. bei Safari (siehe Bild). Ist vielleicht eine Einstellung bei meiner Seite falsch bzw. was kann ich machen?



  • Hallo TK2007

    Bei Ihnen ist das Online-Update vom Februar noch nicht installiert (Sie nutzen eine Layout-Version vom Januar). Ggf. mal auf "Extras > Updates suchen" klicken und danach STRG-Shift-T drücken und dann veröffentlichen…

  • Hallo,


    das habe ich bereits mehrfach versucht. Nach dem Update und der Tastenkombination erscheint auch die Meldung "Verarbeitung läuft".


    Titel: Zeta Producer 14

    Version: 14.2.1.0

    Versionsname: Express

    Datum: 22.12.2017 11:05 (vor 2 Monaten)

    Lizenz:

    Sprache: de

    Kultur: de-DE

    UI-Kultur: de-DE

    Letztes Content-Update: 26.02.2018 12:47 (vor 4 Minuten)

    Web-Projekt: C:\Users\.....\Documents\Zeta Producer 14\projects\.....

    Projektvorlage: Arztpraxis 3

    Layout: Flat Responsive (angepasst)

    Layout vorhanden: Ja

    Variante: 01-slate-angepasst-2

    Variante vorhanden: Ja

    Gesamtanzahl Seiten: 34

    Anzahl inaktiver Seiten: 0

    Anzahl aktiver Seiten: 34

    Anzahl Bilder: 11

  • Layout: Flat Responsive (angepasst)

    Das "(angepasst)" hier bedeutet, dass Sie eine Kopie des Original-Layouts nutzen. Kopierte Layouts sind von Updates ausgeschlossen, weil wir ja nicht Ihre Anpassungen ersetzen möchten.


    Um das Original-Layout zu nutzen, einfach das kopierte Layout löschen und das Projekt neu öffnen…

  • Achtung: vor dem Löschen des Layout-Ordners ggf. den Unterordner variants irgendwo wegsichern. Dieser Ordner enthält die Layoutanpassungen. Den Ordner kann man dann ggf. in den Ordner mit dem Namen des Original-Layouts verschieben, damit die Einstellungen erhalten bleiben.

  • Zitat

    "Um das Original-Layout zu nutzen, einfach das kopierte Layout löschen und das Projekt neu öffnen…"

    Wenn ich den angepassten Layout Ordner "flat responsive (angepasst)" lösche, wird das ganze Project nicht mehr geöffnet. Es erscheint eine Fehlermeldung beim Start von Zeta (siehe Bild). Wenn ich auf Fortsetzen "klicke" schließt sich Zeta.




    Können Sie mir vielleicht detailliert erläutern, wo ich welchen Ordner löschen muss?

    Den Ordner variants -in dem angepassten layout- habe ich gesichert.

  • Mein Fehler, sorry. Sie hätten erst das Layout in den Layout-Einstellungen auf das Standard-Layout umschalten müssen. Haben Sie das gelöschte Layout noch? Falls nicht, kein Problem, dann kann ich das direkt in Ihrer Datenbank reparieren.

  • Hallo,


    ja, ich habe das Layout noch.

    Wie stelle ich den auf das Standard Layout um? Ich habe als Layout zur Auswahl nur flat responsive angepasst.

    Ich habe jetzt die Variante auf "weiß - light" gewechselt anstatt -slate 2 angepasst- und danach den Layout Ordner "flat responsive (angepasst)" gelöscht.Siehe Foto




    Selbes Ergebnis: Zeta sucht den Ordner und startet nicht.

  • Hallo, wenn Sie in der Liste weiter rechts schauen, sollte "Flat Responsive" sichtbar sein, die Layouts sind alphabetisch sortiert. Das müssen Sie auswählen (nicht eine Variante des angepassten Layouts…)