Gästebuch Adminanmeldung funktioniert nicht, "Kennwort ist nicht korrekt."

  • Hallo Zeta-Fans,


    wenn ich wie unter Ziffer 2 beschrieben https://docs.zeta-producer.com/eintraege-verwalten.html

    nach Eingabe meines Kennwortes auf "Anmelden" klicke,

    wird nicht, wie erwartet, der Administrationsbereich des Gästebuchs geladen, sondern es erscheint stattdessen immer wieder


    "Das angegebene Kennwort ist nicht korrekt. Bitte versuchen Sie es erneut."


    - Obwohl ich es mehrfach geändert, danach jeweils unter "Veröffentlichen" auf "Webseite online veröffentlichen" geklickt und die "gaestebuch.php?administration" neu aufgerufen habe.


    Eine Emailadresse habe ich nicht eingetragen. Einen Haken vor "Neue Einträge moderieren" habe ich nicht gesetzt.
    Was kann ich tun, um in den Administrationsbereich des Gästebuchs zu gelangen?

  • Hallo,


    das passiert in der Regel nur, wenn die im Browser eingegebene Web-Adresse nicht mit der Web-Adresse, die in den FTP-Einstellungen des Projekts eingegeben wurde, übereinstimmt.

  • Hoppla,


    eine Antwort innerhalb nur 1 Minute nach Absenden ist nicht nur vorbildlich, sondern weltrekordverdächtig. Danke.


    Die Webadresse, die in den FTP-Einstellungen im oberen Feld neben "Web-Adresse" steht, rufe ich mit dem Zusatz "/gaestebuch.php?administration" auf.
    Kanns trotzdem daran liegen?

  • Aus dem Gästbuch Editor kopiere ich http://www.islamverstehen.lima…tebuch.php?administrationNach dem Aufrufen ergänzt der Torbrowser ein "s" hinter http und zeigt im Adreßeingabefeld https://www.islamverstehen.lim…tebuch.php?administration. Auch dann noch, nachdem ich den Haken vor "HTTPS Everywhere" herausgenommen habe und jetzt darüber der Tooltip "HTTPS Everywhere (disabled)" erscheint.


    Der Browser Internet Explorer ergänzt ebenfalls selbsttätig ein "s", das ebenfalls stets wieder erscheint, nachdem ich es rauslösche und aufrufe. Hier jedoch erscheint im Kennworteingabefeld ein Augensymbol und es erscheint keine Fehlermeldung nach Eingabe des Kennwortes. Aber auch kein Adminbereich, es passiert einfach nichts.


    Das Kennwort lautet: kennwort


    (Anmerkung: Von den Gästebuchoptione habe ich ein Bildschirmfoto gemacht. Nach Klick auf "Hochladen" erscheint jedoch die rote Fehlermeldung "Die Datei ist zu groß.")

    • Hilfreich

    Ok, die ursache ist, dass Ihre Website zwingend HTTPS nutzt, Sie aber in der Web-Adresse in den FTP-Einstellungen kein "https://" eingegeben haben.


    Nach Umstellung einer Website auf HTTPS müssen Sie einfach in den FTP-Einstellungen des Projekts im Feld Web-Adressezu Beginn auch das Protokoll https://eingeben. Wenn Ihre Web-Adresse z.B. http://www.example.com ist, sollte dann nach der Eingabe entsprechend https://www.example.com im Feld stehen. Danach dann die Website veröffentlichen.

  • Danke Uwe Keim, danke Stefan S.,


    genau das war es. Vorbildlich perfekt gelöst:

    • blitzschnell
    • fähig

    • verständlich: Schritt-für-Schritt-Anleitung, die jeder Laie auf Anhieb leicht nachvollziehen kann.


    Das kann man nicht "toppen" - Summa cum laude, Note 1.0

  • Hallo habe das gleiche Problem mit dem Adminzugang im Gästebuch

    Gästebucheinträge funktionieren, alles was hier vorgeschlagen wurde schon gemacht, kein Erfolg.

    Bekomme immer die Meldung " Kennwort stimmt nicht"

    Habe auch schon das Gästebuch inkl. Seite gelöscht ( auch vom Server) alles brachte kein Erfolg.

    Vielleicht gibt es ja noch etwas was ich übersehen habe.

    www.bmw-fans-nrw.de

    Danke schon mal.

    ZP 14.3.1 Express

    Win 10

  • Bitte mal alle Cookies im Browser löschen und nochmals testen. Wenn es dann immer noch nicht funktioniert, senden Sie uns bitte eine E-Mail mit folgendem Inhalt:

    • URL zu diesem Forumsartikel
    • URL zur Seite mit dem Gästebuch auf Ihrer Website
    • Passwort für die Gästebuch-Administration

    an support[ät]zeta-producer.com ([ät] durch @ ersetzen).

  • Also ich hab jetzt einiges auf dem Server getestet und komme nich nicht dahinter was das lost ist.

    Haben Sie auf dem Server die Möglichkeit die PHP Version zu wechseln? Wenn möglich, wechseln Sie mal auf PHP 7 und geben Sie dann hier bescheid. Wäre interessant zu sehen, ob das was ändert.

  • Also ich habe nun schon mehrere Stunden versucht, das Problem auf dem Server zu debuggen. Eben hat unser Entwickler auch noch mal nachgesehen. Aus einem für uns nicht erkennbaren Grund, kann der Login-Dialog nicht auf bestimmte globale Variablen zugreifen, in denen das Passwort definiert ist. Keine Ahnung, was die Telekom hier treibt. Irgendwie muss deren PHP Speziell eingestellt sein. Leider konnten wir nicht herausfinden, welche Einstellung dies verursachen könnte.


    Da müssen wir leider passen. Das tut uns leid. Da kann ich nur empfehlen ggf. auf einen anderen Hoster auszuweichen.