SMTP beim Formularversand

  • Hallo ich habe heute meine Seite auf SSL umgestellt und wollte zusätzlich SMTP-Versand im Kontaktformular einrichten. Ich habe alle Daten eingegeben, neu erstellt und veröffentlicht. Aber die Antwortzeiten sind ganz lange und dann bricht die Verbindung mit einem Fehler ab. Ich habe die .htaccess rausgenommen und alle möglichen Optionen versucht, aber es funktioniert nicht. Ohne SMTP funktioniert der Versand. Also kann es ja eigentlich weder an dem SSL oder der .htaccess liegen.


    Ich habe hier auf einer Unterseite, das Formular mal reinkopiert.


    https://www.consultoro.de/kontakt_copy


    Vielleicht kann mal jemand drüber schauen und mir Tipps geben, was ich anders machen muss.


    Danke schön!

  • Hallo,

    es kann durchaus sein, dass z.B. Ihr Webserver keine Kommunikation nach aussen zulässt und dadurch z.B. der SMTP-Server nicht erreichbar ist und das System dann lange auf einen Timeout wartet. Eventuell erhalten Sie beim Absenden des Formulars mehr Informationen, wenn Sie in den Formular-Einstellungen bei den optionalen Einstellungen die "Debug"-Option aktivieren (in den Optionen ganz nach unten scrollen).

  • Die Debug-Ausgabe sehen Sie im Fehlerfall im Webbrowser, nachdem Sie ein Formular abgesendet haben.

  • Das Formular scheint aber laut Screenshot oben einen 500er Fehler zu liefern. Viele Provider bieten Zugriff auf das error.log des Webservers und da stehen dann meist auch Fehlerdetails drin.

  • Leider werden unterschiedliche Fehler geliefert. Es scheint immer in einen Timeout zu laufen. Im Debugger sehe ich nichts. Der Provider sagt es sei alles in Ordnung. Ich nutze die Version 13.03 Business, habe PHP 7. Test mit 5.6 war leider erfolglos. Die Empfänger - Emailadresse ist ein reguläres Postfach. Der Empfnag und Versand ohne SMTP funktioniert.

    Ich habe gerade keine wirkliche Idde, wo ich noch suchen soll. Liegt es am Formmailer Script?


    Diese Meldung kommt, wenn man lange genug wartet:


    The page you are looking for is temporarily unavailable.

    Please try again later.

    3858fb5ac9289b7d979cd642cd1f5195 6e1b0f10e4a9f2df146067fc2d660f31 c4e308313192e3f20ef266c03efca50f

  • Hallo Christine,


    ich bin selbst bei 1&1 und nutze die V14. Habe Deine Fragestellung mal nachgebaut und komme zu dem selben Ergebnis. Weder über TLS (587) noch über SSL (465) kommt es zu einem Versand. Bei ausreichender Wartezeit kommt es zum von Dir beschriebenen Timeout.

  • Hallo,


    ich habe das selbe Problem!


    Seite ist Neu auf ssl umgestellt und es funktioniert kein Versand über smtp (egal ob TLS 587 oder SSL 465). 1und1 als Anbieter.


    Dazu kommt noch ein anderes Problem!

    Damit die Formulare funktionieren, habe ich den SMTP-Versand entfernt.

    ABER: Nach dem Versenden des Formulars werde ich jetzt auf die Startseite der Webseite weitergeleitet und nicht mehr die Seite: "Daten erfolgreich übermittelt".

    Hab auch mal eine andere Seite der Webseite bei erfolgreichem Versand verlinkt, gleiches Ergebnis > Startseite.


    Kann es an der .htaccess Datei liegen, die ich angelegt habe damit man auch auf die SSL-Seite / Variante der Webseite umgeleitet wird.

    Anbei der Code der .htaccess

    RewriteEngine on

    RewriteCond %{HTTP_HOST} www\.hoehne-sinemus\.de

    RewriteRule .* http://hoehne-sinemus.de/$1 [R=301,L]
    RewriteCond %{SERVER_PORT} !443
    RewriteRule .* https://hoehne-sinemus.de/$1 [R=301,L]


    Was muss ich ändern, damit ich wieder auf die richtige Seite: "Daten erfolgreich übermittelt" gelange nach dem Versand?

    So ist es für den Nutzer der Seite nicht klar ob seine Daten versendet wurden!

  • Hallo,


    nach Umstellung einer Website auf HTTPS müssen Sie einfach in den FTP-Einstellungen des Projekts im Feld Web-Adresse zu Beginn auch das Protokoll https:// eingeben. Wenn Ihre Web-Adresse z.B. http://www.example.com ist, sollte dann nach der Eingabe entsprechend https://www.example.com im Feld stehen. Danach dann die Website veröffentlichen.

  • Hallo,


    die Einstellungen habe ich auf https://www.example.com geändert. Dennoch wurde ohne die .htaccess Datei immer die Variante ohne https aufgerufen.

    Nur wenn ich die Adresse manuell in den Browser eingegeben habe mit https://.... wurde die richtige Seite geladen.

    Daher blieb nur der Weg mit der .htaccess

  • Die .htaccess Regeln leiten Zugriffe auf die Domain mit www. auf die Domain ohne www. und ohne https weiter. Korrigiert würde die Regel so aussehen:


    Code
    RewriteEngine on
    RewriteCond %{HTTP_HOST} www\.hoehne-sinemus\.de
    RewriteRule .* https://hoehne-sinemus.de/$1 [R=301,L]
    RewriteCond %{SERVER_PORT} !443
    RewriteRule .* https://hoehne-sinemus.de/$1 [R=301,L]

    In den FTP-Einstellungen sollten Sie dann entsprechend aber das www. auch nicht eingeben, sonst wird da ja auch immer wieder umgeleitet.

  • PS: wenn der SMTP-Versand bei 1&1 nicht funktioniert, wird das mit relativer Sicherheit von denen Blockiert. In dem Fall nutzen Sie die Formulare doch einfach ohne die SMTP-Option (was ja zu funktionieren scheint).

  • Vielen Dank!


    Das mit der Weiterleitung auf die Erfolgreich gesendet Seite funktioniert wieder!


    Gibt es auch eine Lösung für den SMTP Versand mit SSL oder TLS?

    Oder liegt es nur am Provider und es gibt keine Möglichkeit über SMTP zu versenden?

  • Hallo zusammen,


    es liegt tatsächlich am Provider, Onkel Google konnte aber weiterhelfen: https://hoster.wtf/11-eigene-s…den-mailversand-geblockt/


    Der Versand über SMTP klappt mit Port 25 und TLS


    Nach der Änderung nicht vergessen, den DEBUG-Modus rauszunehmen.

  • Danke für das recherchieren@Hanabi :thumbup:. Nachdem ich mehrfach mit der 1und 1 Hotline telefoniert habe und nicht wirklich eine Antwort bekam, bin ich nicht drauf gekommen mal Google zu fragen.


    Ich werd es morgen testen und einrichten.

  • SMTP funktioniert nun, aber ich habe jetzt auch das Problem, dass er entweder gar nicht auf die "Gesendet" Seite weiterleitet oder auf die Startseite weiterleitet. Fürchterlich sowas.||