Kontaktformular, keine Pflichtfeld Validierung

  • Hallo,


    das ist sehr eigenartig. Können Sie zum Test mal im Katalog-Bestellen-Formular das Captacha ausschalten (Optionen > Skript > Via PHP) und nochmal veröffentlichen. Möchte gerne zunächst sehen, ob das was ändert. Wenn das nichts ändert, brauche ich das Projekt (da melde ich mich dann wieder).

  • Eigenartig. Ich Versuch das am Montag mal nachzustellen. Ggf. War ja der Capta-Schlüssel falsch oder so.

  • Nein, noch nicht. Kannst Du mir genau beschreiben, wie das Captcha eingestellt wurde? Also ob z.B. der Key für Invisible-Captcha beantragt war und diese Option aktiviert wurde etc. ich sollte auch wissen, was im Formular unter Optionen im Feld "Skript" gewählt war.


    Kannst Du mir zum Test dann bitte auch noch deine beiden Captcha-Keys und die URL zu diesem Artikel (als Referenz) per E-Mail an support[ät]zeta-producer.com ([ät] durch @ ersetzen) schicken?

  • Hallo!


    Gibt es hierzu in der Zwischenzeit eine Lösung?
    Denn ich habe exakt das gleiche Problem.
    Durch die Aktivierung des unsichtbaren reCaptcha (alles richtig eingestellt) werden die Formulare ohne Inhalt (also keine Pflichtfeldabfrage) versendet.
    Setze ich in den Formular-Optionen Skript: "via PHP" funktioniert die Pflichtfeldabfrage wieder.

    (ich habe in einem vorhandenen Formular den Schlüssel ersetzt und das Häkchen für unsichtbares reCaptcha gesetzt, Skipt: via PHP mit Sicherheitsprüfung. Zuvor habe ich einen neuen Schlüssel registriert und den alten Schlüssel für das sichtbare gelöscht, die Captcha-Funktion funktioniert ja auch, nur leider ohne Feldabfrage)

    Entferne ich das Häkchen "unsichtbares reCaptcha" wird das normale reCAPTCHA v2 angezeigt und das Formular funktioniert einwandfrei.

    Vielen Dank im Voraus!


  • Gute Hinweise. Danke, auf dieser Basis können wir testen und den Fehler hoffentlich finden und beheben.

  • Ich konnte den Fehler beheben. Online-Update ist raus. Frühestens um 16:00 Uhr mal auf "Extras > Updates suchen" klicken um das Update zu laden. Danach dann ggf. "Erweitert > Erstellen > Alle Seiten erstellen" und mit F7 veröffentlichen. Nun sollten Formulare wieder korrekt validiert werden, auch wenn ein "invisible" ReCaptcha verwendet wird.

  • Danke für Ihre Info.


    Die Pflichtfeldvalidierung erfolgt jetzt mit dem invisible ReCaptcha, aber das ausgefüllte Formular lässt sich nicht mehr versenden.

  • In unseren Tests ging das Versenden problemlos. Wie äußert sich das „lässt sich nicht versenden“ bei Ihnen? Gibt es einen Link zu Ihrem Formular, wo wir dieses Verhalten sehen können?

  • Besten Dank und Sorry, da hatte es eine Zeile Code, die ich in meinem Testprojekt hatte, nicht ins Update geschafft. Ist nachgeholt. Bitte ab 9:30 nochmals "Extras > Updates suchen"… Dann sollte es wirklich funktionieren.

  • Hallo Stefan,

    vielen Dank.

    Ich habe das Thema eben wieder aufgenommen.


    Allerdings habe ich im Kontaktformular noch ein Problem,

    2 Pflichtfelder sind ausgefüllt, unten erscheint ein roter Strich und das Formular wird nicht versendet.

    Liegt scheinbar an der PHP mit Sicherheitsprufung. mit PHP geht es.


    Danke für ein Feedback.

  • Hallo SilverEagle ,


    ich habe ein Testprojekt mit einem Formular mit der gleichen Feld-Anzahl und den selben Feldnamen und Pflichtfeldern angelegt. Im Formular die Google API-Keys in den Optionen eingegeben und die Option "Schlüssel… sind für invisible reCAPTCHA registriert…" aktiviert.

    In meinem Test funktioniert die Validierung absolut korrekt. Eventuell wurden die widgets nicht neu erstellt? Versuch mal "Erweitert > Erstellen > Ausgewählte Seiten erstellen" und darin dann die Option "Alle Vorlagendateien kopieren" aktivieren und auf Start klicken. Anschließend veröffentlichen.

    Wenn dann immer nich nicht validiert wird, die Seite mit dem Formular bitte mal als Testseite duplizieren und so mit aktiver Option "PHP mit Sicherheitsprüfung" veröffentlichen und mir hier die URL zum Testen mitteilen.


    PS: bei Eurem Formular sind es ja nicht nur 2 Pflichtfelder, sondern 3. Das Feld "Mittteilung" ist auch ein Pflichtfeld und muss ausgefüllt werden.