Fehlermeldung "$z ist undefiniert", was tun?

  • Guten Tag - der benannte Link ist schon ewig drin und nun tritt diese Meldung bei vielen im Frame eingebauten Scripten auf.

    Habe alle Seiten schon neu erstellt, ZETA neu installiert, update gemacht...hilft alles nichts.

    eine der betroffenen Webseiten - https://www.kreuzfahrten-allgaeu.de/





    + der Quelltext unten.

  • "Output" und "Preview" habe ich auch gelöscht und alle Seiten wieder hergestellt, hilft auch nichts...dann kam aber auch wieder massenhaft diese kaputte Links Anzeige, nicht nur von der grad offenen Seite sondern von allen Projekten....nervig, was ist denn nun wieder los....


    SZ ist undefiniert war aber auch schon bei Version 14.3.1 plötzlich da.

    Jetzt mit ZETA 14.3.2 NEU auch noch das mit den Links.

    Das war vor dem update nicht

    Ich nutze den Zeta Producer 14.3.3 Business - :evil: :thumbsup:
    Ich meine es auch nicht böse :P

  • Hallo,


    da verursacht ein externes Skript Fehler. Wenn Sie dieses mal deaktivieren und die Seite dann neu erstellen, wird der Fehler nicht mehr auftreten. Sie müssten das externe Skript dann Schritt für Schritt untersuchen und anpassen.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Hallo, das interne Script ist schon jahrelang drin und hat nie diese Fehler verursacht....erst seit 1 Woche tritt das auf.

    Ich nutze den Zeta Producer 14.3.3 Business - :evil: :thumbsup:
    Ich meine es auch nicht böse :P

  • Hallo, das interne Script ist schon jahrelang drin und hat nie diese Fehler verursacht....erst seit 1 Woche tritt das auf.

    Hallo,


    da verursacht ein externes Skript Fehler. Wenn Sie dieses mal deaktivieren und die Seite dann neu erstellen, wird der Fehler nicht mehr auftreten. Sie müssten das externe Skript dann Schritt für Schritt untersuchen und anpassen.

    aber ok ich sende es mal weiter, Danke.

    Ich nutze den Zeta Producer 14.3.3 Business - :evil: :thumbsup:
    Ich meine es auch nicht böse :P

  • Das habe ich als Antwort bekommen : ich denke es handelt sich hier um einen jQuery Konflikt.

    Sie sollten versuchen, ohne jQuery auszukommen. Sonst kann es immer weider mal zu Versionskonflikten kommen.


    Was kann ich tun?

    Ich nutze den Zeta Producer 14.3.3 Business - :evil: :thumbsup:
    Ich meine es auch nicht böse :P

  • In den Layouts von Zeta Producer wird jQuery bereits standardmäßig geladen. Im externen Skript also einfach das Laden der jQuery-Bibliothek entfernen.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Hallo Steffen T. Wir haben den Header und den Footer erstellt und die subdomain wurde mit A-Record zum Scriptanbieter weiter geleitet, der hat das Angebotsscript in der Mitte eingefügt.

    Liegt der Fehler in der Mitte?

    Ich nutze den Zeta Producer 14.3.3 Business - :evil: :thumbsup:
    Ich meine es auch nicht böse :P