Online-CMS, keine Kennwort-Abfrage

  • Wir verwenden die Business Version 14.3.3 von Zeta-Producer.


    Wenn wir auf einer (index) Seite das Online-CMS-Widget einfügen und die Seite mit "?edit" aufrufen erscheint keine Prompt-Abfrage für die Kennwort-Eingabe. Weder mit Edge, noch mit Firefox, Google Chrome oder Safari.


    Nach intensiver Recherche im Forum haben wir folgende Optionen auf Fehler überprüft:

    • Falsche Serverdaten
    • Aktionen / Website-Features überprüfen mit positivem Ergebnis
    • Nicht übereinstimmende Adress-Angabe beim Konfigurieren des Servers, bzw. bei der Abfrage im Browser
    • Fehlende Eingabe eines Unterordners im Browser


    Da ich dort keine Fehler finden konnte, hoffe ich auf Unterstützung im Forum.


    Vielen Danke für die Energie und Zeit der Hilfestellung!


    Nancy

  • Gegebenenfalls hilft dies?


    Nach Umstellung der Website auf HTTPS müssen Sie in Zeta Producer lediglich in den FTP-Einstellungen des Projekts im Feld Web-Adresse zu Beginn auch das Protokoll https:// eingeben. Wenn Ihre Web-Adresse z.B. http://www.example.com ist, sollte dann nach der Eingabe entsprechend https://www.example.com im Feld stehen. Danach dann die Website veröffentlichen.

  • Hallo Nancy


    wenn ich in Chrome https://baumundraumkultur.at/index.php?edit aufrufe und dann mit "Mausklick rechts"->"untersuchen" die Console öffne, werden jede Menge Fehler angezeigt:


    GET https://www.baumundraumkultur.at/assets/php/cms/etc/jquery/jquery.upload-1.0.2.min.js net::ERR_ABORTED 510 (Not Extended) index.php?edit:593 

    GET https://www.baumundraumkultur.at/assets/php/cms/etc/jquery/theme/jquery-ui-1.8.11.custom.css net::ERR_ABORTED 510 (Not Extended) index.php?edit:594 

    GET https://www.baumundraumkultur.at/assets/php/cms/etc/jquery/jquery-ui-1.8.11.custom.min.js net::ERR_ABORTED 510 (Not Extended) index.php?edit:596 

    GET https://www.baumundraumkultur.at/assets/php/cms/etc/tiny_mce/jquery.tinymce.min.js net::ERR_ABORTED 510 (Not Extended) index.php?edit:594 

    GET https://www.baumundraumkultur.at/assets/php/cms/etc/jquery/jquery-ui-1.8.11.custom.min.js net::ERR_ABORTED 510 (Not Extended) index.php?edit:595 GET https://www.baumundraumkultur.at/assets/php/cms/etc/jquery/jquery.upload-1.0.2.min.js net::ERR_ABORTED 510 (Not Extended) index.php?edit:596

    GET https://www.baumundraumkultur.at/assets/php/cms/etc/tiny_mce/jquery.tinymce.min.js net::ERR_ABORTED 510 (Not Extended) index.php?edit:824 Uncaught TypeError: $z(...).dialog is not a function at HTMLDocument.<anonymous> (index.php?edit:824) at fire (bundle.js?v=636718218044514251:16) at Object.fireWith (bundle.js?v=636718218044514251:16) at Function.ready (bundle.js?v=636718218044514251:16) at HTMLDocument.DOMContentLoaded (bundle.js?v=636718218044514251:16) (anonymous) @ index.php?edit:824 fire @ bundle.js?v=636718218044514251:16 fireWith @ bundle.js?v=636718218044514251:16 ready @ bundle.js?v=636718218044514251:16 DOMContentLoaded @ bundle.js?v=636718218044514251:16 index.php?edit:1 [DOM] Password field is not contained in a form: (More info: https://goo.gl/9p2vKq) <input type="password" name="password" placeholder="Kennwort" id="password" value class="text ui-widget-content ui-corner-all" style="width:225px; float: right">

    Die Fehlernummer ist

    510 Not Extended Die Anfrage enthält nicht alle Informationen, die die angefragte Server-Extension zwingend erwartet


    Ich nehme an, dass dort noch etwas auf dem Server fehlt, bitte wie folgt vorgehen:

    1. "Erweitert" ->"Erweiterte Einstellungen" ->"Interne Listen" -> alle Listen löschen

    2. "Erweitert" ->"Erstellen" ->"alle Seiten erstellen" und danach "Veröffentlichen" ->"komplette Webseite veröffentlichen"

    3. "Erweitert" ->"Erweiterte Einstellungen" ->"Interne Listen": Wenn dort jetzt Einträge vorhanden sind, sollten diese uns zum Fehler führen.

  • dann schauen wir mal weiter, ob wir das Problem noch gelöst bekommen. Ich erläutere mal nebenbei noch den Hintergrund, damit wir eine Richtung bekommen, in die wir suchen müssen.

    - Das mit den internen Listen habe ich gemacht um sicherzustellen, dass alle von Zeta zu veröffentlichenden Dateien auch auf den Server übertragen wurden. Da die Listen immer noch leer sind, wurde anscheinend alles auf den Server übertragen.

    - Eine PHP-Abfrage zeigt die Version 7.1.1. Auch hier sollte es keine Probleme mit Zeta geben.

    - https ist in den FTP-Einstellungen bereits vorhanden; die Seite ist zwar mit und ohne www und auch unter http erreichbar (dazu mal meinen Blogbeitrag .htaccess lesen), dies sollte aber für den momentanen Fehler keine Rolle spielen.


    Auffällig ist, dass die Startseite https://www.baumundraumkultur.at/index.php (also ohne ?edit) fehlerfrei läuft. Die Fehler in der Chrome Console werden nur mit dem Zusatz ?edit angezeigt, also beim Login-Versuch in das online-cms.


    Als nächstes schlage ich vor, das Widget "Online-CMS" zu entfernen, neu zu veröffentlichen und dann einen neuen Artikel "Online-CMS" auf der Startseite zu platzieren. Für das Passwort testweise bitte keine Sonderzeichen und Umlaute verwenden, diese könnten, abhängig von der Serverkonfiguration, durchaus für Probleme sorgen.


    Wenn das auch nicht hilft, die FTP-Einstellungen notieren (für spätere Wiederherstellung), dann bei "FTP-Server konfigurieren" auf "neu"->"Kostenlos zum Testen auf zeta-producer.com", im nächsten Fenster bei "Subdomain" nur baum eingeben, dann weiter und schließlich veröffentlichen. Danach dann den Link im Widget aufrufen und berichten.

  • Vielen Danke für die detaillierte Fehlersuche auch noch zur später Stunde!!!


    Alles, was du schreibst habe auch ich schon so überprüft.

    Das online CMS Widget habe ich auf verschiedensten Seiten - sogar einer extra neuen Test Website - immer wieder eingefügt, gelöscht und neu eingefügt.


    Ich habe mir auch schon die Dateien auf dem Hoststar FTP-Server selbst angesehen.

    Nach der jetzigen Probe mit eurem Server, wo die Abfrage funktioniert und das online Einfügen von Artikeln genial einfach funktioniert ;-))) - verhärtet sich mein Verdacht, dass der Fehler am Hoststar-Server liegen muss.

    (Als Subdomain auf eurem Server habe ich "baumraum" verwendet, da baum zu kurz war ;-).

    Kann ich jetzt noch etwas tun, ohne den Support von Hoststar?

  • Hallo Nancy,


    zunächst eine Richtigstellung: ich bin, auch wenn sehr aktiv hier im Forum, kein Mitarbeiter von Zeta, sondern lediglich User der Software, hier im Forum aber zusätzlich als "externer Moderator" unterwegs.


    Eine Fehleranalyse versuche ich immer auf Basis der Logik, also im Prinzip nach dem Ausschlussverfahren (wenn nicht A dann B)


    Ein letzter Punkt, den Du noch selbst überprüfen kannst, betrifft die Datei und Ordnerberechtigungen. Gerade für PHP-Anwendungen sind immer Schreibrechte in den entsprechenden Ordnern auf dem Server notwendig. Verbinde dich dazu über filezilla mit dem Server und wechsle dort in das Verzeichnis /assets/php. Dieses sollte, ebenso wie die darunter liegenden Ordner die Berechtigung 705 haben. Dateien im Verzeichnis sollten auf 604 stehen. Falls Du dort andere Ordnerberechtigungen zu stehen hast, bitte anpassen.


    Wenn die Ordnerberechtigungen stimmen, ist der nächste Weg tatsächlich der direkte Kontakt zum Support von Hostar mit Verlinkung auf diesen Thread im Forum und die funktionierende Veröffentlichung unter http://baumraum.zeta-producer.com/index.php?edit

  • Es gibt Provider, die PHP mit gewissen Sicherheits-Tools betreiben, die z.B. den Zugriff auf Dateien mit dem Wort "etc" im Pfad verhindern. Ich bin sicher, dass das bei Ihrem Provider der Fall ist. Der Provider soll sicherstellen, dass für Ihre Website keine Dateizugriffe unterhalb des Ordners assets/php/cms/ blockiert werden.

  • Vielen Dank, für die guten Hinweise. Ich lerne wirklich jetzt extrem viel und schnell Neues dazu, durch die konstruktive Fehlersuche!


    Die Serverrechte auf Hoststar passen. Alle Unterordner 755, bzw. Files 644.

    Bei der php Engine bräuchten wir eine andere Einstellung (FastCGI Mode), die wir ohne Support nicht einstellen konnten.


    Jetzt habe ich aber noch ein anderes Problem. Ich konnte auch am Zeta Server nur ein einziges Mal (Samstag in der Nacht) editieren (Serfacebook und Edge). Der Versuch, auf Mac, I-Pad > Safari, Firefox, und Surfecbook Edge erneut zu editieren gelang jetzt auch nicht mehr. Es wird wieder keine Prompt Abfrage aufgerufen.

  • Hei Uwe, Danke!


    Gerade auf das Gleiche drauf gekommen ;-)


    Jetzt habe ich folgende Fragen.


    1. Mit Internet Explorer 11 sind wir drauf gekommen, dass Links im PHP-Script unterschiedlich mit "https" bzw. mit "http" aufgerufen werden, was der Browser dann blockt.

    Meine Frage dazu, kann das passiert sein, da ich lokal das Projekt einmal mit "http" abgespeichert hatte und daran gearbeitet habe und dann später erst mit "https" und daran weiter gearbeitet habe. Oder kommen diese Einstellungen von Zeta selbst?


    2. Hoststar redirected von "http" auf jeden Fall auf "https".


    3. Eine Veröffentlichung unter "http" ist für uns mit online CMS keine Option.

    Die Zeta Demo Version funktioniert mit "https" einwandfrei ohne Spezialsettings der Browser.

    Können wir "http"-Aufrufe steuern und unterbinden?


    Danke für die Unterstützung von allen Seiten!