Formular Optionen

  • Wohl eine Anfängerfrage, aber es ist zum verzweifeln. Formular erstellt, funktioniert alles absolut einwandfrei bis auf die "Rückmeldung", z.B. "Besten Dank für die Resultatmeldung". Habe in den Formular-Optionen alles probiert, kriege das aber nicht hin.



    Wie kriege ich das richtig hin, dass nach dem Versand (funktioniert perfekt) die entsprechende Meldung erscheint?


    Im voraus herzlichen Dank für Eure Hilfe

  • Danke, aber dort war ich bereits, löst mein Problem nicht. vgl. unten:



    Was heisst oid://page/de .....? Drücke ich auf das Link Symbol erhalte ich meine Site-Struktur. Gehe ich auf die "richtige" Unterseite, verändert sich zwar der Bezug, aber das Resultat bleibt das gleiche, es kommt keine "Versandmeldung".

  • Hallo Michel,


    im Quelltext sind weder für den Erfolg noch für den Fehler Seiten hinterlegt. Gehe mal bitte auf das Link-Symbol und wähle für Erfolg und Fehler die entsprechenden Seiten manuell aus. Bei der Erfolgsmeldung wähle testweise eine beliebige andere Seite als /test-oom.html

  • Habe ich gemacht, es ändert sich aber gar nichts.


    Sorry, aber wie hinterlege ich einen Quelltext (soweit ich das kapiert habe, geschieht das ja nach dem klick auf den link, ganz unten. Oder liege ich damit falsch?

  • Hallo Michel,


    Quelltext brauchst Du hier gar nicht. Ich habe lediglich die Anzeige des Quelltextes Deiner Testseite genutzt, um zu prüfen, ob eine Verlinkung auf die entsprechenden Seiten erfolgt. Im Normalfall sollte sich dann folgendes finden lassen:

    Code
    1. <input type="hidden" name="f_success" value="https://www.hanabi-pirna.de/nachricht-erfolgreich-gesendet.html?page-id=498">
    2. <input type="hidden" name="f_error" value="https://www.hanabi-pirna.de/nachricht-konnte-nicht-versendet-werden.html?page-id=499">

    Bei Dir findet sich dazu

    Code
    1. <input type="hidden" name="f_success" value="http://www.seniorengolf.ch/test-oom.html">
    2. <input type="hidden" name="f_error" value="http://www.seniorengolf.ch/test-oom.html">

    Erfolgs- und Fehlerseite verweisen also direkt auf das Kontaktformular, dadurch sieht der Besucher nach Absenden der Nachricht wieder direkt die Seite mit dem Kontaktformular.


    Die Seite http://www.seniorengolf.ch/nac…cht-versendet-werden.html ist aber existent, wenn auch mit einem anderen Layout. Bitte prüfe einmal, ob im Verzeichnisbaum links unterhalb von System die automatisch erzeugten Seiten "Nachricht erfolgreich gesendet" und "Nachricht konnte nicht versendet werden" existieren. Wenn ja, wähle im Formular diese Seite aus, wenn nein, lege diese Seiten bitte unterhalb von "System" an und verlinke dann im Kontaktformular auf die beiden neu erstellten Seiten.


    Wenn sich tatsächlich nichts ändert, also selbst nach Auswahl der entsprechenden Seiten über "Link" immer noch oid:// im Linkfeld steht, kommen wir hier momentan nicht weiter. Ich würde dann empfehlen, am Montag ein Support-Ticket zu lösen.

  • Ganz herzlichen Dank für die grossen Bemühungen! Ich habe jetzt zusätzlich nochmals ein Formular "Testquittung" http://www.seniorengolf.ch/testquittung.html völlig angelegt. Resultat: es geht auch nicht.


    Ich habe jetzt so ziemlich alles versucht, was mir zum ganzen einfällt, es geht nicht! Sofern Du Zeit hast, noch 2 Fragen:


    Wenn ich Deine 2 Codeschnipsel die Du gesendet hast vergleiche, fällt auf, dass bei Deinem Code im Vergleich zu meinem am Schluss eine "page ID" angegeben ist, bei mir nicht. Woher kommt diese page ID?


    Du schreibst: Bitte prüfe einmal, ob im Verzeichnisbaum links unterhalb von SYSTEM die automatisch .........Was meinst Du unterhalb von System (ich finde nirgends den therm "System"??)


    Wäre super wenn wir das noch lösen könnten, sonst löse ich am Montag dann wie vorgeschlagen ein Support Ticket.


    Herzliche Grüsse

    Beat

  • Hallo Beat,


    bevor wir weitermachen, noch eine Entschuldigung, ich hatte in der Kombination Beat/Michel den Michel als Vornamen gewertet.


    Sämtliche Daten zum Projekt werden ja in einer Datenbank gespeichert. "page-id=498" ist sozusagen der Datensatz für die 498. Seite im Projekt, wie die Seite genau heißt, steht dann in einem anderen Feld des Datensatzes. Bei Dir wurde vermutlich deshalb keine page-id erzeugt, weil innerhalb der selben Seite verlinkt wird.


    Die zweite Frage versuche ich mal mit Bildern zu beantworten ;).


    Bild 1 zeigt den Seitenbaum mit blau unterlegtem "System"

    Bild 2 zeigt die einzelnen Unterseiten von "System"

    Bild 3 zeigt die Verwendung im Formular

  • Hallo Thomas


    Also das mit dem Vornamen macht gar nichts, ich bin mich das mit meinem für Deutschland wohl eher komischen Vornamen gewohnt.


    Unglaublicher Service, herzlichen Dank!


    Ich glaube, wir kommen der Sache näher. Habe hier irgendwo offensichtlich einen groben Bock eingebaut, bei mir gibt es "System" nicht!




    Ich versuche mal herauszufinden, warum das so ist!


    Herzliche Grüsse

    Beat

  • Hallo Beat,


    die wurden entweder mal gelöscht oder oder das Projekt wurde als leeres Projekt ohne Inhaltsvorlage angelegt (die Option gab es nach meiner Kenntnis in einer älteren Version).

    Auch wenn die Seite "System" praktisch nicht benötigt wird, sollte sie angelegt werden mit folgenden Unterseiten:

    - Seite nicht gefunden

    - Nachricht erfolgreich versendet

    - Nachricht konnte nicht gesendet werden

    Wichtig: Damit diese Seiten nicht im Menü und den Suchergebnissen auftauchen, die Seiten ausblenden und unter Seiteneigenschaften das Häkchen entfernen bei "Google-Sitemap.

  • Hallo Thomas


    Ganz herzlichen Dank, ALLES GELÖST! Ich habe die "Systemseite" entsprechend angelegt und auch die entsprechende Verlinkung vorgenommen.


    Ein ganz schönes Wochenende wünscht Dir

    Beat