Einstellungen "Seite": Dateinnamen und (fehlende) Dateiendungen

  • Hallo, ich habe mit dem ZP 14 "Neue Website erstellen" aufgerufen und hierbei zum Test lediglich ein Layout aud den Design-Vorlagen (in diesem Fall "Flat Responsive - Nature") ausgewählt, die Website-Erstellung durchlaufen lassen und selbst keinerlei Änderungen vorgenommen.


    Anschließend habe ich den Bearbeitungs-Modus der einzelnen Seiten und hierbei die Option "Google" geöffnet.


    Hierbei fällt mir auf, dass z.B. bei der Startseite der Dateiname "index" in der Maske aufgeführt ist, aber keine Dateiendung angezeigt wird (also bspw. ".html"). Am Ende ein grünes Symbol.


    Bei der in der Design-Vorlage automatisch erstellten Seite namens "Unterseite" ist als Dateiname "level-2" angezeigt und nicht, wie ich erwartete, "unterseite" - wobei "unterseite" in der Auswahl (Pfeil nach unten im entsprechenden Feld) jedoch aufgeführt ist.


    Auch hier keine Dateiendung, dafür am Ende jedoch ein orangefarbenes Symbol.


    Keine Dateiendungen auch bei den beiden weiteren Seiten "Kontakt", "Impressum" sowie im Bereich "System" (inkl. Unterseiten wie "Suche") - mit entsprechenden farbigen Symbolen, die allesamt nicht "grün" sind.


    Veröffentlicht man die Website, dann sind (in diesem Fall) aber Dateiendungen (.html) bei den veröffentlichten Seiten in der URL angezeigt:


    https://hosting.zeta-producer.com/6138117843/index.html



    Welchen Hintergrund hat das bzw. weshalb werden im ZP die Dateiendungen nicht korrekt (entsprechend der veröffentlichten Website) in den Einstellungen angezeigt?

    Dafür sind die entsprechenden Felder ja meiner Einschätzung nach gedacht.

    Beste Grüße
    Jörg




    ---
    Ich nutze Zeta Producer 15.1.1 Business

  • Steffen T. Hallo,

    herzlichen Dank für die prompte Antwort! :thumbup:

    Die Endung ".php" wird ebenso automatisch erstellt? Wenn ja, unter welchen Voraussetzungen?

    Beste Grüße
    Jörg




    ---
    Ich nutze Zeta Producer 15.1.1 Business

  • Hallo Jörg,


    der Wechsel auf "php" erfolgt in der aktuellen Zeta-Version automatisch, sobald ein auf der Seite eingefügter Artikel aktives PHP benötigt. In den Vorgängerversionen bekam man dort noch die Fehlermeldung "falscher Seitentyp" und musste manuell wechseln. Wenn das PHP-Element von der Seite entfernt wird, geht es übrigens nicht automatisch zurück. Wäre ja auch blöd, wenn Google die Seite allerbeste-zahnbuerste-der-welt.php indiziert hat und man dann bei Anklicken des Links auf ERROR 404 kommt. ;)

  • Guten Abend Thomas,

    vielen Dank für die Info! :thumbup:

    Nachtrag: Fände im Falle dessen, dass man ggf. PHP-Elemente im Nachhinein entfernt eine Prüfung (ähnlich der Linkprüfung) gut. Bei umfangreichen könnte nämlich schnell vergessen werden, manuell den richtigen Dateityp wieder zuzuweisen.

    Beste Grüße
    Jörg




    ---
    Ich nutze Zeta Producer 15.1.1 Business

    Einmal editiert, zuletzt von jjonline ()