Links werden in HTML falsch dargestellt, funktionieren aber trotzdem...

  • Hallo,


    wie ist das möglich?


    Aus dem Artikelteil verlinke ich zurück zu einem Eintrag in der Tabelle auf derselben Seite. Wie man sieht, funktioniert das einwandfrei (Link: ...zu diesem Eintrag in der Tabelle).


    Zufällig habe ich gesehen, dass der Code aber auf eine andere Seite verweist! s. Markierung.

    Es gibt zwar eine Page "Kleine Storys", aber nirgendwo ein -01. Alle Google-Eintragungen sind richtig.


    <p><a href="oid://article/1d815e86-6cb6-492a-a9fc-b6bd3a566fea">...zur

    Übersicht</a>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;<a href="oid://page/de$kleine-storys_01?#wasistzeit">...zu diesem Eintrag in der

    Tabelle</a></p>


    Da alles funktioniert, könnte mir das ja egal sein; aber ich verstehe nicht, warum; trotz des falschen HTML-Codes?

  • Lieber Norbert,


    aus meiner Sicht hängt dass mit Deinen Versuchen zusammen, außerhalb der Programmkonventionen Sprünge nicht nur auf einen einzelnen Artikel zu machen, sondern in einzelne Artikelabschnitte zu gelangen, nachdem Du dort über HTML manuelle Sprungmarken eingefügt hast, wie im verlinkten Beispiel mit #wasistzeit. Um zu verstehen, was dort genau läuft, müsste man sich zunächst mit Deinen zusätzlich erstellten Sprungmarken beschäftigen. Ich hatte vor kurzem einem anderen User, der unbedingt einen bestimmten Code in Zeta unterbringen wollte, sinngemäß geantwortet,


    "... dass dieses Forum keinen Support leistet für mutwillig selbst zerstörte Projekte ..."


    Unsere Vereinsseite ist sicherlich nicht gerade "der letzte Schrei" und hat auch kaum Effekte, aber sie läuft seit 4 Jahren stabil unter Zeta 12 / 13 / 14 mit 250 Seiten, rund 5000 Fotos, 2 GB Gesamtoutput, einem Shop, mehreren geschützten Bereichen und diversem, von externen Servern eingebundenem Material (Hochwasser & Unwetter).


    Gib Dich zufrieden mit den "Unzulänglichkeiten" in Zeta, die vielleicht Deinem Anspruch nicht ganz genügen, aber dafür eine stabile Seite garantieren.

  • Sollte das nicht eher in das Forum „Web-Plauderecke“, denn das sind keine Funktionen von Zeta?
    Web-Plauderecke

    Forumbeschreibung:


    Alles was sonst noch in den Bereich Web fällt, wie z.B. HTML-, JavaScript- oder CSS-Fragen ("Geht die Navigation auch rechtsbündig?")



  • Hallole Thomas,


    natürlich gebe ich mich damit zufrieden, weil es prima läuft! Das sagte ich ja bereits ;-).


    Ich verstehe es halt nur nicht: Die Sprungmarken gelten nur innerhalb dieser einen Seite; keine andere Page ist betroffen, und eine mit diesem Namen gibt es nicht.


    Auch will ich nicht, dass sich jemand mit dem Problem auseinandersetzt; ich dachte nur, dass jemand eine 'plötzliche Eingebung' hat, weil es trotzdem funktioniert - auch wenn es die verlinkte Seite gar nicht gibt.


    Wenn ich etwas nicht verstehe, werde ich unruhig. Im HTML kann dieser Verweis nicht funktionieren; und das verblüfft mich eben...


    Ein Artikel ist also nicht die kleinste Einheit, die von ZP angesprungen werden kann; außer halt im "Normalbetrieb". Ich freue mich daher, dass es für User, die die Grundfunktionen erweitern möchten, einige Möglichkeiten gibt: HTML, CSS usw.

    Dies nütze ich gerne aus und frage daher auch gerne mal das Forum.

    Dass es die Möglichkeit der ID-Vergabe gibt, ist superb und ermöglicht eine Menge, die ich jetzt umsetzen kann!


    Mein Anspruch wird tatsächlich erfüllt: dass ZP stabil ist und im Prinzip auch einfach zu bedienen. Ich selbst bin nicht so... *gg


    Und wenn ich herumprobiere, um einen Weg zu meinen Vorstellungen zu erfüllen und dabei meine Seite mutwillig zerstöre, dann hole ich ein Backup zurück und packe das Thema neu an. Für so etwas ist das Forum tatsächlich nicht da.


    Guten Rutsch! :-)