https und zwei Domains - auf einen Content weitergeleitet

  • Hallo Forum,


    vermutlich ist es eine "blöde" Frage - aber ich stelle sie einfach mal:


    Es existieren bei 1&1 zwei Domains - die mit der RewriteEngine auf einen Content zeigen.:


    Dadurch wird ja immer Domain-A aufgerufen (steht auch in Adresszeile) auch benn Domain-B eingegeben wird.


    JEtzt soll auf https umgestellt werden. Bei 1&1 ist ein ein Zertifikat inklusive - daher die Frage:


    Reicht das eine Zertifikat für die Domain-A ? und was muss in ZP beachtet werden ?


    Die SFTP-Konfiguration in ZP lauft natürlich auf die Hauptdomain A, es steht aber kein https bei der Webadresse davor ....


    Danke und Grüße


    Websven


    PS: es kommt nicht auf das Suchmaschinen-Ranking an ......

    Viele Grüße

    Sven :/

    ------------------------------------------

    Zeta Producer 14.3.0 Business

  • Hallo Sven,


    SSL-Zertifikat für die Domain A einrichten und in Zeta die Webadresse mit vorangestelltem https ergänzen (Domain A). Dann neu veröffentlichen und schon fertig. Der erste Aufruf auf Domain B leitet direkt auf Domain A weiter, die weitere Kommunikation findet dann nur noch zwischen Besucher und sicherer Domain A statt.

  • Ich würde die Weiterleitung dann nach Aktivierung von SSL wie folgt aktualisieren (damit gleich auf HTTPS weitergeleitet wird):

    Code
    1. RewriteEngine On
    2. RewriteCond %{HTTP_HOST} ^www.domain-A.de
    3. RewriteRule ^(.*)$ https://domain-A.de/$1 [R=301,L]
    4. RewriteCond %{HTTP_HOST} ^www.domain-B.de
    5. RewriteRule ^(.*)$ https://domain-A.de/$1 [R=301,L]
    6. RewriteCond %{HTTP_HOST} ^domain-B.de
    7. RewriteRule ^(.*)$ https://domain-A.de/$1 [R=301,L]
  • Hallo Thomas und Stefan,


    vielen Dank.

    Ich habe das Zertifikat jetzt aktiviert.


    Mal schauen, wie lange es jetzt dauert ....


    Grüße

    Viele Grüße

    Sven :/

    ------------------------------------------

    Zeta Producer 14.3.0 Business

  • Hallo nochmal,


    also so ganz verstehe ich das jetzt nicht. Ich habe die Weiterleitung jetzt wie von Stefan vorgeschlagen geändert.

    Habe dann im Firefox und Edge den Cache gelöscht, Browser geschlossen und geöffnet. Wenn ich jetzt Domain-A.de ohne www eingebe passiert nix. wenn ich dann das www davor setze, geht die weiterleitung auf https://domain-A.de. wenn ich dann wieder Domain-A.de ohne www eingebe funktioniert es mit dem https. Dies hab ich mal wiederholt, weil ich eigentlich immer alles ohne www eingebe.

    Hab ich jetzt ein denkfehler ? Ich hatte dann die htacces noch mal um die zeilen ohne www bei Domain-a.de ergänzt, dann wurde aber gleich ein Weiterleitungsfehler angezeigt, daher habe ich die zwei Zeilen wieder raus genommen ... dann war nach Cache-Löschung ohne www wieder nix mit https, bis einmal die Weiterleitung mit der anderen Schreibweise funktioniert hat :wacko:


    Bei der Domain-B.de funktioniert es wie es soll....


    Ich hatte gedacht, dass mit der Weiterleitung verstanden zu haben ;(


    Grüße

    Sven

    Viele Grüße

    Sven :/

    ------------------------------------------

    Zeta Producer 14.3.0 Business

  • Tante Google hat jetzt diese Seite gefunden.


    Nachdem ich jetzt noch


    Code
    1. RewriteCond %{SERVER_PORT} !^443$
    2. RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]

    hinzugefügt habe scheint es zu funktionieren ... :)


    Grüße

    Viele Grüße

    Sven :/

    ------------------------------------------

    Zeta Producer 14.3.0 Business

  • Guten Morgen,


    jetzt habe ich von einem anderen PC Domain-B.de aufgerufen, da kommt dann folgende Fehlermeldung:


    Code
    1. Fehler: Gesicherte Verbindung fehlgeschlagen
    2. Beim Verbinden mit Domain-B.de trat ein Fehler auf. Die Gegenstelle meldet, dass sie auf einen internen Fehler gestoßen ist. Fehlercode: SSL_ERROR_INTERNAL_ERROR_ALERT
    3. Die Website kann nicht angezeigt werden, da die Authentizität der erhaltenen Daten nicht verifiziert werden konnte.


    in der Adresszeile bleit dann natürlich auch https://Domain-B.de stehen - also die Weiterleitung funktioniert nicht. habe jetzt wieder

    Code
    1. RewriteCond %{SERVER_PORT} !^443$
    2. RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]

    entfernt. Wenn jetzt Domain-A.de noch nicht im cach steht bleibt http://Domain-A.de stehen. erst wenn mit http://www.domain-A.de die Weiterleitung auf https://Domain-A.de einmal durchlaufen ist, wird auch https://Domain-A.de aufgerufen ..... ||=O


    ISt es jetzt doch einfacher, auch für Domain-B.de ein Zertifikat einzurichten ? es gibt doch irgendwo die kostenfreien Zertifikate - obwohl es nicht an den Kosten scheitern dürfte.


    Danke und Grüße


    Sven

    Viele Grüße

    Sven :/

    ------------------------------------------

    Zeta Producer 14.3.0 Business

  • Hallo Sven,


    für Domain B würde ich folgenden Eintrag nehmen:


    Code
    1. # Beginn Umleitung auf eine andere Domain
    2. Redirect 301 / https://www.domain-a.de
    3. # Ende Umleitung auf eine andere Domain

    Weitere Umleitungen sind in Domain B nicht erforderlich, da dort keine Unterseiten existieren


    Bei Domain A sind 2 Umleitungen erforderlich, die sich aber nur auf den direkten Aufruf der Domain A beziehen (die Domain B wird immer auf https://www.domain-a.de umgeleitet)


    Mit dem ersten Abschnitt werden aufrufe von http://daomain-a.de auf https://www.domain-a.de weitergeleitet. Der zweite Abschnitt übernimmt dann die Weiterleitung von http://www.domain-a.de auf https://www.domain-a.de.

  • Hallo Thomas,


    das muss ich mal in Ruhe probieren - wahrscheinlich erst am WE. Aber Danke schon mal.


    Grüße

    Viele Grüße

    Sven :/

    ------------------------------------------

    Zeta Producer 14.3.0 Business

  • Hallo Thomas,


    kann es sein, dass bei dem Redirect 301 /https://www.domain-a.de ein Leerschritt hinter dem ersten / fehlt ?

    Kann ich Dir ein EMail zum WE hin senden ? Da würde ich die KlarNamen der Domains nennen, die sollen vom Seiteninhaber hier nicht genannt werden.


    Grüße

    Sven

    Viele Grüße

    Sven :/

    ------------------------------------------

    Zeta Producer 14.3.0 Business

  • Hallo Thomas,


    irgendie hat es doch nicht so ganz funktioniert und internal-Servererror produziert - aber nicht immer. Leider hab ich den Überblick verloren, unter welchen Bedingungen die aufgetreten sind. Mein htaccess sieht jetzt so aus:


    Wie gesagt, beide Domains sind auf ein Verzeichnis bei 1&1 konnektiert. Ist leider so "gewachsen" - eigentlich hätte eine Domain ja genügt .....


    Der Aufruf beider Domains mit und ohne www funktioniert jetzt und landen auf https://Domain-A.de


    Wenn es Dich interessiert schicke ich Dir eine Mail mit "Hintergrundinformationen" und den Domainnamen :)


    Danke für die Mühe, die ich Dir gemacht habe und schon mal ein schönes WE


    Sven

    Viele Grüße

    Sven :/

    ------------------------------------------

    Zeta Producer 14.3.0 Business