CMS Anmeldung friert ein, nach Umzug

  • Hallo,


    ich habe viel gelesen und doch nicht das Richtige gefunden.

    Aber zum Glück weiß das Forum hier alles ^^.

    Ich habe eine Testseite für einen Kunden erstellt (ohne https), also einer Subdomain.

    Nun habe ich diese auf die eigentliche Domain umgezogen (mit https:), und die .htaccess Datei hinein kopiert.

    Einfach den kompletten Inhalt markiert und in das neue Verzeichnis kopiert, damit die CMS EInträge mit übernommen werden, was auch geklappt hat.


    Wenn ich die Seite zum Bearbeiten aufrufe, wird diese jetzt aber geblockt und ich muss diesen Block aufheben.

    Dann kommt das Passwort Fenster. Hier gebe ich das Passwort ein und es passiert danach nichts mehr. Ich kann kein OK, Abrechen oder sonstiges eingeben.

    Sie Seite friert ein (und das bei dem schönen Wetter)

    Lösche ich aber die .htacces Datei, funktioniert das Einloggen wieder und kann im CMS arbeiten.


    What kän ei du, wenn ich das wärrie richtig maken will ? :-)

  • Hallo Markus,


    wenn ich Dich richtig verstehe, hast Du über Filezilla alle Ordner und Dateien aus dem Verzeichnis /sub.test nach /kunde-real kopiert, um die Inhalte des Online-CMS zu übernehmen. Damit auch die .htaccess, die für /sub.test geschrieben wurde und nicht für /kunde-real. Bei dem von Dir geschilderten Verfahren werden vermutlich durch die .htaccess Seitenaufrufe von kunde-real.de/beispiel.html nach /sub.test.de/beispiel.html weitergeleitet.


    Das "Einfrieren" der Seite, also eine weiße Seite, ist ein typisches Zeichen für eine unter http veröffentliche Webseite, die über https aufgerufen wird. Die Seite online-cms.php versucht dann auf Dateien zuzugreifen, die unter http://kunde-real.de liegen, was aber (wegen fehlendem "s") eine unsichere, und deshalb nicht erlaubte Aktion ist.


    Bei einem Umzug auf eine andere Domain ist lediglich die Webadresse in den FTP-Einstellungen von Zeta zu ändern (https:// nicht vergessen), danach vollständig zu veröffentlichen und lediglich der Inhalt des Ordners CMS_Data manuell vom alten auf den neuen Server zu kopieren. Siehe auch Umzug von CMS Seiten

  • Hallo,


    erst mal vielen Dank für die Antwort.

    Auf der Subdomain (Testseite für den Kunden), habe ich keine htaccess gehabt.

    Ich habe den kompletten Inhalt von A nach B kopiert und dann auf B nachträglich die htaccess Datei hinein kopiert.


    Ich habe jetzt aber genau nach Anleitung von Dir gehandelt und, was soll ich sagen.....klar hat es funktioniert.

    Also den Inhalt gar nicht erst von A nach B kopiert, sondern die FTP Einstellungen im Programm geändert. Die htaccess Datei erst in das neue Verzeichnis hinein kopiert, wobei das vermutlich keine Rolle spielt, wann ich diese einbinde, dann den Inhalt komplett hochgeladen. Anschließend den CMS_DATA Ordner manuell von A nach B kopiert.

    Jetzt wird auch nichts mehr geblockt.


    Ich hatte das schon unter dem von Dir geschriebenen Link gelesen gehabt aber nicht ganz verstanden.


    Ich bin schon wieder begeistert und das schon am frühen Morgen.


    Vielen Dank noch mal und mal wieder ein fettes LOB.


    Noch einen schönen Tag und alles was dazu gehört.