Zeta 15 und schwarzer (weißer) Bildschirm im Bearbeitungsbereich

  • Guten Tag in die Runde,


    ich setzte (derzeit noch als Demo) die Version 15.01 ein, um damit meine neue Homepage zu gestalten. Bis zur Version 14 klappte das perfekt. Mit dem Update auf die Version 15 passierte folgendes:

    Ich arbeite an irgendeiner Seite, die (ich bin Fotograf) einige Bilder enthält, z.B. als Galerie oder auch Slideshow. Ich gebe Text ein, alles gut. Ich füge ein Bild ein, alles gut. Ich wechsle auf eine Seite mit einem Slider. Schaue und tippe dort vielleicht noch ein wenig an diesem oder jenem und völlig unvermittelt und NIE an den selben Stellen bleibt das Bearbeitungsfenster (in meinem Fall) schwarz.

    Zeta läuft zwar noch. Ich kann auf eine andere Seite wechseln, sehe, wie diese geladen wird und dann ist auch hier der Bearbeitungsausschnitt schwarz (weiß).

    Nächste Seite, wird geladen, kurz angezeigt. Schwarz. Völlig egal, welche Seite ich anklicke.

    Es hilft dann nichts. Neu starten und hoffen, dass es lange gut geht. Aber wirklich arbeiten kann man so nicht.


    Meine Systeme:
    Zeta 14 (perfekt) auf einem Win 10 Rechner mit 8GB RAM > Update > Fehler tritt mit Version 15 auf.

    Zeta 15 auf den "großen" gepackt. Win 7 mit SP2, alles auf dem neuesten Stand, System auf SSD mit genügend Platz, Zeta-Daten auf HDD mit 1 TB, 200 GB frei, 16 GB RAM. Meine Hoffnung: Mehr Speicher, schneller Prozessor (8x), NVidea Grafik GT 420 mit neuesten Treibern. Hilft nicht, Fehler tritt auch auf diesem Rechner auf.


    Hat jemand eine Idee?

    Hier ein Link zu einem kleinen Video, damit man sieht, was passiert.

    https://drive.google.com/open?…ICrtmCosxWHF-Ux2rJDzv2cuW

    Vielen Dank.

    Christian Blanke

  • Hallo Herr Blanke,


    danke für die ausführlichen Infos und das Video. Einen solchen Effekt haben wir noch nie beobachtet und auch noch von keinem anderen Kunden berichtet bekommen.


    Frage: Wenn Sie mal ein ganz neues Projekt zum Testen erstellen, tritt der Effekt dort dann auch auf? So können die Ursache evtl. etwas eingrenzen.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Hallo Steffen,

    ich habe eine neue WebSite erstellt. Ich kann natürlich den Effekt nicht provozieren. Auch konnte ich mit meinem Projekt den leeren Bildschirm heue noch nicht erzeugen. Klar, Vorführeffekt. Gestern wollte ich die Fertigstellung meiner WebSite forcieren, um endlich mal fertig zu werden. Da konnte ich nicht arbeiten. Sicher an die 5 mal habe ich Zeta bzw. den ganzen Rechner neu gestartet, danach habe ich ziemlich frustriert aufgehört und das Handtuch geschmissen.

    Ich beobachte das mal weiter. Schaue, wann der Effekt erstmals auftritt, wenn er auftritt.

    Gruß
    Christian Blanke

  • Ok, danke für die Rückmeldung.


    Haben Sie evtl. externen Code in der Website? Irgendein Javascript oder externe Widgets?


    Wenn ich das im Video richtig sehe, dann haben Sie oben einen Slider auf den Seiten. Ich könnte mir vorstellen, dass dieser den Effekt erzeugt. Falls das Verhalten nochmals auftritt, dann mal den Slider testhalber deaktivieren oder auf einer Seite mal löschen und prüfen, wie es sich dann verhält.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Hallo,

    hier ein Update, um 09:51h ist der Fehler wieder aufgetreten. Folgendes habe ich gemacht:

    Auf einer Seite ist ein vollformatiger Slider mit 5 Fotos. Am ersten habe ich den Text ergänzen wollen, was auch noch geklappt hat. Speichern, Verarbeitung läuft, kurzes Aufblitzen der Seite. Weiß ... Danach war Schicht im Schacht.

    Ich habe schon länger den Verdacht, dass Zeta mit vielen Fotos nicht gut umgehen kann. Es verschwinden aus Karussel oder Slider auch schon mal Fotos, wenn man nur eines hinzufügt und ggf. noch verschiebt.

    Externe Widgets, nicht, dass ich wüsste. Eigenen Code durchaus. Und etwas eigenes CSS. Das ist aber nix dolles... Ich krame das mal raus und schreib es hier rein.

    Update:
    Hier der CSS-Code:


    <style type="text/css">


    h1, h2, h4, h5, h6 {

    border-bottom: 1px dotted #690000;

    }


    .left { text-align:left; }

    .right { text-align:right; }

    .center { text-align:center; }


    media screen and (max-width: 1206px) {


    .right { text-align:left; }

    .center { text-align:left; }



    .footerbox {

    clear: left;

    padding: 1em;

    margin: 5px;

    float: left;

    width: 32%;

    min-width: 360px;

    height: auto;

    min-height: 210px;

    padding: 1em;

    box-sizing: border-box;

    background-color:#f3f3f3;

    position: static;

    box-shadow: 10px 10px 10px 10px #f0f0f0;

    }


    } /* Ende media screen and (max-width: 768px) */


    .footerbox {

    clear: right;

    padding: 1em;

    margin: 5px;

    float: left;

    width: 32%;

    min-width: 360px;

    height: auto;

    min-height: 210px;

    padding: 1em;

    box-sizing: border-box;

    background-color: #f3f3f3;

    position: static;

    }


    .footerbox:last-child {

    margin-right: 0;

    }



    .slider100 {

    height:100vh;

    margin-top:-120px;

    text-align: button;

    }


    media (max-width: 1330px) {

    .slider100 {

    height: auto;

    margin-top: -100px;

    }}

    .zp15slider-caption a {

    border-radius: 10px;

    display: inline-block;

    color: rgba(0,0,0,0.7);

    text-shadow:

    0 4px 4px rgba(255,255,255,0.6),

    0 15px 6px rgba(0,0,0,0.7);

    font-size: 42px;

    transform: scaleX(3.5);

    text-decoration: none;

    transition: all 0.3s ease-in-out;

    }

    .zp15slider-caption a:hover {

    color: rgba(0,0,0,0.7);

    text-shadow:

    0 4px 4px rgba(255,255,255,0.6),

    0 24px 4px rgba(0,0,0,0.7);

    }


    </style>



    Attribut "Body-Start"


    <style type="text/css">


    .back-to-top {

    position: fixed;

    bottom: 2em;

    right: 0px;

    text-decoration: none;

    color: #000000;

    background-color: rgba(178, 0, 0, 0.6);

    font-size: 12px;

    padding: 1em;

    display: none;

    z-index: 10001;


    }

    .back-to-top:link {

    color: white !important;

    }


    .back-to-top:hover {

    background-color: rgba(178, 0, 0, 1);

    color: white !important;

    }

    </style>


    <script>

    jQuery(document).ready(function() {

    var label = 'nach oben';

    var offset = 120;

    var fadedur = 800;

    var duration = 1000;


    $('body').append('<a href="#-1" class="back-to-top">'

    + label

    + '</a>');


    $(window).scroll(function() {

    if ($(this).scrollTop() > offset) {

    $('.back-to-top').fadeIn(fadedur);

    } else {

    $('.back-to-top').fadeOut(fadedur);

    }

    });


    $('.back-to-top').click(function(event) {

    event.preventDefault();

    $('html, body').animate({scrollTop: 0}, duration);

    return false;

    })

    });

    </script>



    <style type="text/css">


    media screen and (max-width: 768px) {


    .telefon {

    position: fixed;

    height: 50px;

    width: 50px;

    top: 8px;

    left: 1.5em;

    text-decoration: none;

    background-color: none;

    background-image: url("oid://image/telefon-symbol-rund");

    background-repeat: no-repeat;

    background-size: cover;

    display: none;

    padding: 0em;

    z-index: 10001;

    }


    .telefon:link {

    color: white !important;

    }


    .telefon:hover {

    color: white !important;

    }


    } /* Ende media screen and (max-width: 768px) */

    </style>


    <script>


    jQuery(document).ready(function() {

    var label = '';

    var offset = 80;

    var fadedur = 400;

    var duration = 800;



    $('body').append('<a href="tel: +492525950929" class="telefon">'

    + '</a>');


    $(window).scroll(function() {

    if ($(this).scrollTop() > offset) {

    $('.telefon').fadeIn(fadedur);

    } else {

    $('.telefon').fadeOut(fadedur);

    }

    });



    });

    </script>



    Attribut "Copyright-Notice"


    <div class="footerbox">

    <p class="left">

    <strong>Kontakt:<br />

    </strong>Christian Blanke Fotografie<br />

    Nienkämpe 27<br />

    59269 Beckum<br />

    <br />

    T: +49 (0) 25 25 / 95 09 29<br />

    info@foto-blanke.de<br />

    </p>

    </div>


    <div class="footerbox">

    <p class="center">

    <strong>Copyright:<br /> </strong>

    <script type="text/javascript" language="JavaScript">

    DatumAktuell = new Date();

    JahrAktuell = DatumAktuell.getFullYear();

    document.write("&copy; 2005-"+ JahrAktuell + "<b><br>Christian Blanke Fotografie</b>");

    </script>

    <br />

    <br />

    Die Verwendung jedweder Inhalte, insbesondere der Fotos, bedarf unserer schriftlichen Zustimmung.

    </p></div>


    <div class="footerbox">

    <p class="right">

    <a href="http://www.facebook.com/pages/Christian-Blanke-Fotografie/386341048045186" target="_blank"><img class="no-border" src="oid://image/facebook-logo" alt="Folgen Sie mir auf Facebook" title="Folgen Sie mir auf Facebook" width="50" height="50" /></a>


    <a href="https://www.instagram.com/christianblanke.photo/" target="_blank"><img class="no-border" src="oid://image/insta-logo" alt="Folgen Sie mir auf Instagram" title="Folgen Sie mir auf Instagram" width="50" height="50" /></a>


    <a href="http://www.youtube.com/channel/UCF-DR8ctXpQPlauBWFDdw3Q" target="_blank"><img class="no-border" src="oid://image/youtube-logo" alt="Folgen Sie mir auf YouTube" title="Folgen Sie mir auf YouTube" width="50" height="50" /></a>

    <p></br></br></p>


    </p>

    </div>

  • Ich vermute auch, dass es an irgend etwas im "eigenen code" liegen könnte. Mit scheint z.B. text-align: button; fehlerhaft zu sein. Was helfen könnte:


    Sie können in Zeta Producer seit Version 15 auch Entwickler-Tools nutzen. Blenden Sie diese mit F12 ein und lassen Sie sich die "Console" anzeigen. Wenn das Display dann auf weiß umschaltet, sehen Sie da in der Console ggf. irgendwelche Fehlermeldungen?

  • Ggf. auch mal das komplette CSS mal temporär entfernen und testen, ob der Fehler dann noch auftritt… Wenn die Vorschau weiß bleibt lassen sich die Inhalte übrigens bei Bedarf noch in der Spaltenansicht bearbeiten auf die man mit F8 umschalten kann (um z.B. den Slider zu deaktivieren und zu sehen, ob das das die weiße Vorschau wieder behebt). Nochmals F8 schaltet wieder auf die Vorschauansicht.


  • Hatte auf den Button geklickt, um zu sehen, was passiert. Die Ansicht wurde von weiß wieder aufgebaut, so dass ich was sehen konnte. Dann bin ich auf eine andere Seite gegangen. Diese war noch vollständig zu sehen. Ich konnte die Elemente anklicken, als schon wieder der Fehler auftrat. Nach dem Neustart war das zuletzt angeklickte Element verschwunden und lässt sich auch nicht mehr wiederfinden.

  • Oha, da stürzt anscheinend der eingebettete Chrome-Browser komplett ab. Das müssen wir versuchen zu reproduzieren. Können Sie mir bitte Ihr Projekt senden und mir sagen auf welcher Seite dieser Fehler aufgetreten ist?


    1. Öffnen Sie Ihr Projekt in Zeta Producer
    2. Gehen Sie auf das Menü "Extras"
    3. Klicken Sie auf den Button "Optionen"
    4. Klicken Sie auf "Aktionen"
    5. Klicken Sie rechts auf die Aktion "Projekt Senden" damit diese Markiert ist
    6. Klicken Sie unten auf den Button "Ausführen"
    7. Geben Sie im 1. Feld Ihre E-Mail-Adresse ein, damit wir Sie für Rückfragen kontaktieren können
    8. Geben Sie als Referenz ins Feld Bemerkungen den Link zu diesem Forum-Artikel ein (per Kopieren und Einfügen)
    9. Klicken Sie auf den Button "Senden"
  • PS: haben Sie schon versucht etwaige Virenscanner oder Sicherheitstools mal temporär zu aktivieren um zu versuchen, ob das den Fehler vermeidet?

  • Oh je, 495 MB, das dauert Stunden. Telekom und Co gönnen uns hier nur max. 1,1 MBit Upload und max. 9 MBit download. Zeta meldet ca. 2,5 Stunden.

    Ich halte dann mal Mittagsschlaf.

    Ich meine mich zu erinnern, dass ich "Portrait" angeklickt hätte. Nochmals der Hinweis: Ein Bildelement oberhalb von "Pass- und Visafotos" ist weg und bei den Themenschwerpunkten gab es einen Slider. Der ist auch weg. Warum auch immer. Gelöscht habe ich ihn nicht.

  • Mein Beileid! Lassen Sie die Übertragung einfach mal laufen. Hatten Sie bereits mal alles eigene CSS entfernt? und trat der Fehler dann auch auf?

  • Nein, habe ich nicht. Wie erwähnt, lief das, so wie es ist, in Zeta 14 top. An dem ganzen Projekt habe ich nicht mehr gearbeitet, weil es ständig Probleme gab mit Z15. Dann war Urlaub, dann muss man ja auch mal arbeiten und Geld für neue Software verdienen ;-) , und jetzt, wo ich Zeit hätte, läuft es nicht.

    By the Way... Im Momenthabe ich 0,07 MB/sek. Ich denke, WeTransfer wäre schneller. Gibt es eine Mailadresse, wo ich das hinschicken kann. Und was muss ich schicken? den gezippten Projektordner komplett?

  • Nein, das geht wegen der Dateigröße nur über das eingebaute Tool. Sie können das auch gerne abbrechen und erstmal den test mit entferntem CSS machen. Version 15 hat für die Vorschau einen komplett anderen Mechanismus als Version 14 und ist daher nicht vergleichbar. Kann durchaus sein, dass Version 15 auf Syntax-Fehler anders reagiert. Ich würde das mit dem entfernen des eigenen CSS zunächst mal testen und das Projekt dann über Nacht senden lassen.

  • Hallo,


    ich kann das im zugesandten Projekt nachvollziehen. Ursache sind sehr große Bilder, die sich aufsummieren. Da geht der Browser dann schon mal in die Knie. Ich bezweifle, dass wir da was am Programm ändern können. Es wäre besser Sie organisieren Ihre Inhalte etwas anders, dann lädt auch die Seite viel schneller. Momentan sind die Bilder so groß, dass das Laden auf mobilen Engeräten nicht performant ist.


    Haupt-Übeltäter ist das Seiten-Hintergrundbild, das Sie in den Layou-Einstellungen zugewiesen haben. Das ist über 8MB groß!

    Dann folgen Bilder im PNG-Format, mit transparenzen, die in Headern und Slidern genutzt werden. Auch hier wären reduzierte Bilder ohne Transparenz im JPG-Format ggf. besser.


    Ich würde mal damit beginnen, das Seiten-Hintergrundbild einfach zu entfernen, vielleicht tritt der Fehler dann schon nicht mehr auf.

  • Hallo,

    danke für den Tipp, ich probiere es gleich mal aus. Ich bin davon ausgegangen, dass Zeta ähnlich arbeitet, wie mein altes Programm. Dort wurden die Bilder im Original in einer Ressourcen-Bibliothek abgelegt, von wo ich sie irgendwohin im Projekt habe einfließen lassen. Allerdings unterstützt das alte Prog kein Wysiwyg. Bei einer Vorschau werden die Bilder passend generiert, also z.B. aus einem 8 MB Bild mit großer Kantenlänge wird eines gemacht, was den Hintergrund ausfüllt, max. Full-HD.

    Ich schau mal zu. "Again what learned", wie der Dortmunder sagt. ;-)

    In diesem Sinne...

    Wenn noch was ist, darf ich mich melden?!

    Gruß
    Christian Blanke

  • Das machen wir bei Bildern, die im Inhaltsbereich platziert werden auch, aber nicht bei den Hintergrundbildern, die im Layout-Editor ausgewählt werden. Grund ist, dass ein Browserfenster keine feste Größe hat und der Benutzer daher besser selbst entscheidet, was die korrekte Größe ist um eine entsprechende Quslität zu gewährleisten. Und die PNG-Bilder, die Sie in den Headern/Slidern nutzen sind halt grundsätzlich größer als entsprechende JPG-Bilder und wenn dann noch eine Transparenz ins Spiel kommt, muss der Browser beim Rendern halt sehr viel mehr arbeiten… Klar, Sie dürfen sich jederzeit hier melden.