Warenkorb Button funktioniert nicht mehr

  • Guten Abend,


    ich verwende den Highlight-Artikel auf meinen Produktseiten, leider funktionieren diese nicht mehr.

    Beim anklicken wir man auf die Warenkorbseite weitergeleitet "Es befinden sich keine Artikel in Ihrem Warenkorb"


    Hat es seitens zeta im Highlight-Artikel irgendwelche Anpassungen gegeben?

  • Hallo Marc,


    nach meiner Kenntnis nicht. Unter der aktuellen 15.1.0 funktioniert das Einkaufen über Highlight-Artikel, siehe https://www.hanabi-pirna.de/test.php?variant-id=338


    Ich tippe da eher auf die veraltete PHP-Version 5.6, die auf dem Server läuft. Die aktuelle Zeta-Version ist ausgelegt auf die PHP-Generation 7, also aktuell 7.2 und 7.3. Stelle mal die PHP-Version um und teste dann erneut. Ich habe leider keine Domain mehr mit extended Support für PHP 5.6, der müsste im Übrigen auch inzwischen kostenpflichtig sein.

  • Hallo Thomas,


    danke für den Tipp, das habe ich jetzt umgestellt. Hab mir gerade mal die Codes angeschaut, da hat sich einiges getan. Da ich meinen Highlight-Artikel kopiert habe war der natürlich von dem Update ausgenommen. Ich werde jetzt mal provisorisch die Seite veröffentlichen, so dass der Warenkorb wieder funktioniert und morgen werde ich das in den Codes mal abändern.

  • Guten Morgen,


    konnte den Fehler lokalisieren, aus irgenwelchen Gründen auch immer hat es mir das java-script file "shop-article" herausgelöscht. Kann mir das aber leider nicht erklären, da ich den Highlight-Artikel schon seit Monaten nicht mehr bearbeitet habe.


    Ebenfalls sind zwei java-script files und ein pdf file welche unter Dateine abgespeichert waren seit dem Update auf 15.1 herausgelöscht worden. Bei der großen Anzahl der Bilder welche ich eingebaut habe, fehlt mir allerdings gerade der Ansatz diese auf Vollständigkeit zu überprüfen.

  • Das java-script file "shop-article" Projekte > Taste of Koroni > Widgets


    Die beiden javascript files und das pdf - Erweitern > Dateien > (Seltsam war, dass die Dateien aufgeführt waren, aber keine Größe hatten.

    Zahnrad > Eigenschaften > Datei > Datei anzeigen = kein file vorhanden.