Der 'Microsoft.ACE.OLEDB.12.0'-Provider ist nicht auf dem lokalen Computer registriert.

  • Guten Morgen,

    soebne wurde ein kostenloses Update installiert mit dem Ergebnis, dass Zeta nicht mehr funktionier

    Wo liegt das Problem?

    MDG

    bro



    System.InvalidOperationException


    -----------------


    Der 'Microsoft.ACE.OLEDB.12.0'-Provider ist nicht auf dem lokalen Computer registriert.


  • Hallo,


    Ursache ist, dass das 64-Bit-Access-Setup nicht installiert wurde.


    Bitte mal im Verzeichnis "C:\Users\*UserName*\AppData\Local\Zeta Producer 15\Applications\" die Datei "AccessDatabaseEngine_X64.exe" ausführen.


    Wurde das Problem damit behoben?

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Hallo zusammen,


    ich hatte das selbe Problem und habe nun die AccessDatabaseEngine_X64.exe gestartet. Die Installation bricht ab, weil ich 32bit Office-Produkte installiert habe. Ich möge diese bitte deinstallieren, sagt die Fehlermeldung .... Das habe ich nicht vor. Es geht um Office 2010. Was tun?


    Viele Grüße


    Gerhard

  • Hallo zusammen,

    ich habe zurzeit das gleiche Problem und hänge sehr an meinen Office 2007 Produkten. Ich bin über alle Hinweise zur Lösung dankbar!

  • Ich verwende auch Office 2010. Davon gibt es auch eine 64 Bit Version.

  • Hinweis! Falls der Fehler durch das Installieren der Access-Database-Engine nicht behoben werden kann, dann bitte vorläufig wieder die Zeta-Producer-Version 15.1.1 installieren und diese verwenden bis wir den Fehler behoben haben. Sorry und Danke für das Verständnis.


    Download Zeta Producer 15.1.1: https://ft.zeta-software.de/465426201

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Ich habe mir inzwischen für kleines Geld eine Version Office Professional Plus 2010 32/64 bit gekauft, mein Outlook gesichert, das alte Office entfernt und das neue 64 bit installiert. Inzwischen funktioniert alles wieder inkl. Easy2sync for Outlook (ohne es neu zu installieren). Zeta Producer geht auch. Ich hatte zwar heute was anderes vor, bin aber froh, dass ich jetzt alles auf der Reihe habe. Danke für die Hilfe!


    Viele Grüße


    Gerhard

  • P.S. Ich habe nach dem Entfernen des alten Office erst die Access-Database-Engine aus dem Zeta-Producer-Verzeichnis installiert, dann lief Zeta Producer. Dann habe ich erst das neue Office installiert. Falls das irgendwie von Wichtigkeit sein sollte ...

  • Ich habe die 15.2. vor einigen Tagen installiert und stieß dabei ebenfalls auf das oben beschriebene Problem. Alle oben genannten Lösungsvorschläge brachten keinen Erfolg, und ich habe mich in Geduld geübt.


    Da ich wenig Lust auf eine Deinstallation verspürte und zudem wichtige Änderungen an der Seite vornehmen muss, habe ich noch einen weiteren Anlauf gewagt. Soeben habe ich über die nicht funktionierende Installation das Update nochmals drübergebügelt. Einziger Unterschied zur ersten Installation: Rechtsklick auf die zp15-setup.exe und „Ausführen als Administrator“. Die Installation lief vollständig durch, das Projekt wurde konvertiert und alles scheint zu laufen.


    Hinweis: Laut Protokoll wurden in den letzten Tagen keine Updates für Office-Produkte oder Windows installiert.


    System:


    Windows 10 64 bit

    MS Outlook 2007

    MS Visio 2003

  • Ich war ebenfalls betroffen und habe nun alles so eingerichtet wie beschrieben. Also mit Patch auf 32-Bit und Deinstallation MDAC.

    Meine Frage ist nun: Passiert dies in Zukunft bei jedem Update von Producer?


    MfG

    Steffen

  • Hallo Steffen,


    ich denke, nein. die Entwickler von Zeta waren sicherlich auch überrascht, auf wie vielen Rechnern unter einem 64-er Betriebssystem Office in 32-Bit lief. Das sollte bei künftigen Versionen Berücksichtigung finden.

  • Hallo Steffen,


    ich denke, nein. die Entwickler von Zeta waren sicherlich auch überrascht, auf wie vielen Rechnern unter einem 64-er Betriebssystem Office in 32-Bit lief. Das sollte bei künftigen Versionen Berücksichtigung finden.

    Auf dem Datenträger von MS-Office 2010 zum Beispiel sind ja die 32 und 64 Bit Varianten vorhanden. Warum bei der Installation auf einem 64-Bit Betriebssystem automatisch die 32-Bit Version installiert wird, ist mir auch nicht klar. Um die 64-Bit Installation durchzuführen, muss man manuell die 64-Bit Setup-Datei auf dem Datenträger auswählen.