Sicherung regelmäßig durchführen!

  • Hallo,


    immer wieder kommt es zu Problemen, da Projekte verschwinden bzw. "zerstört" werden und nicht mehr wiederhergestellt werden können. Wie allgemein in der EDV gilt es auch bei Zeta Producer, dass Daten gesichert werden sollten (müssen). Am Leichtesten geht dies mit dem einfachen Kopieren aus dem Explorer heraus. Zum Sichern eines Projekts müssen nur zwei Ordner (z.B. auf einen USB-Stick, externe Festplatte, Webspace,...) gesichert (kopiert) werden:

    • ...Dokumente und Einstellungen\Benutzername\Eigene Dateien\Zeta Producer Desktop 9\Projects\Mein Projekt
    • ...Dokumente und Einstellungen\Benutzername\Eigene Dateien\Zeta Producer Desktop 9\Layouts\DEU\Mein Layout

    Empfehlenswert wäre es, nach jeder Änderung die Dateien zu sichern, so dass der Letztstand vorhanden ist. Ansonsten kann nur noch der Inhalt der Online-Webseite in die Artikel kopiert werden und die Bilder müssen mühevoll importiert werden. Das Rücksichern erfolgt, durch das Kopieren in den entsprechenden Verzeichnissen (auch nach einer Neuinstallation).


    Alternativ gibt es die Möglichkeit, die Sicherungsfunktion von Zeta Producer zu aktivieren und das Projekt am Webserver abzulegen (die Funktion ist standardmäßig nicht aktiviert). Bei großen Projekten kann die Datenübertragung sehr lange dauern und entsprechend Webspace in Anspruch nehmen. Die Sicherung kann aktiviert werden durch:

    • Webseite -> ... Sicherheitskopien konigurieren -> Konfigurieren... -> Ja, Zeta Producer soll regelmäßig Sicherheitskopien erstellen und Vorlagenprojekte mitsichern! (Standard setzen)

    Die Sicherungsdatei liegt dann als ZIP-File vor.

  • Ich weiß nicht was geschehen ist, aber durch irgendeine Veränderung ist meine Website weitgehendst abgestürzt. Das Layout ist verschwunden (ist aber nicht das Problem, kann wieder hergestellt werden), Texte sind auch noch vorhanden, lediglich die Grafiken werden in der Vorschau nicht mehr angezeigt. Im Bearbeitungsmodus sind diese aber noch da. Wo könnte der Fehler liegen?
    Ein Backup habe ich letzte Woche auch erstellt, nur habe ich da so meine Probleme. Die Zip-Datei extrahieren ist kein Problem, aber wo soll ich die extrahierten Dateien hochladen? Nach dem extrahieren sind nur die Ordner Database-Dump und Web mit seinen Unterordnern vorhanden. Dies ergibt für mich keinen Sinn. Ich arbeite mit ZP 9. Vielen Dank für die Unterstützung.
    Peter Druschba

  • Hallo,


    anscheinend dürften nicht alle Daten gesichert worden sein. Die Standardeinstellungen bei ZP9 und bei ZP10 sichern nicht alles z.B. der Ausgabeordner fehlt. Die entzippten Dateien müssen in den Ordner ....Dokumente und Einstellungen\Eigene Dateien\Zeta Producer 9\Projects\Dein Projekt bzw. (Windows 7) ...Dokumente\Eigene Dokumente\Zeta Producer 9\Projects\Dein Projekt zurückgespielt werden und du musst alle Seiten nochmals erstellen lassen (am Besten vorher den internen Cache von ZP löschen) damit der Ordner Ausgabe (ist jener der ins Web kopiert wird) neu erstellt werden kann.


    Am Besten wäre es gewesen, wenn du der Sicherungsanleitung mit einem anderen Verzeichnis oder USB-Stick gefolgt hättest, dann wäre dein Projekt innerhalb 1er Minute wiederhergestellt gewesen.


    Gruß Robert

  • Danke für die Antwort, werde es versuchen. Es wäre mir aber lieber gewesen, den Grund zu erfahren warum die Grafiken im Bearbeitungsmodus erscheinen und in der Vorschau fehlen. Das muss doch eine ursache geben?
    Schönen Gruß Peter Druschba

  • Es könnte sein das ZP in der Vorschau auf die Bilder des Ausgabeordner zurückgreift und daher nichts anzeigt, wenn dieser fehlt. Bei der Bearbeitung könnte ZP dann auf seine internen Kopien zurückgreifen, so dass diese bei der Bearbeitung vorhanden sind. Dies wäre eine Erklärung für mich.


    Schau bitte mal nach, ob du den Ordner Ausgabe hast und ob darin auch alle Bilder sind. Wenn nicht, das Projekt nochmals erstellen, mit allen Kopien von Dateien und Ordner (die Parameter sind anzuklicken) und dann probieren, ob in der Vorschau dann die Bilder vorhanden sind.


    Gruß Robert

  • Der Ordner Ausgabe ist schon da. Was mir aufgefallen ist, daß das Projekt bei den vorhandenen Webprojekten (ZP9) nicht da ist und ich es eigentlich von hier aus gar nicht aufrufen kann. Aufrufen kann ich es nur über "zuletzt verwendete Webprojekte". ?. Es ist aber definitiv da unter "C:\Dokumente und Einstellungen\Druschba\Eigene Dateien\Zeta Producer Desktop 9\Projects\Kopie von Gnadenhof" Könnte da irgendwo der Fehler zu suchen sein?
    Schönen Gruß Peter Druschba

  • Hallo,


    auch meine aktuellen Projekte sind unter "zuletzt verwendete Webprojekte" auffindbar. Anscheindend sortiert ZP9 die Projekte. Importierte Projekte erscheinen unter "Webprojekte" und wenn sie bearbeitet werden "rutschen" sie nach "zuletzt....".
    Dein Projekt sollte aus folgenden Ordnern und Dateien bestehen:


    \Ausgabe .............................. Ordner der ins Web kopiert wird und deiner Webseite entspricht
    \Layouts ................................ ist standardmäßig leer
    \Temp ..................................... ist standardmäßig leer
    \Vorlage Standard .................. hat die Unterordner \_media und \templates und die Datei template.mdb (entspricht der Ordnerstruktur eines Layouts)
    \Web ....................................... hat den Unterordner \media der wiederum \files und \images hat (bei files und images sind alle deine importierten Bilder nochmals vorhanden, jedoch kodiert). Weiters muss im Stammverzeichnis dieses Ordners noch die Datenbank web.mdb befinden in dem sich die Projektdaten befinden.


    Beim "Erstellen" -> Vorschau -> Webseite erstellen (konfigurierbar) ist rechts neben dem Buch ein Pfeil-Button. Dort "Zwischenspeicher zur Seitenerstellung leeren" und "Erstellen Liste leeren" anklicken, dann Seiten-Optionen und "Ausgewählte Seite und alle Unterseiten als geändert markieren", dann "Bilder-Optionen" alle Bilder als geändert markieren, dann "Datei-Optionen" alle Dateien als geändert markieren , Alle Ordner kopieren und alle Vorlagendateien kopieren oben anklicken (Bilder und Dateien könnten auch hier aktiviert werden). Anschließend das Projekt neu erstellen.


    Bitte zukünftig die Sicherungsanweisung durch das Kopieren z.B. auf USB-Stick durchführen - kostet nur ein paar Minuten, erspart aber viele Stunden an Nacharbeit, da ZP9 standardmäßig den Ausgabeordner und das Layout nicht sichert.


    Gruß Robert

  • Irgendwie scheint alles so zu sein wie oben beschrieben, aber irgendwo muss ein Fehler sein und ich kann ihn nicht beheben. Ich habe in gutem Glauben auch die Sicherungen durchgeführt "eine Sicherheitskopie sollte erstellt werden. Möchten Sie die Sicherheitskopie auführen" . Das hab ich dann auch gemacht. Dass dies nicht ausreicht um verloren gegangene Daten wieder herzustellen konnte ich doch nicht wissen. Da die Seite im Internet noch einigermassen vorhanden ist wäre meine Frage ob es möglich ist, die Website wieder downzuladen um es anschliessend als neues Webobjekt im ZP zu integrieren?
    Schönen Gruß Peter Druschba

  • Hallo Druschba,


    dies ist leider nicht möglich.
    Sie können die Inhalte von Ihrer Homepage rauskopieren und dies wieder in Ihre Project einfügen,
    so könnten Sie auch Zeit sparen.


    Gruß
    Alpay

  • Hallo Peter,


    wenn du das Projekt bearbeiten kannst und nur die Bilder fehlen, dann stellen sich für mich die Fragen:


    a) hast du entsprechende Bilddateien im Ordner \web?,
    b) hast du einen Ordner \Ausgabe mit allen Dateien (z.B. Images und Files)? und
    c) hast du das Projekt nun auf die oben beschriebene Art und Weise neu erstellt?


    Anscheinend ist das Projekt noch nicht total zerstört sonst wäre ein Bearbeiten nicht möglich (die Datenbank scheint zu funktionieren).
    Du könntest ja mal versuchen mittels FTP-Client deinen Webinhalt in den Order \Ausgabe rückzukopieren (aber bitte nur in diesen Ordner), vielleicht funktioniert dann die Vorschau wieder.


    Gruß Robert

  • Es ist richtig, dass das Objekt nicht vollends zerstört ist. Ich werd mir das noch mal wie oben beschrieben anschauen. Eventuell finde ich den Fehler. Ich habe das Objekt, da es ohnehin verändert werden musste, komplett neu erstellt und die noch vorhandenen Texte und Bilder teilweise übernommen. Ich verwende das Design "On the Air". Da das Objekt für einen gemeinnützigen Verein ist, benötige ich kein Impressum. Ist auch nicht in der Navigation. Aber in der Fußzeile erscheint "Startseite+Kontakt+Impressum". Ich möchte dieses Impressum löschen, denn es erscheint beim anklicken natürlich "Seite nicht auffindbar". Was muss ich tun?

  • Hallo Peter,


    eine Möglichkeit ist:


    1. Du musst oben bei der Menüleiste auf Webseite > Einstellungen und dann bei dem
    Fenster "Webprojekt-Einstellungen" auf "Extra-Menü konfigurieren" Klicken.


    2. Hier dann einfach das Impressum bei Name und den Link bei URL löschen und dann mit OK bestätigen.


    3. Dann Fenster schließen und unter Vorschau > Webseite erstellen (komplett) anklicken.


    4. Das sollte es dann gewesen sein.


    Gruß
    Jochen