• Hallo zusammen,
    meine homepage ist mit Zeta erstellt, meinen host habe ich bei IONOS und wollte dort das SSL aktivieren, jedoch funktioniert das laut IONOS nur mit homepages die über deren Anbieter gestaltet wurden. Meine Frage nun: habe ich irgendeine Möglichkeit über Zeta das SSL zu aktivieren oder geht das nur ausschliesslich über den host, in meinem Fall IONOS?
    Danke für eure Hilfe und LG

  • Steffen T.

    Hat das Thema freigeschaltet
  • Zeta Producer ist vom Hosting/Webserver komplett unabhängig. SSL ist eine Option des Webservers und kann nur dort entsprechend aktiviert werden.

    Sie müssen sich also an den Host wenden. Die Aussage, dass das von der Art und Weise, wie die Seite erstellt wurde, abhängig sein soll, kann ich nur für ein Missverständnis halten.

  • Hallo Stefan,
    leider muss ich dich nochmal kontaktieren. Also: IONOS hat mir nun das SSL freigeschaltet und im IONOS -Panel erscheint meine Seite als sicher. Gebe ich bei Google oder Firefox nun meine Homepage mit www........ ein erscheint sie als unsicher, jedoch gebe ich sie als https://www....... ein erscheint sie als sicher.
    IONOS meinte ich muss etwas in Zeta umstellen oder anders aktivieren. Leider habe ich nun schon alles ausprobiert aber es immernoch nicht geschafft dass die Seite als sicher erscheint nur mit www.....
    Wäre dir um jeden Ratschlag dankbar!
    Liebe Grüsse

  • Hallo,


    nach Umstellung der Website auf HTTPS müssen Sie in Zeta Producer lediglich in den FTP-Einstellungen des Projekts im Feld Web-Adresse zu Beginn auch das Protokoll https:// eingeben. Wenn Ihre Web-Adresse z.B. http://www.example.com ist, sollte dann nach der Eingabe entsprechend https://www.example.com im Feld stehen. Danach dann die Website veröffentlichen.

  • SSL wird ausschließlich auf dem Webserver aktiviert. Der Ansprechpartner ist also der Provider.


    Die Umstellung in den FTP-Einstellungen war richtig und wichtig, sie hat jedoch keine Auswirkung auf die Verschlüsselung auf dem Webserver.

  • Hallo

    Beim Webserver(Provider) ist auf SSL eingestellt auch die verwendeten Iframs haben https, beim Handy wird eigenartiger Weiße die Seite richtig angezeigt ?


    MFG.

  • Hallo Reini,


    in den FTP-Einstellungen steht http://www.ramingstein-wetter.at. Die IFrames sind aber mit https://ramingstein-wetter.at (ohne www) eingebunden. In der Chrome-Console werden sie sogar nur mit http angezeigt, nur der Quelltext zeigt die https-Adresse. Hier also bitte noch einmal nacharbeiten.


    Wichtig wäre aber auch von Deiner Seite in die Chrome-Console, da es offensichtlich mit dem Multigeiger-Citysensor weitere Probleme gibt.


    Starte Chrome und lasse Dir dann mit F12 die Entwicklertools (Konsole) anzeigen. Oben rechts rot markiert sind die Fehler. Ein doppelklick führt Dich direkt zum entsprechenden Eintrag.

  • "Teile der Website sind nicht sicher" = http statt https

    Schau Dir mal den Quelltext (hier Starteite) an:


    <script> // if after 1000ms we haven't got webfonts, show the user something, a FOUT is better than nothing // http://kevindew.me/post/47052453532/a-fallback-for-when-google-web-font-loader-fails setTimeout(function() { // you can have the webfont.js cached but still have no classes fire and you will have a window.WebFontConfig object if ( ! ("WebFont" in window)) { // non wfl loader class name because their events could still fire document.getElementsByTagName("html")[0].className += " wf-fail"; } }, 1000); WebFontConfig = { google: { families: [ 'Roboto:300,400,700', 'Architects+Daughter:400,700' ] } }; </script>


    <li data-clickurl="http://www.kreischberg.at"> <a href="http://www.kreischberg.at"> <img src="media/images/e113650c75210bc6334d8c0263c891a9-large.jpg" width="1100" height="380" alt="" /> </a> </li>


    if ( $z('#headerslider .flex-container ul.slides li img').length > 0 ){ // init flexslider after 1st image has loaded, so have dimensions as quickly as possible without having to wait too long on window loaded or such and can start right with doc ready $z('#headerslider .flex-container ul.slides li img').first().one("load", initSlider).each(function() { if(this.complete) $z(this).trigger('load'); }); // .each() is to work around a browser bugs which don't fire load() for cached images http://stackoverflow.com/a/3877079 }


    und weitere

  • Mixed Content (im Sinne einer sicheren Webseite) entsteht ausschließlich durch Scripte und IFrames, also externe Inhalte, die wir auf unseren Seiten einbinden. Hier muss die Adresse des externen Anbieters mit https eingebunden werden.


    Was mich an der aktuell betroffenen Seite irritiert, ist der Umstand, dass die Chrome-Konsole folgendes meldet:

    Code
    Mixed Content: The page at 'https://ramingstein-wetter.at/' was loaded over HTTPS, but requested an insecure frame 'http://ramingstein-wetter.at/minidisplay.gif'. This request has been blocked; the content must be served over HTTPS.
    (index):1254 Mixed Content: The page at 'https://ramingstein-wetter.at/' was loaded over HTTPS, but requested an insecure frame 'http://ramingstein-wetter.at/mini_currentt.gif'. This request has been blocked; the content must be served over HTTPS.

    Danach sollen sowohl die minidisplay.gif als auch die mini_currentt.gif über http eingebunden sein. Wenn man sich aber den Quelltext der Seite ansieht, findet man:

    Code
    <iframe style="BORDER-LEFT-WIDTH: 0px; BORDER-RIGHT-WIDTH: 0px; BORDER-TOP-COLOR: #ffffff; BORDER-BOTTOM-WIDTH: 0px; BORDER-LEFT-COLOR: #ffffff; BORDER-BOTTOM-COLOR: #ffffff; BORDER-RIGHT-COLOR: #ffffff; BORDER-TOP-WIDTH: 0px;" height="500" src="https://www.ramingstein-wetter.at/minidisplay.gif" frameborder="1" width="640" name="myiframe"></iframe>

    bzw.

    Code
    <iframe src="https://www.ramingstein-wetter.at/mini_currentt.gif" name="iframe" width="480" height="300" style="border: 0; overflow: auto;"></iframe>

    die Inhalte sind also bereits sicher eingebunden. Testweise habe ich beide Elemente mal auf unserer Seite platziert. Siehe https://www.hanabi-pirna.de/test.php. Auch hier werden in der Konsole die Inhalte trotz https als unsicher deklariert.


    Frage: wie verhält es sich, wenn https ohne www. eingesetzt wird? Hierzu beide IFrames erneut angelegt, diesmal aber auf www. in der Adresse verzichtet. Siehe da: die IFrames werden angezeigt.


    kurzfristige Lösung:

    • entferne bei den IFrames, die Inhalte außerhalb von Zeta auf Deiner Seite einbinden, das www. in der Webadresse

    langfristige Lösung:

    • entscheide Dich, ob die Webadresse https://www.ramingstein-wetter.at (mit www) sein soll oder https://ramingstein-wetter.at (ohne www)
    • trage die entsprechende Variante in den FTP-Einstellungen von Zeta ein
    • erkundige dich beim Hoster, wie Du die Umleitung so konfigurieren kannst, dass alle Aufrufe (mit und ohne https sowie mit und ohne www) auf die von Dir gewünschte primäre Adresse laufen.
    • Überprüfen bei allen IFrames und Scripten, ob Du die korrekte Version der Adresse eigegeben hast.