reCAPTCHA funktioniert im Kontaktformular auf einmal nicht mehr

  • Liebe Community,


    es geht um das Kontaktformular mit recaptcha auf unserer Website. Hier kommt jetzt auf einmal folgende Fehlermeldung:

    Spam-Schutz / Spam-Protection

    Das reCAPTCHA konnte nicht verifiziert werden.

    Could not verify the reCAPTCHA.

    Fehler / Error:

    Der reCAPTCHA-Server konnte nicht kontaktiert werden. Ist allow_url_fopen in Ihrer php.ini aktiviert? /

    Couldn't contact the reCAPTCHA-Server. Is allow_url_fopen enabled in your php.ini?


    Was ich nicht verstehe ist, dass es bis jetzt immer funktionierte und keine Änderungen vorgenommen worden sind.

    Habe ein wenig gegoogelt aber so richtig fündig bin ich nicht geworden. PHP Version ist 7.2.23.


    Danke für euer Feedback.

  • Hanabi

    Hat das Thema freigeschaltet
  • Hallo Hellish,


    willkommen im Forum. Bitte poste mal einen Link zur Seite, dann können wir anhand der zp-php-info.php feststellen, ob fopen aktiviert ist. Weitere mögliche Ursache könnte die Umstellung auf https sein. Die Fehlermeldung sollte dann aber eigentlich anders sein.

  • Bei Ihnen ist in der PHP.ini die Option "allow_url_fopen" auf "off" gestellt. Das muss aber auf "on" stehen, damit ReCaptcha funktioniert. Bitten den Provider kontaktieren und ihn fragen, wie Sie das umstellen können, oder ob er es umstellen kann.

  • Besten Dank, Stefan. Das hat mir viele wertvolle Zeit gespart. Ich konnte es in meinen Einstellungen ändern (verstehe zwar nicht warum sich dies änderte, da das Kontaktformular ja schon länger besteht, aber egal.


    Happy weekend :-)