Probleme mit der Formatierung

  • Hallo,


    wieder hatten das ja schon mehrfach, das es bei meinen Seiten scheinbar "spukt", weil sich irgendetwas, nicht nachvollziehbar, in der Formatierung verstellt.

    Aktuell mal wieder ein Beispiel, welches ich seit einigen Tagen immer mal wieder habe.

    Seht euch den Screenshot doch bitte mal an. Die Aufzählung ist in der Bearbeitungsansicht anders als "in echt". Nicht die Reihenfolge, sondern die Darstellung unter den Aufzählungszeichen. Es nutzt auch nichts, wenn ich das Fenster breiter mache, es wird weiterhin so seltsam dargestellt.

    Das ist jetzt kein Weltuntergang, aber normal ist das auch nicht, denn ich hatte dieses Problem bis vor ca. 2 Wochen (schätze ich) noch nicht. Aber inzwischen taucht das immer öfter auf, in Dateien/Seiten/Texten, die schon angelegt waren und nachbearbeitet werden sollen.

    Ich wollte euch darüber nur mal informieren. Es nervt einfach, dass immer wieder neue Dinge auftauchen, die so sicher nicht beabsichtigt sind.


    Viele Grüße

    Guido

  • Online sieht die Liste ja korrekt aus. Das half also leider nicht. Senden Sie mir Ihr Projekt damit ich mir das im Projekt ansehen kann:


    1. Öffnen Sie Ihr Projekt in Zeta Producer
    2. Gehen Sie auf das Menü "Extras"
    3. Klicken Sie auf den Button "Optionen"
    4. Klicken Sie auf "Aktionen"
    5. Klicken Sie rechts auf die Aktion "Projekt Senden" damit diese Markiert ist
    6. Klicken Sie unten auf den Button "Ausführen"
    7. Geben Sie im 1. Feld Ihre E-Mail-Adresse ein, damit wir Sie für Rückfragen kontaktieren können
    8. Geben Sie als Referenz ins Feld Bemerkungen den Link zu diesem Forum-Artikel ein (per Kopieren und Einfügen) und beschreiben Sie mir genau, auf welcher Seite ich den entsprechenden Artikel mit der Liste finde.
    9. Klicken Sie auf den Button "Senden"
  • Im Quelltext sind in den <li> Tags immer noch <div> Tags enthalten und dies teilweise auch schon wieder mit der Blocksatz-Formatierung. Ich vermute sehr stark, dass die Texte aus einem anderen Programm kopiert und in ZP eingefügt wurden. Kann das sein, und wie genau sind Sie da vorgegangen?

  • Gute Frage. Grundsätzlich ist es so, dass ich je nach Anbieter die alten Angebote als Vorlage für neue nehme.

    Ich habe also vermutlich beim Hotel Cella Central eine alte Seite mit einem Angebot von Travelcircus als Vorlage genommen, diese kopiert und dann die Aufzählungsinhalte aus dem Originalangebot https://www.travelcircus.de/hotel-cella-central übernommen. d.h. ich nehme z. B. die Texte hinter den Aufzählungszeichen wie z.b. Freie Nutzung des Wellnessbereichs im Hotel Alpenblick und überschreibe damit die vorhandenen (aufgezählten) Texte aus dem alten Angebot. Das mache ich meist Zeile für Zeile. Bei anderen Anbietern funktioniert das ähnlich Travador Angebote dienen als Vorlage für Travador Angebote (COOEE Hotel), Hofer Angebote für Hofer Angebote (Vitalhotel Tauernhof), etc. Entsprechend der unterschiedlichen Seitenstruktur der Anbieter kopiere ich also auch von unterschiedlichen Vorlagen.


    Das ist dann von der Formatierung her manchmal problematisch und dann lösche ich die ganz Zeile mit Aufzählungszeichen, füge den Text zunächst in Notepad und dann (unformatiert) im Zeta Artikel ein. Allerdings funktioniert auch das nicht immer so sauber, wie es aussehen sollte. Manchmal gibt es da einfach ein Chaos an Größen, trotz des Umwegs über Notepad. Es kommt auch vor, dass ich Leerschritte mit "Entf" löschen möchte und dann ist die ganze Zeile plötzlich entweder verschwunden oder sie steht komplett oberhalb der Aufzählung.


    Was ich aber ganz und gar nicht verstehe ist, dass diese genannten Artikel alle "ordentlich", also so wie sie sollen, aussehen wenn ich sie abspeichere, aber dann sieht die Bearbeitungsansicht teilweise plötzlich so aus wie heute bei diesem Cella Central Artikel. Obwohl er vorher vollkommen okay war. Es muss sich also etwas verändert haben nachdem der Artikel abgespeichert wurde und das Projekt geschlossen wurde, oder als es neu geöffnet wurde. Auch das komplette entfernen der Formatierung mit dem durchgestrichenen A hilft leider nicht immer.


    Und dazu gleich noch ein Rätsel zum selber ausprobieren. Was passiert, wenn man auf der Startseite in der Aufzählung unmittelbar vor dem 4* Boutique Hotel Enter drückt, um darüber eine Aufzählungszeile einzufügen? Es erscheint ein Aufzählungszeichen, aber man kann nicht dahinter klicken um etwas einzufügen.

    Auch das ist ein Rätsel.

  • Da müssten Sie dann jetzt mal den Quellcode bereinigen oder einfach löschen und im Editor neu aufbauen. Innerhalb eines <li></li> darf kein <div></div> enthalten sein. Künftig dann den korrigierten Quellcode benutzen. Sie können natürlich auch damit leben, dass es nur im Editor komisch aussieht. Fakt is, das <div> im <li> ist absolut überflüssig und ebenso das style="text-align: justify;.


    Zum Artikel auf Ihrer Startseite: auch hier sind im Quellcode wieder massenhaft doppelte und überflüssige Formatierungen in Form von <span> enthalten, die das verursachen.

  • Okay, danke.

    ich verstehe nur noch nicht, wieso sich das erst im nachhinein verändert hat, nachdem es beim ersten abspeichern ja keine Probleme gab.

    Aber egal, ist im Moment nicht so wichtig.


    Ich habe jetzt mal was ausprobiert mit einem sauberen Textwidget.

    Wenn ich das normal ausfülle, dann sieht auch alles normal aus, auch im Quellcode (Bild 1 + 2)

    Sobald ich einen Text (von einer Webseite) reinkopiere, werden irgendwelche Formatierungen übernommen. (Blid 3 + 4)

    Lösche ich den Text wieder raus, bleiben die Formatierungen in der gelöschten Zeile aber erhalten. (Bild 5 + 6)

    Wenn ich dann einen neuen Text eintippe, bleiben die alten Formatierungen trotzdem. (Bild 7 + 8)

    Vermutlich sammelt sich dadurch immer mehr Datenmüll an Formatierungen an und irgendwann wirkt sich das dann schlecht aus.


    Ich darf also keine externen Inhalte reinkopieren, wenn diese irgendwie formatiert sind.

    Das ist natürlich unpraktisch, aber es scheint nicht anders zu gehen, denn selbst mit der Löschung der Formatierung bekomme ich den Formatierungsmüll nicht weg.

  • Man kann auch ohne Formatierungen aus der Zwischenablage einfügen. Ich glaube, die Tastenkombination dazu ist STRG-SHIFT-V oder STRG-ALT-V.

  • Hallo Stefan,


    nur zur Info. Eben habe ich das Problem auf einer anderen Seite von mir entdeckt.

    Diese Aufzählung habe ich vor ca. einem Jahr dort hingeschrieben (nicht von irgendwo kopiert) und eben mal wieder in den Bearbeitungsmodus geschaut.

    Ist kein Weltuntergang, sollte aber sicherlich nicht so sein, wie es angezeigt wird.

    Das muss sich irgendwann nach der Umstellung von 14 auf 15 von alleine verstellt/verändert haben.


    Viele Grüße

    Guido


  • Auch da sind wieder <div> drin, mit Textausrichtung "Links" was ja eh standard ist. Wie das da rein kam, ist nun leider nicht mehr nachvollziehbar. Das wichtigste ist ja aber, dass es auf der Seite korrekt aussieht. Trotzdem Danke für den Hinweis.

  • Ich sehe keinen kleinen Textblock. Für mich ist in allen 3 Blöcken die Schrift gleich groß. Also optisch, ohne das nachzumessen.

  • Wenn ich den Quellcode auf der Seite checke, hat der erste Absatz auch die korrekte Schriftgröße von 1.3em.

  • Angezeigt wird aber eine Größe von 1.00em :-(


    ich habe das ja jetzt bei den anderen Projekten mehrfach getestet, also bei verschiedenen Projekten und 1.30em kam der alten Größe

    <span style="font-size: medium;"></span>

    relativ nahe.

  • Na toll, nur in meinem Browser :(

    Verstehe ich zwar nicht, weil ich extra noch ein paar Wörter ergänzt hatte um zu prüfen, dass mir kein alter Cache angezeigt wird, aber irgendwie hat Chrome mich ausgetrickst. Sorry, dann ist alles okay. Danke!


  • Am besten immer vor der Kontrolle den Browser-Cache löschen .


    Die Schriftgröße wird in einer separaten CSS Datei gespeichert. Also selbst wenn die aktuelle HTML-Seite gezeigt wird, könnte das CSS ja noch aus dem Cache kommen. Also cache löschen, oder mehrfach mit STRG-F5 neu laden…