Falk Routenplaner

  • Ich verwende auf unserer Hompage den Falk Routenplaner der über Quelltext eingebunden werden kann.
    Bis zur letzten Version hat der Routenplaner auf der Seite auch funktioniert, jetzt wird der Planer auf der veröffentlichten Seite nicht mehr richtig dargestellt, in der Vorschau passt alles ?(


    Hier mal der Quelltext den eich eingebunden habe:

    Code
    1. <!-- START Routenplaner-Code --><STYLE type="text/css">#falkwidget {background-color:#f0f0f0;background:-webkit-gradient(linear, 0% 0%, 0% 100%, from(#f0f0f0), to(#cccccc));background:-webkit-linear-gradient(top, #f0f0f0, #cccccc);background:-moz-linear-gradient(top, #f0f0f0, #cccccc);background:-ms-linear-gradient(top, #f0f0f0, #cccccc);background:-o-linear-gradient(top, #f0f0f0, #cccccc);}</style><script type="text/javascript">var tr_defdest="Ziel (Straße, PLZ Ort)";var tr_defstart="Start (Straße, PLZ Ort)";var tr_location="aktueller Standort";var tr_css="";var tr_title="Obere Mühle 9, 97486 Königsberg";</script><script src="http://www.falk.de/js/homepagetools/falk-homepagetools.js" type="text/javascript"></script><link type="text/css" href="http://www.falk.de/css/homepagetools-widget.css" rel="stylesheet" /><!--[if lte IE 9]><link type="text/css" href="http://www.falk.de/css/homepagetools-IE9.css" rel="stylesheet" /><![endif]--><div id="falkwidget" style="border: 1px solid rgb(222, 222, 222); background-image: -webkit-linear-gradient(top, rgb(240, 240, 240), rgb(204, 204, 204)); border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; width: 420px; box-shadow: rgb(163, 163, 163) 5px 5px 5px; background-position: initial initial; background-repeat: initial initial;"><form name="falkform" action="http://www.falk.de" method="get" target="_blank" accept-charset="utf-8"><h3 style="font-family: Arial;"><a target="_blank" href="http://www.falk.de/routenplaner" style="color: rgb(119, 119, 119); font-weight: normal; font-family: Verdana;">So finden Sie uns!</a></h3><span id="falk_logowrap"><a target="_blank" title="www.falk.de" href="http://www.falk.de"><img onload="falk_events();" alt="Falk" class="falklogo" src="http://www.falk.de/i/homepagetools/falk.png" style="display: block;"></a></span><ul class="forms"><li><span class="input location"><input type="text" value="Start (Straße, PLZ Ort)" class="address start inactive" autocomplete="off" id="falk_widgetStart" style="font-family: Verdana;"><input type="hidden" name="start" id="falk_sendStart" style="font-family: Verdana;" autocomplete="off"><div class="clear-button"></div><span class="hitbox"><span id="falk_geo" class="current-position start" title="Standort ermitteln und übernehmen"></span></span></span></li><li><span class="input location"><input type="text" value="Ziel (Straße, PLZ Ort)" class="address destination" autocomplete="off" id="falk_widgetDest" style="font-family: Verdana;"><input type="hidden" name="dest" id="falk_sendDest" style="font-family: Verdana;" autocomplete="off"><div class="clear-button"></div><span class="hitbox"><span class="current-position destination"><span>B</span></span></span><span class="route-toggle"></span></span></li><li class="options"><span class="drive-walk-toggle drive" id="falk_toggle"><span class="drive" id="falk_drive"></span><span class="walk" id="falk_walk"></span>&nbsp;</span><input type="hidden" name="rm" id="falk_mode" class="dw-mode" value="0" style="font-family: Verdana;" autocomplete="off"><input type="hidden" name="st" value="1" style="font-family: Verdana;" autocomplete="off"><input type="hidden" id="mydest" class="falk_dest" value="Obere Mühle 9, 97486 Königsberg" style="font-family: Verdana;" autocomplete="off"><span id="falk_submit" class="submit" style="background-color: rgb(0, 139, 209); font-family: Verdana; color: rgb(255, 255, 255); background-position: initial initial; background-repeat: initial initial;">Route anzeigen</span></li></ul></form></div><!-- Eigenes Routenplaner-Widget erstellen: www.falk.de/routenplaner-widget --><!-- ENDE Routenplaner-Code -->



    Könnt Ihr das mal testen?


    Vielen Dank.

  • Hallo,


    also in habe deinen Code mal in meinem Testprojekt eingebaut und da geht es (ZP 11).


    Versuche mal nach Website erstellen komplett, die Website veröffentlichen komplett durchzuführen.


    Gruß
    Jochen

  • Hallo Jochen, habe ich gemacht, leider ohne Erfolg.


    So sieht der Routenplaner auf der veröffentlichten Homepage aus:



    und so sieht der Routenplaner im ZP11 aus:




    Ich verwende ZP11.1.1


    Das verstehe ich nicht ?(


    Als Browser verwende ich Chrome und habe auch schon einen Test mit IE gemacht, leider ohne Erfolg.


    www.cdr-engineering.de/kontakt

  • Hallo,


    also ich habe jetzt eben mal mein Testprojekt auch mal mit deinem verwendeten Layout "Tweet" veröffentlicht und dein Routenplaner-Code wird korrekt angezeigt...


    Jetzt fällt mir noch folgendes ein, was du mal noch versuchen kannst:


    1. Den Menübefehl "Website | Erstellen | Ausgewählte Seiten erstellen" ausführen.
    2. Auf der rechten Seite "Alle Ordner kopieren" auswählen.
    3. Auf "Start" klicken.
    4. "Veröffentlichen" klicken.


    Und, bringt es was?


    Gruß
    Jochen

  • Hallo nochmal,


    also ich kann testen was ich will mit deinem Quellcode, und es wird auf allen Browsern in der News-Spalte richtig angezeigt.


    Beschreibe mal bitte, wie du den Quellcode in dein Projekt eingebunden hast?
    Und hast du irgendwelche Änderungen manuell in deinem Projekte in der styles.css Datei gemacht, oder irgendwas anderes,
    da du schreibst das der Routenplaner schon mal ging?


    Evtl. hilft es ja auch schon den Artikel mit dem Code zu löschen und wieder neu zu erstellen und veröffentlichen.


    Gruß
    Jochen

  • Zitat

    Beschreibe mal bitte, wie du den Quellcode in dein Projekt eingebunden hast?

    Artikel einfügen > Quelltext > dann den Code aus der Zwischenablage eingefügt.


    Zitat

    Und hast du irgendwelche Änderungen manuell in deinem Projekte in der styles.css Datei gemacht, oder irgendwas anderes, da du schreibst das der Routenplaner schon mal ging?

    Die Anpassungen sind beim ersten Erstellen der Seite gemacht worden und da hat der Routenplaner funktioniert, das war im September. Seit dem wurde an der css nichts mehr geändert.

    Zitat

    Evtl. hilft es ja auch schon den Artikel mit dem Code zu löschen und wieder neu zu erstellen und veröffentlichen.

    Das hab ich auch schon probiert. Ich habe auch schon leere Seiten erstellt und dort den Code eingefügt, immer mit dem gleichen Ergebnis ;(

  • Hallo,


    was mir auffällt, wenn ich mir deine Webseite ansehe ist, das beim IE und Firefox der Hintergrund deines Routenplaners "transparent" dargestellt wird. Beim Google Chrome, Opera und Safari, wird der graue Hintergrund dargestellt.


    Das sieht so aus, also ob der CSS-Code der Routenplaners da irgendwas "zerschießt", in Verbindung mit deinem Layout, und daher dieser fehlerhaft angezeigt wird.


    Hingegen wird dein Code von hier in meinem Testprojekt, auf allen Browsern richtig dargestellt...


    Versuche mal noch folgendes: Gehe in den Newsbereich > Neuer Artikel > Text und Bild > Text/News und wechsele in diesem Artikel auf die HTML-Quellcode ansicht > Füge dort dann mal den Falk Code ein > Erstellen und veröffentlichen.


    Evtl. klappt es ja so?...


    Wenn das auch nicht hinhauen sollte, dann lösche mal die obere css-anweisung des Codes raus:
    <STYLE type=text/css>#falkwidget {background-color:#f0f0f0;background:-webkit-gradient(linear, 0% 0%, 0% 100%, from(#f0f0f0), to(#cccccc));background:-webkit-linear-gradient(top, #f0f0f0, #cccccc);background:-moz-linear-gradient(top, #f0f0f0, #cccccc);background:-ms-linear-gradient(top, #f0f0f0, #cccccc);background:-o-linear-gradient(top, #f0f0f0, #cccccc);}</STYLE>


    Dann erstellen und veröffentlichen.


    (Habe es gerade so bei meinem Testprojekt getestet > Ohne negative Auswirkung, und dein Hintergrund würde nicht stören!)


    Wenn das auch nichts bringen sollte, dann bitte auf den Montag 07.01.2013 warten, bis die Zeta-Leute wieder hier sind.


    Gruß
    Jochen

  • Hallo Jochen, erst mal vielen Dank für die Hilfe :)
    Leider funktioniert es trotzdem nicht, ich habe nochmal alles mögliche versucht.


    Ich werde mich am Montag mal an den Support wenden.

  • Hallo nochmal ;-)


    eine allerletzte Idee hätte ich da noch.....


    Versuch mal unter Website > Erweitert > Erweiterte Einstellungen > Kodierung, die Häkchen bei "HTML-Code optimieren" und "CSS-Dateien komprimieren" testweise raus und reinzumachen, und dann jeweils erstellen und veröffentlichen (komplett).


    Vielleicht bringt das ja mal was?.....


    Wenn nicht, dann bin ich auch mal auf den Montag gespannt, was hier nun das Problem dann war.


    Gruß
    Jochen

  • Hallo,


    ich habe das nun auch mal getestet und konnte die falsche Darstellung auch bei mir reproduzieren. Ursache ist die Option "HTML-Dateien komprimieren". Bitte mal über "Website | Erweitert | Erweiterte Einstellungen | Optionen" die genannte Option deaktivieren. Danach über "Website | Erstellen" den Befehl "Alle Seiten erstellen" wählen. Danach sollte die Darstellung korrekt sein.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Hallo,


    Wir haben das eben analysiert. Ursache hierfür ist invalides HTML im Quellcode von Falk (<div> in <span>). Solange Falk das nicht korrigiert, müssen Sie wie bereits von meinem Kollegen beschrieben vorgehen und die HTML-Komprimierung deaktivieren.

  • Vielen Dank für Hilfe. Ich habe die Komprimierung ausgeschaltet, jetzt geht der Routenplaner :-)


    Hat es sonstige negative Auswirkungen wenn die HTML-Komprimierung ausgeschaltet ist?


    Viele Grüße

  • Hallo,


    nein, das hat keine negativen Auswirkungen. Die Dateien werden halt etwas größer aber das fällt nicht sehr ins Gewicht, zumal viele Provider bereits global in Apache eine Komprimierung aktiviert haben.