Fehlermeldung - geschützter Bereich

  • Hallo !


    Wenn ich einen geschützten Bereich einrichte kommt diese Fehlermeldung :


    Fehler. Das Kennwortschutz-Modul konnte nicht installiert werden: PCLZIP_ERR_DIR_CREATE_FAIL (-8) : Unable to create directory '/var/www/vhosts/ff-sooss.at/httpdocs/media/Scripting/ServerSideScripting/PHP/pa/templates'


    Der Link zu dem geschützten Bereich : http://www.ff-sooss.at/mitgliederbereich.php


    Mein Webspace ist kompatibel mit PHP 5.3.2 und Schreibrechte habe ich auch - bitte um Hilfestellung !


    Danke !


    LG Hermann

  • Hallo Hermann,


    ist auch sicher auf deinem Webspace das PHP 5.3 aktiv geschalten?


    Bei manchen Webhoster ist meist noch eine ältere Version aktiv, und man kann diese aber dann in seinem Kundenbereich wechseln.


    Dies mal bitte überprüfen.


    Gruß
    Jochen


    Nachtrag: Ich habe gerade gesehen, das du die PHP 5.2.4 hast, also auf die 5.3 oder höher wechseln, und dann sollte/könnte es gehen.

  • Hallo !


    Ich habe jetzt von meinem Webspace Anbieter einen neuen Account bekommen der PHP 5.3 installiert haben soll.
    Da ich nicht weis wie ich das auslesen kann, bin ich auf eure Hilfe angewiesen.


    Der Mitgliederbereich mit geschütztem Bereich zeigt aber auch hier die selbe Fehlermeldung auf !


    Fehler. Das Kennwortschutz-Modul konnte nicht installiert werden: PCLZIP_ERR_DIR_CREATE_FAIL (-8) : Unable to create directory '/var/www/vhosts/ff-sooss.at/httpdocs/media/Scripting/ServerSideScripting/PHP/pa/templates'


    Bitte um weitere Hilfe


    MfG Hermann

  • Hallo !



    Gestern abend hatte ich im Zeta Producer im Menü FTP auf folgenden Host umgestellt und die Seite dann neu veröffentlicht :


    powerc194.galaxy-gmbh-service.de


    Auf deinem Screenshot ist aber noch 184 zu lesen.


    Habe ich möglicherweise irgendetwas beim neu hochladen nicht richtig gemacht ? Oder gibt es hier noch eine zusätzliche Funktion zum aktivieren ?



    LG Hermann

  • Hallo Hermann,


    sorry, aber das ist KEIN Screenshot: http://www.ff-sooss.at/media/S…PHP/shop/etc/php-info.php


    Das zeigt tatsächlich, die immer noch falsche PHP Version der Webseite www.ff.sooss.at an!


    Dein letztes Bild zeigt zwar an, das wohl nun die 5.3.2 aktiv sein sollte, was aber definitiv noch nicht der Fall ist (zumindest nicht da, wo es sein sollte).


    Kläre das mal bitte mit deinem Webhoster ab.


    Zur kontrolle kannst du dann immer den Link oben aufrufen, dieser liest und zeig dann immer die aktuelle Version an.


    Gruß
    Jochen

  • Hallo Jochen !



    Danke für die Info - ich bin noch ein ziemlicher Rookie was so spezielle Themen wie PHP angeht.


    Werde meinem Webspace-Anbieter mal auf die Füße treten ! :cursing:


    LG Hermann

  • Hallo Hermann,


    dann kann es jetzt eingentlich, nur noch 2 Ursachen geben.


    1. Es steht in der FTP-Konfiguration nicht die richtige Web-Adresse drin (falls ja, dann richtigstellen)
    2. Du hast keine Schreibrechte, innerhalb deines Webspaces (wieder mit deinem Anbieter klären)


    Gruß
    Jochen

  • Fehler. Das Kennwortschutz-Modul konnte nicht installiert werden: PCLZIP_ERR_DIR_CREATE_FAIL (-8) : Unable to create directory '/var/www/vhosts/ff-sooss.at/httpdocs/media/Scripting/ServerSideScripting/PHP/pa/templates'

    Hallo,


    das sieht ganz klar nach fehlenden Schreibrechten aus. Das Widget, konnte sich nicht selbst in ein Verzeichnis entpacken. Es benötigt Schreibrechte unter /var/www/vhosts/ff-sooss.at/httpdocs/media/Scripting/ServerSideScripting/PHP/
    Das heißt, der user unter dem der Webserver läuft, sollte unter /var/www/vhosts/ff-sooss.at/httpdocs/media/Scripting/ServerSideScripting/PHP/ Schreibrechte bekommen, dann wird es klappen.

  • Gott sei Dank !


    Nachdem ich jetzt rausgefunden habe wie ich die Schreibrechte vergeben kann, funkt es einwandfrei ! :D


    Trotzdem allen nochmals ein Danke die mir bis hierher geholfen haben ! :thumbsup:


    LG Hermann