Formular with FormMailer - ZP 9 - Language issue

  • I have
    made the changes and the new FormMailer works just fine :) .
    I have some problems with the language though since my website is not in
    German.



    1) Concerning the Catcha: the 'spam-schutz' text above and the ‘absenden’
    button


    I think they used to be browser dependant ? Can the leading text
    and the button text be browser dependant as before ?



    2) The email
    subject text


    which I could manage before within Zeta is now fixed and in German


    (Ein Formular wurde Ihnen von Ihrer Website gesendet. Jemand hat
    Ihnen ein Formular mit den folgenden Werten gesendet.)



    Is it possible for me to change this since I have websites in several
    languages (Danish, English, Greek).



    German is no-go for my non-German websites. English would be a better default
    solution – since the captcha is in English anyway



    I also have websites in ZP 10 and ZP 11 (in Business version). I suppose
    I shall have the same issues there ?

  • Dear Steffen,
    I am not sure how to do this in ZP11.


    When I upload the customised SendEmail.php in the /php/formmailer folder and then send a formular, the program stops and shows only a white page and not the 'ok-sent'-page.
    The mail is sent and received though.


    When I reinstall the original formmailer in the php-folder it works again but obviously with the German text.


    Do you have any suggestion please
    Kind regards
    Vibbe

  • Hello,


    then you most certainly introcuded an error in the PHP script. See your server's error.log for details.

  • Hello,


    first of all, you shouldn't use the SenEmail.php script from ZP9 in ZP11 as ZP11 had some important changes/fixes incorporated into the script.
    Second, if the "www" is missing, please verify, your FTP-Settings in Zeta Producer and check the Entry in the "Web-Adresse" Field. That is the Address which gets passed to the SendEmail.php Skript, so probably you don't have a "www" in there either.


    Either way, it doesn't matter if you are using a "www" in your hostname, the important thing to remember ist, that the script will only properly work if it is accessed (through the Browser) by using the address you defined as "Web-Adresse". So if the "Web-Adresse" is without "www" the script will only work you don't use a "www" when typing the address into your browser's location field.

  • Thanks for your immediate answer.
    I must have misunderstood your answer above concerning the use of the script from zp9 in zp11. I'll make my changes in the ZP11 SendEmail.php script. Surely this must be the problem. Kind regards v

  • I uploaded the original sendEmail.php script from ZP11.
    It works fine with the German texts.


    But when I make even the smallest change in the German text in the script, it stops here:
    http://www.mpeppa.gr/media/Scr…rmmailer/SendEmail.php?sc (now I get the 'www').
    I do receive the mail with the changed text:"A formular - Ein Formular wurde Ihnen von Ihrer Website gesendet..."


    Sorry to bother you with this :-( but it is quite important for me to be able to change the language
    Kind regards v

  • Hi,


    in order to troubleshoot this further, i'd need the URL to the Website where you use the changed script as well as the FTP-Credentials (Servername, Username and Password), so i can log in and test. Normally we do not support modified scripts, but i can take a quick look for you.

  • Hello Vibbe,


    i am so sorry, i have meant you to send the credentials to us via E-Mail but forgot to specifically mention that.


    Now that the credentials are in the public (on the world wide web), i strongly encourage you to immediately change at least your password!
    After you've changed it, please send us the credentials via E-Mail to support[ät]zeta-producer.com (replace [ät] with @).


    Thanks!

  • Hello,


    i took a quick look at mpeppa.gr/media/Scripting/ServerSideScripting/PHP/formmailer/SendEmail.php and didn't see any modifications, so i believe you reverted back to the original script.


    However, i noticed one thing. Your files are written with a BOM (one form of utf-8 encoding) which often causes "white pages".


    In your Producer Project, please go to "Website > Erweitert > Erweiterte Einstellungen", select "Kodierung" in the window and remove the Checkmark in front of the "BOM schreiben" setting. Then republish all pages.
    If you make changes to SendEmail.php in a Texteditor, make sure to save the file as UTF-8 but without BOM!

  • Hi, I'll ask for a new password.
    The script is modified only at one place (the h1) where I added a few words in English:
    $body[] = "<head><meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\" /><title></title><style type=\"text/css\">" . $css . "</style></head><body>";
    $body[] = "<h1>A formular was sent - Ein Formular wurde Ihnen von Ihrer Website gesendet</h1>";
    $body[] = "<p>Jemand hat Ihnen ein Formular mit den folgenden Werten gesendet.</p>";
    $body[] = "<table cellpadding=\"0\" cellspacing=\"0\" border=\"0\">";
    I'll look into the BOM thing tonight. Maybe this solves the problem,
    Thanks a lot
    v

  • hello again,
    I looked at the BOM Checkmark in front of the "BOM schreiben" setting but it was NOT checked.
    So I do not know why the files are written with the BOM??
    Kind regards vibbe

  • Hello,


    well, the SendMail.php Skript was written incl. BOM. So the question is, what Editor did you use, when you made your modifications and does that Editor have a setting to disable saving the file with a BOM.

  • Hi, I have just used Notepad on Windows.
    I can see on W3.org that I have the choice to save without BOM if I use eg Notepad++.
    I'll download it and try.
    Thanks and kind regards