Validierungsfehler ZP 11

  • Hallo,


    ich bin dabei die noch verbliebenden Fehler abzustellen ( zum Glück nur noch paar Stück ) aber bei ´2 komm ich ich nicht so recht weiter:


    So hier der erste !


    Code
    1. The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.
    2. Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>.
    3. Line 29, column 107: required attribute "type" not specified …t" src="media/Scripting/ServerSideScripting/js/zp-widgets.js"></script><script>


    Die weiteren Fehler beziehen sich alle nur noch auf die iFrame - Sachen

    Code
    1. An "id" is a unique identifier. Each time this attribute is used in a document it must have a different value. If you are using this attribute as a hook for style sheets it may be more appropriate to use classes (which group elements) than id (which are used to identify exactly one element).
    2. Line 66, column 10: ID "iframecontent" already defined <div id="iframecontent" class="zpSO-SubMenu-IFrame" style="height:100%">


    Eine Frage zu den iFrame ? Vergibt Zeta für jeden iFrame eine separate ID oder wird immer die gleiche eingetragen so kommt mir das vor weil die Fehlermeldung immer aussagt das die ID bereits eingesetzt wird.
    LG

  • Hallo,


    zu 1:


    Es kommt hin und wieder noch vor, das manches im Code, den der ZP generiert manche Validatoren als falsch ansehen.
    Das wird von Update zu Update vom Zeta-Team korrigiert.
    Was an deinem ersten Fehler nicht richtig sein soll, kann ich dir jetzt auf die Schnelle nicht sagen, da ich nicht so der "coder" bin ;)


    Zum 2ten Punkt:
    Jeder Artikel im ZP, bekommt sein eigen ID.
    Das kann man sehen, wenn man im jeweiligen Artikel auf Mehr und dann auf "+" klickt (siehe Bild).
    Vielleicht ist da in der Tat, eine ID in deinem Projekt "doppelt" vorhanden.


    Gruß
    Jochen

  • Hallo,


    es geht nicht um die Artikel ID, es geht um die iFrame ID. Jeder iFrame sollte eine eigene haben ob das nun ein Name ist oder eine Zahl spielt keine Rolle.


    Bei mir haben aber 5 iFrame die gleiche ID, und da finde ich nix wo ich das ändern kann das macht ja Zeta automatisch.


    LG

  • Hallo Jochen,


    das Problem der iFrame hat sich dadurch erledigt das ich diese gelöscht und in Zeta 11 neu angelegt habe. Scheinbar behandelt Version 11 die anders als Version 10.


    Beim konvertieren von 10 auf 11 ist da wohl was verwurschtelt worden, nun sind diese Fehler zumindest raus, nun noch die anderen abstellen.


    LG