Probleme mit der Rücksicherung eines Backups bei ZP 10.5

  • Hallo,
    beim Rücksichern eines Backups auf das geöffente Porjekt erscheint eine Fehlermeldung:
    Der Prozess kann nicht auf die Datei "C:\Users\...\Documents\Zeta Producer 10\Projects\GfA-Duesseldorf\Web\web.mdb" zugreifen, da sie von einem anderen Prozess verwendet wird.


    Auch mit einem anderen Projekt habe ich Probleme beim Wiederherstellen des Backups. Mir scheint hier leigt ein generelles Problem vor.


    Ein Wiederherstellen eines Backups ohne ein Projekt geöffent zu haben, ist bei ZP ja aus dem Programm heraus nicht vorgesehen.


    Gibt es hier eine Hilfe oder muss ich wirklich alles manuell aus dem dem Backupzipfile restaurieren?


    Freundliche Grüße
    Herbert

  • Hallo Herbert,


    und wie verhält es sich, wenn du beim Backup wiederherstellen, dies als neue Webseite wiederherstellst?
    Vielleicht klappt das ja dann so.


    Gruß
    Jochen

  • Hallo Jochen,
    ich habe Deinen Vorschlag mal ausprobiert. Wenn ich das als neue Webseite wiederherstelle und komplett neu erstelle, dann klappt alles.
    Aber das kann doch nicht die Lösung sein, dass ist nur ein Workaround.
    Gruß
    Herbert

  • Hallo Herbert,


    danke dir für die Rückmeldung und ich gebe dir recht, das dies keine zufriedendstellende Lösung sein kann.
    Habe das bei mir auch mal eben versucht, mit dem gleichen Ergebnis wie bei dir!


    Mal abwarten, was dem Steffen von Zeta-Software morgen dazu einfällt.


    Gruß
    Jochen

  • Hallo,


    die einfachste Lösung ist das entsprechende Projekt einfach woanders hin, mittels Copy&Paste, zu sichern, z.B. USB-Stick. Genauso einfach kann das Projekt auch wieder hergestellt werden. Ab ZP 10 wird auch das Layout im Projektpfad mitgenommen und muss nicht mehr extra gesichert bzw. kopiert werden.


    Das Erstellen der Webseite ist auch nicht erforderlich. Warum ZP von Haus aus nicht auf diese Art und Weise sichert ist mir aber auch schleierhaft. Das Sichern ist in diesem Forum schon öfters das Thema gewesen.


    Gruß Robert

  • Hallo Robert,


    ja das mit dem Copy&Paste ist eine Möglichkeit, die immer funktioniert (so mach ich das auch schon von anfang an).


    Dennoch wäre es interessant zu erfahren, wieso es die interne Sicherrungswiederherstellung gibt, wenn die nicht richtig geht!


    Habe das jetzt mal ein paar mal getestet, mit immer dem gleichen Ergebnis, das er auf die "web.mdb" nicht zugreifen kann, da sie geöffnet ist (sowohl bei ZP 9 und 10).


    Ist ja auch irgendwie logisch, da das Projekt ja zu diesem Zeitpunkt geöffnet ist.


    Wenn man hingegen die Wiederherstellung in ein neues Projekt macht, geht es problemlos > Auch logisch, da das neue Projekt zu diesem Zeitpunkt ja auch noch leer ist!


    Liebes Zeta-Team, es wäre nett dazu mal eine Aussage zu bekommen, ob das ein geduldeter Bug ist, oder wie man das zu verstehen hat.


    Ist nähmlich eine ganz schöne Falle!


    Und wenn es gehen würde wäre es ja eigentlich ganz schön praktisch > Wenn man mal kurz was testen möchte und dies ruckizucki wieder rückgängig machen möchte, ohne immer wieder ein neues Projekt zu wiederherstellen......


    Schöne Grüße
    Jochen

  • Hallo Daniel,


    vielen Dank für die Aussage!


    Somit weiß man jetzt erstmal bescheid über das Thema.


    Hoffentlich kriegt Ihr das hin, da es ja wie gesagt, an sich ein sehr nützliches Feature wäre.


    Gruß
    Jochen

  • Hallo Zeta-Team und Zeta Producer Kollegen,


    habe seit dem Update auf die Version 10.5.0.22 jetzt folgendes festgestellt beim Punkt "Sicherung > Wiederherstellen eines Projektes":


    1.Die Möglichkeit (die ja eh nicht funktionierte) "Die aktuelle Webseite überschreiben" gibt es nicht mehr zur Auswahl > Gut, so ist dieser "Schönheitsfehler" weg, auch wenn es wünschenswert wäre, wenn dies vielleicht mal gehen würde....


    2.Wenn ich aber jetzt eine Rücksicherung starte kommt die Fehlermeldung, die man im anhängenen Bild sehen kann.
    Desweiteren habe ich als Text-Datei die Details der Fehlermeldung angefügt.


    Fragen dazu:


    - Haben auch andere dieses Problem, oder nur ich?
    - Liegt es am Update?
    - Was kann man machen?


    Vielen Dank und schöne Grüße
    Jochen

  • Hallo Jochen


    Bitte entschuldige, das sieht nach Bug aus.


    Ich werde mir das anschauen, als Notlösung wäre folgender Vorschlag:

    • Du erstellst vom jetzigen Projekt im Dateisystem eine Kopie,
    • Dann öffnest Du das Backup-ZIP-Archiv mit einem ZIP-Tool (also einfach dem Windows Explorer z.B.)
    • Kopiere den Inhalt des Archivs entsprechend passend in die Kopie Deines Projekts im Dateisystem


    Dadurch sollte er alles durch den Inhalt ersetzen und die nicht mitgesicherten Elemente kommen dann aus der Kopie des Projekts.


    Gruß
    Uwe

  • Hallo Uwe,


    danke für die schnelle Antwort und das aufzeigen einer Notlösung!


    Ist jetzt aber kein Notfall bei mir ;-)
    Ist mir halt nur aufgefallen beim testen der 22`er Version.


    Ich betreibe das Sichern meiner Projekte sowieso auf einem anderen Weg.


    Wäre aber natürlich schon schön, wenn das ZP eigene Backup+Wiederherstellen wieder gehen würde.


    Wenn es ein Fix dazu geben sollte wäre es schön, wenn das hier gepostet werden könnte.


    Apropos Fix und Posten.... Wie wäre es eigentlich hier im Forum mit einer "Version-History" der Updates, wo
    man sieht was gefixt, oder sonst gemacht bzw. geändert wurde?


    Gruß
    Jochen

  • Hallo,


    kurz zur Info:


    Habe die letzten Tage mal zum testen ZP auf 3 Rechnern (Win7, Vista und XP) installiert und
    alle zeigen das gleiche Problem!


    Wäre schön, wenn das beim nächsten Update behoben werden würde.


    Gruß
    Jochen