Fehlermeldung Kontaktformular

  • Hallo


    wenn jemand das Kontaktormular absendet erscheint bei ihm die Fehlermeldung "Der Server unter nachricht-erfolgreich-gesendet.html konnte nicht gefunden werden.". Trotzdem erhalte ich das Kontakt Email. Wo liegt der Fehler und wie kann ich den Fehler beheben?


    Freundliche Grüsse
    Hans Schweizer

  • Hallo,


    bei den Formularen muss eine Seite für das erfolgreiche Versenden und für das "misslungene" Versenden angelegt sein. Diese wird dann angesprungen. Das Formular wird, wenn die Seiten nicht angelegt wurden, trotzdem versendet, führt aber zu der Fehlermeldung.




    Bitte nochmals die Formulardaten überprüfen, ob die Rücksprungadressen richtig sind bzw. ob auch die HTML-Seiten wirklich existieren.


    Gruß Robert



    P.S. die Anfrage gehört eigentlich unter die allgemeinen Probleme und nicht zu "Tipps & Tricks"

  • Hallo Robert


    Danke für die schnelle Hilfe. Ja, die Rückantwort Seiten sind im Server direkt im html Verzeichnis vorhanden, so wie sie von Zeta Producer erstellt worden sind.


    Wie müssen die Rücksprung Adressen heissen und wo überprüfe ich das? Sind die auf dem Kontaktformular vorhanden oder wo sonst?


    Habe im Source Code Kontakt folgende Zeilen gefunden:


    <script type="text/javascript">
    function Form256Validate()
    {
    if (document.form256.F1.value == "")
    {
    alert('Bitte füllen Sie dieses Feld aus. ' + document.form256.NAME1.value);
    document.form256.F1.focus();
    return false;
    }
    if (document.form256.F2.value == "")
    {
    alert('Bitte füllen Sie dieses Feld aus. ' + document.form256.NAME2.value);
    document.form256.F2.focus();
    return false;
    }
    if (document.form256.F3.value == "")
    {
    alert('Bitte füllen Sie dieses Feld aus. ' + document.form256.NAME3.value);
    document.form256.F3.focus();
    return false;
    }


    return true;


    Hat das was damit zu tun? Muss ich da was ausfüllen?? Wenn ja was und wie?


    Gruss Hans

  • Hallo,


    du musst den Artikel "Formular" bearbeiten. Rechts unten siehst du einen Button mit drei Punkten. Darauf musst du klicken, dann öffnet sich das Fenster Forumlar auswählen. Dann auf Bearbeiten klicken dann kommst du auf das Fenster Formulare verwalten. Dort dann dein Kontaktformular selektieren und wieder auf bearbeiten klicken.


    Bei den URLs sieht du dann die jeweiligen HTML-Seiten die angesprungen werden. Diese müssen auch vorhanden sein.


    Gruß Robert


    P.S. gib bitte nächstes Mal auch die Adresse der Webseite ein, damit man das Problem sich auch "real" ansehen kann. So kann man dir leichter helfen.

  • Hallo Bernt,


    du hast noch einen Fehler bei den URL`s drin!


    Und zwar steht bei dir z.B bei Nachricht erfolgreich gesendet folgendes drin:


    http://meine-website/system/na…erfolgreich-gesendet.html


    Und das kann so nicht funktionieren.


    Es müsste eigenlich in deinem Fall so heissen: http://neu.motorradfreunde-kgm…erfolgreich-gesendet.html


    Geh nochmal rein in die Formular-Verwaltung und gebe die richtigen URL`s an (einfach die richtigen Seiten auswählen), dann wieder dein Projekt neu ertstellen und veröffentlichen.


    Viel Glück


    Gruß
    Jochen

  • Hallo Jochen,


    dasss versuche ich schon in zigfacher Ausfertigung; aber es funzt net. Also mach ich doch irgend etwas falsch. Würde es helfen, das Kontaktformular einmal zu löschen und wieder neu anzulegen?


    Wenn ich das administriere, dann gehe ich in das Feld "URL" und klicke dann unter SYSTEM die Seite NACHRICHT-ERFOLGREICH-GESENDET.HTML an. Das sieht genauso aus, wie wenn ich die "Suche-Seite" anklicken möchte; nur, bei der Suche funzt es, bei der Nachricht-erfolgreich-gesendet nicht. Dabei ist die Seite dort vorhanden, wo die anderen auch sind.


    Was mache ich falsch?????

  • Hallo Bernt,


    in der Tat wäre es wohl am besten ein komplett neues Kontatkformular zu erstellen und das
    dann an die dementprechende Stelle deiner Seite einzubauen.


    Irgendwas stimmt nähmlich an deiner Zuordnung immer noch nicht!


    Und manchmal ist es besser und schneller, einfach einen kurzen Prozess zu machen,
    und das fehlerhafte Fomular zu löschen und ein neues zu erstellen.


    Dann wird es bestimmt auch klappen!


    Gruß
    Jochen