Falsche Darstellung in Browser

    • Offizieller Beitrag

    Hallo,

    folgendes könnte/müsste Abhilfe schaffen:


    1. Menü Website > Erweitert > Attribute
    2. Das Attribut „mobile_script“ zum Bearbeiten öffnen.


    Wie man mit Attributen arbeitet, kann in der Online-Doku nachgelesen werden: homepage-erstellen-mit-desktop…oducer.com/attribute.html


    Darauf achten, das bei den Attributen "Alle anzeigen" ausgewählt ist.


    3.In das Attribut dann folgendes eintragen:


    <style>
    .flex-container {
    position: absolute;
    }
    </style>


    4. Dann die Attribute verlassen und danach die Website neu erstellen
    5. Dann veröffentlichen und überprüfen.


    Beim überprüfen dann auch testen ob die anderen Browser es dann noch korrekt anzeigen.
    (Ich habe das jetzt eben auf die Schnelle nicht überprüft)

    • Offizieller Beitrag

    Hallo nochmal,


    ich glaube ich seh schon, was da in Firefox falsch dargestellt wird. Das müssen wir mal im Detail ansehen. Dazu benötigen wir Ihr Projekt. Könnten Sie uns das Projekt bitte zusenden?


    • Öffnen Sie Ihr Projekt in Zeta Producer
    • Gehen Sie auf das Menü "Extras"
    • Klicken Sie auf den Button "Optionen"
    • Klicken Sie auf "Aktionen"
    • Klicken Sie rechts auf die Aktion "Projekt Senden" damit diese Markiert ist
    • Klicken Sie unten auf den Button "Ausführen"
    • Geben Sie im 1. Feld Ihre E-Mail-Adresse ein, damit wir Sie für Rückfragen kontaktieren können
    • Geben Sie als Referenz ins Feld Bemerkungen den Link zu diesem Forum-Artikel ein (per Kopieren und Einfügen)
    • Klicken Sie auf den Button "Senden"
    • Während wir an Ihrem Projekt arbeiten, sollten Sie bei sich keine Änderungen durchführen, denn sonst müssten Sie das ggf. nochmals im von uns modifizierten Projekt durchführen.
    • Offizieller Beitrag

    Hallo,
    ich habe Ihr Projekt erhalten. Sie hätten mir etwas Sucherei erspart, wenn Sie Punkt 8 von oben auch beachtet hätten ;)


    Ich kann das Fehlverhalten mit dem Layout Stripe-Responsive in Firefox nachvollziehen. Der Fehler tritt nur auf, wenn eine Seite auch Artikel im "Banner"-Bereich enthält (da haben Sie Ihr Logo platziert). Den Fehler kann ich aber z.B. in "Contemporary Responsive" nicht nachvollziehen. Ich kann Ihre Aussage "tritt in allen responsive Layouts auf" so also nicht bestätigen.


    Es handelt sich hier mit 99%iger SIcherheit um einen Fehler in Firefox. Wir hoffen, dass dieser zeitnah behoben wird. Bis dahin habe ich folgenden Workaround für Sie:

    • Klicken Sie im Menü Website auf "Erweitert > Attribute"
    • Stellen Sie sicher, dass unten links im Button "Attribute" die Option "Alle anzeigen" angehakt ist
    • Doppelklicken Sie nun in der Liste der Attribute unter "Standard" auf das Attribut "mobile_script"
    • Fügen Sie folgende Textzeilen (ohne Überschrift und ohne Zeilennummern – am besten über das Dokumente-Icon rechts oben im Quellcode-Kasten kopieren) ein und schließen Sie den Dialog dann mit Klick auf "OK"


    CSS
    <style>
    .mozilla .banner #header{margin-top: 0;}
    </style>


    Anschließend müssen Sie evtl. Ihre Seiten neu erstellen (Erweitert > Erstellen > Alle Seiten erstellen) und ggf. veröffentlichen.

  • Hallo,


    ich hab zwar nicht alle (Responsive) Layouts durch, kann aber insoweit bestätigen, dass das Fehlverhalten bei den von mir getesteten Layouts offenbar nur bei Stripe Responsive auftritt.
    Etwas komisch finde ich es nur, dass es bei Producer Responsive nicht auch auftritt. Zumindest die Header sind m.E. so gut wie identisch aufgebaut und es wird bestimmt nicht bei jedem Layout Header ein anderer Code verwendet. Eigentlich hier müsste Firefox doch den selben Fehler anzeigen oder nicht, wenn es denn ein Browserfehler sein sollte?