12.5 - Falscher Dateityp vergeben

  • Beim öffnen eines Projekts aus 12.2 in 12.5 kommt die Meldung: Falscher Dateityp vergeben. Bitte vergeben Sie in den Seiteneigenschaften dieser Seite den Dateityp ".php"


    Unter 12.2 funktioniert das Projekt fehlerfrei.


    Es sind anscheinend alle Seiten betroffen. Die Seiten können nicht erstellt werden.


    Ein anderes Projekt aus 12.2 konnte Problemlos in 12.5 übernommen werden.


    Auch der Neustart von ZP 12.5 brachte keine Verbesserung.

  • Hallo,


    prüfen Sie bitte ob Sie auf den entsprechenden Seiten nicht doch ein entsprechendes Widget platziert haben, das PHP benötigt. Dies könnte zum Beispiel das Widget "Geschützter Bereich" sein, oder auch der Warenkorb etc…


    Evtl. wurde ein solches Widget aus Versehen auf alle Seiten vererbt und verursacht so nun die Fehlermeldung.
    Die Widgets können Sie in der Spaltenansicht (F8 drücken) ja schnelll entdecken, auch wenn die Seite sonst Fehler verursacht.

  • Hallo Herr Seiz


    Stimmt, ich habe auf allen Seiten eine Warenkorb-Anzeige.


    Ist das in 12.5 anders als in 12.2? In der Version 12.2 funktionieren alle Seiten mit Warenkorb-Anzeige als .html

  • Hallo,


    ja, das hat sich geändert. Ist es Ihnen möglich für alle Seiten den Dateityp entsprechend auf PHP umzustellen oder haben Sie zu viele Seiten?

  • So viele Seiten sind es nicht.


    Noch eine Frage dazu. Macht es Suchmaschinentechnisch einen Unterschied? Bzw. muss/soll man die "neuen" .php Seiten auf die alte .html per .htaccess umleiten?

  • Eine Frage hat sich zu diesem Projekt noch ergeben. Es ist kein Favicon mehr vorhanden. Habe es im Layout Designer neu importiert, ändert jedoch nichts. Auch im Quelltext fehlt der Eintrag. Bei den anderen Projekten ist das Favicon vorhanden.

  • Hallo,


    ja, eine Umleitung von den alten URLs aus würde sich empfehlen. Um das mit dem Favicon zu prüfen, muss ich zunächst wissen, welches Layout Sie nutzen?

  • Hallo,


    falls Ihr favicon "favicon.ico" heißt, versuchen Sie bitte mal den Dateinamen zu ändern, z.B. in "favicon-softplus.ico" und es dann über die Layout-Einstellungen nochmals auszuwählen. Klappt das?

  • Hallo,


    ich konnte eben feststellen, dass es sich hier um einen Bug in den Layouts "Panorama Responsive" und "Modern Responsive" handelt. Wird in den nächsten Tagen per Layout-Online-Update behoben werden.


    Besten Dank!

  • Jetzt habe ich mit einem Projekt mit Dokumentation Responsive auch das fehlende Favicon. Mit der lokalen Vorschau hat es funktioniert. Nach dem Upload in ein Testverzeichnis ist es weg.

  • Hallo,


    das muss andere Ursachen haben. Haben Sie mir die URL zu der Seite im Testverzeichnis? Bei Favicons müssen Sie aufpassen. Manche Browser cachen hier derart aggressiv und nicht nachvollziehbar.

  • Sorry, war ein Browserproblem. Nach Cacheentleerung passt es wieder. Habe das wegen den vorigen Faviconproblemen mit dem anderen Layout falsch eingeordnet.


    Danke.