Sonderzeichen werden auf veröffentlichter Website falsch dargestellt (Zeichenkodierung stimmt nicht)

  • Hallo ZP-Supportteam,


    soeben haben wir unsere Homepage auf unserem hauseigenen Testserver veröffentlicht,
    doch leider werden sämtliche Sonderzeichen falsch dargestellt - es stimmt also die Zeichenkodierung nicht.


    Nun wäre meine Frage:
    Wo und wie muss ich die Kodierung ändern, um eine korrekte Zeichendarstellung zu gewährleisten?



    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Mit freundlichen Grüßen,


    Jan Bergmeister
    Computer OASE Geislingen

  • Stellen Sie sicher, dass Ihr Webserver auch auf UTF-8 gestellt ist und nicht etwa im HEADER einen anderen Zeichensatz angibt.


    Falls Sie die Standard-Kodierung des Webservers nicht auf UTF-8 ändern können, dann sollten Sie den Webserver wenigstens so einstellen, dass er im Header keinerlei Kodierung sendet, dann stimmt die Darstellung der mit ZP generierten Webseiten auch.

  • Webserver ist nach Anruf bei unserem Provider auf UTF-8 gestellt worden,
    leider ließ sich das Problem auf diese Weise nur auf ein paar Seiten (Start- und 2-3 weitere Seiten) beheben.


    Irgendwelche Lösungsvorschläge?



    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Mit freundlichen Grüßen,


    Jan Bergmeister
    Computer OASE Geislingen

  • Also in meinem Browser schaut http://dev.comp-oase.de/index.html korrekt aus.


    Auch der Response-Header von Deinem Server schaut korrekt aus:

    Code
    HTTP/1.1 200 OK
    Date: Wed, 03 Jun 2015 14:21:05 GMT
    Server: Apache
    Last-Modified: Wed, 03 Jun 2015 11:25:59 GMT
    ETag: "170832-3b4b-52bc5fc0"
    Accept-Ranges: bytes
    Content-Length: 15179
    Keep-Alive: timeout=15, max=100
    Connection: Keep-Alive
    Content-Type: text/html; charset=UTF-8

    Auf z.B. http://dev.comp-oase.de/aerzte.php ist der Response-Header "falsch":

    Code
    HTTP/1.1 200 OK
    Date: Wed, 03 Jun 2015 14:22:22 GMT
    Server: Apache
    Content-Encoding: gzip
    Vary: Accept-Encoding
    Keep-Alive: timeout=15, max=99
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=iso-8859-1

    Dort ist in Zeile 9 ein falsches Charset drin. (iso-8859-1 statt UTF-8 wie oben).


    Ggf. hängt das damit zusammen, dass es eine PHP-Datei ist?

  • Bitte mal prüfen, was unter "Erweitert > Erweiterte Einstellungen > Kodierung" eingestellt ist.


    Dort sollte bei "Kodierung:" utf-8 gewählt sein und der Haken bei der Option "BOM schreiben" sollte entfernt werden.


    Falls Sie da Änderungen machen müssen, sollten Sie danach alle Seiten neu erstellen > "Erweitert > Erstellen > Alle Seiten erstellen" und veröffentlichen.

  • Eventuell hat der Provider auch nur die Codierung für .html-Dateien umgestellt und müsste dies auch noch für .php-Dateien tun.

  • Danke für die Lösungsvorschläge, werde mich unverzüglich mit unserem Provider in Verbindung setzen und abklären,
    ob das Charset auch für PHP umgestellt wurde - bis jetzt sieht es aber tatsächlich danach aus, als ob nur die Kodierung für HTML-Dateien korrigiert wurde.


    Eine Frage hätte ich aber noch:

    Zitat

    Bitte mal prüfen, was unter "Erweitert > Erweiterte Einstellungen > Kodierung" eingestellt ist.


    Dort sollte bei "Kodierung:" utf-8 gewählt sein und der Haken bei der Option "BOM schreiben" sollte entfernt werden.

    Wo finde ich dieses Menü? Ist von einer Einstellung im ZP oder am Server die Rede?



    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Mit freundlichen Grüßen,


    Jan Bergmeister
    Computer OASE Geislingen

  • Wo finde ich dieses Menü? Ist von einer Einstellung im ZP oder am Server die Rede?

    Dieses Menü findest Du in ZP.


    Falls das alles nicht hilft, kannst Du in die .htaccess folgendes einfügen:


    # Beginn UTF 8
    AddCharset UTF-8 .html
    AddCharset UTF-8 .php
    # Ende UTF 8

  • Problem gelöst, in der PHP.ini war wie bereits von euch vermutet noch das falsche Charset eingestellt - dies wurde nun nachgebessert.


    Danke für die Hilfe, das Thema kann geschlossen werden :)



    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Mit freundlichen Grüßen,


    Jan Bergmeister
    Computer OASE Geislingen