Vererbung

  • Es geht hier um die HP www.dogscout-aurich.de .
    Also ich habe den CSS Code für den Hover Social Media 4 über die Einstellungen> CSS eingefügt. Dann den Quelltext eingesetzt und da passte alles. Habe aber zwei Seiten weiter das Problem, wenn ich den Quelltext setze die position der Butons mittig auf der Seite gesezt werden... ich weiss dass ich einige Seiten verschoben habe( im Arhitektursverzeichnis) aber irgendwie bekomme ich auf diese Seiten die Social Media Widget nicht so wie auf den anderen, als musste ich bis zur lösungsfindung entfernen. Ziel ist ein einheitliches Layout wie auf der Startseite zu bekommen.


    Hoffe deutlich erklärt zu haben....danke für die Mühe, jedoch die zwei Seiten aus dem Onlinehandbuch konnten nicht helfen...

  • Hallo,


    wenn Sie den CSS-Code über "Einstellungen > CSS" eingegeben haben, so gilt der automatisch für alle Seiten. Durch diese Eingabe wird im Hintergrund ein globales Attribut "additional_css" angelegt. Sollten Sie dieses Attribut seitenspezifisch bearbeitet/geändert haben, so hätte würde entsprechende Seite dann eigenes CSS nutzen (abweichend vom globalen Attribut bzw. "Einstellungen > CSS").


    Evtl. können wir mehr im Code der entsprechenden Seiten erkennen. Wie ist die URL zu der Seite, die korrekt dargestellt wird und wie ist die URL zu der Seite bei der die Darstellung nicht korrekt ist?

  • Hallo,


    also, die Seiten mit der "falschen" Darstellung scheinen ja nicht wirklich "falsch" dargestellt zu werden, sondern da Fehlen die Social-Icons schlicht komplett.


    Ich vermute Sie haben den Code mit den Icons (denn die kommen anscheinend von zella.de) über einen Quelltext-Artikel eingegeben. Wenn die Icons also auf bestimmtem Seiten nicht angezeigt werden, dann fehlt auf diesen Seiten schlicht der entsprechende Artikel. Falls er vererbt wurde, könnte "Extras > Optionen > Aktionen > Vererbte Artikel neu berechnen" evtl. helfen. Mehr Infos über das Vererben: https://docs.zeta-producer.com/v12/inhalte-vererben.html

  • Der Code ist syntaktisch nicht korrekt. Da können wir leider nicht weiter helfen, da dieser Code ja nicht von uns stammt.

  • Hallo Tomi,
    der verwendete Code stammt von mir. Ich bin allerdings zur Zeit in Singnapur und nur mit Smartphone bewaffnet.
    Ich bin am Montag wieder zurück. Allerdings stürzt nach 2 Wochen Abstinenz so einiges auf mich ein. Schreib mich einfach Anfang der Woche nochmal an, am besten mit Link zu diesem Beitrag. Dann versuche ich gern das auszumerzen.


    Es müsste dann allerdings eine Seite mit dem Fehler vorhanden sein.

  • Hallo Tomi,
    der verwendete Code stammt von mir. Ich bin allerdings zur Zeit in Singnapur und nur mit Smartphone bewaffnet.
    Ich bin am Montag wieder zurück. Allerdings stürzt nach 2 Wochen Abstinenz so einiges auf mich ein. Schreib mich einfach Anfang der Woche nochmal an, am besten mit Link zu diesem Beitrag. Dann versuche ich gern das auszumerzen.


    Es müsste dann allerdings eine Seite mit dem Fehler vorhanden sein.

    Hallo Mario,
    besten Dank für deine Hilfeleistung schon mal im voraus. Ich werde mich bei dir auf jeden fall melden, und du kannst soweit du zeit hast dementsprächend zurück melden. Ich denke wir werden das schon irgenwie hin bekommen, obwohl ich


    Der Code ist syntaktisch nicht korrekt. Da können wir leider nicht weiter helfen, da dieser Code ja nicht von uns stammt.

    dieser Aussage an sich vertraue, jedoch das merkwürdige ist, dass nur auf bestimmte Seiten die Funktionalität des Codes nicht gegeben ist... na ja für mich als Anfänger im ZP, etwas unerklärlich... mache gerade einen neuen Projekt mit dem Layout und dann werde ich berichten...erstmal wird das Layout soweit fertiggestell und dann der Inhalt mit Text gefüllt...mene Vermutung ist dass ich dort etwas anders gemacht habe, bzw. die neu angelegten Seiten nicht richtig zugewiesen habe. Bei dem jetzigen Projekt werde ich die Seiten nicht aus dem Strukturverzeichnis löschen oder neue dazu hinzufügen, wenn das dann klappt bin ich meinem Fehler etwas näher dran...

  • Der Code ist syntaktisch nicht korrekt. Da können wir leider nicht weiter helfen, da dieser Code ja nicht von uns stammt.

    Hallo Herr Seiz,
    also ich habe nochmal den Code überprüft. Also meiner Meinung nach besteht da keine Grund zu sorge, dass der Code Falsch ist. Ich habe festgestellt dass der Fehler in der Layoutprogramierung sitzen muss, denn die erste Seite(Wurzelseite) läuft perfekt so wie man sie auch programiert, jedoch die Vererbung desen auf die anderen Seiten fünktioniert nicht richtig. Hier kann ich noch nicht nachvollziehen woran es liegen kann, jedoch vielleicht eine Unterstützung seitens der ZP Programierer wäre wünschenswert.

  • Senden Sie mir bitte das Projekt, damit ich das ansehen kann. Folgen Sie bitte folgender Anleitung:


    • Öffnen Sie Ihr Projekt in Zeta Producer
    • Gehen Sie auf das Menü "Extras"
    • Klicken Sie auf den Button "Optionen"
    • Klicken Sie auf "Aktionen"
    • Klicken Sie rechts auf die Aktion "Projekt Senden" damit diese Markiert ist
    • Klicken Sie unten auf den Button "Ausführen"
    • Geben Sie im 1. Feld Ihre E-Mail-Adresse ein, damit wir Sie für Rückfragen kontaktieren können
    • Geben Sie als Referenz ins Feld Bemerkungen den Link zu diesem Forum-Artikel ein (per Kopieren und Einfügen)
    • Klicken Sie auf den Button "Senden"

    Während wir an Ihrem Projekt arbeiten, sollten Sie bei sich keine Änderungen durchführen, denn sonst müssten Sie das ggf. nochmals im von uns modifizierten Projekt durchführen.

  • Senden Sie mir bitte das Projekt, damit ich das ansehen kann. Folgen Sie bitte folgender Anleitung:


    • Öffnen Sie Ihr Projekt in Zeta Producer
    • Gehen Sie auf das Menü "Extras"
    • Klicken Sie auf den Button "Optionen"
    • Klicken Sie auf "Aktionen"
    • Klicken Sie rechts auf die Aktion "Projekt Senden" damit diese Markiert ist
    • Klicken Sie unten auf den Button "Ausführen"
    • Geben Sie im 1. Feld Ihre E-Mail-Adresse ein, damit wir Sie für Rückfragen kontaktieren können
    • Geben Sie als Referenz ins Feld Bemerkungen den Link zu diesem Forum-Artikel ein (per Kopieren und Einfügen)
    • Klicken Sie auf den Button "Senden"

    Während wir an Ihrem Projekt arbeiten, sollten Sie bei sich keine Änderungen durchführen, denn sonst müssten Sie das ggf. nochmals im von uns modifizierten Projekt durchführen.

    Herr Seiz als erstes möchte ich mich erstmal für die schnelle Antwort bedanken, das Projekt ist unterwegs zu Ihnen. Ich hoffe es ist nichts was lange aufhalten wird.

  • Ich hab Ihre Website nochmal durchgesehen und der Code auf der Startseite ist definitiv ein anderer als z.B. auf der Seite "Aktuelles". Alle Codes sind voll von Syntax-Fehlern. Ich schlage folgende Lösung vor:


    • Löschen Sie all die Quelltext-Artikel, die die Social-Media-Buttons enthalten auf allen Seiten weg
    • Wechseln Sie dann auf die Startseite und fügen Sie am ende der Seite einen Quelltext-Artikel ein
    • Setzen Sie folgenden Quelltext (ohne Überschrift und ohne Zeilennummern – am besten über das Dokumente-Icon rechts oben im Quellcode-Kasten kopieren) in den Artikel ein:
    • Klicken Sie im Quelltext-Artikel unten links auf das Mischpult-Icon und aktivieren Sie die Option "Auf allen Seiten anzeigen"
    • Veröffentlichen Sie die Seiten neu


    Hier handelt es sich lediglich um verschiedene Artikel mit fehlerhaftem HTML-Code und nicht um eine Fehlfunktion in Zeta Producer.

  • Ich hab Ihre Website nochmal durchgesehen und der Code auf der Startseite ist definitiv ein anderer als z.B. auf der Seite "Aktuelles". Alle Codes sind voll von Syntax-Fehlern. Ich schlage folgende Lösung vor:


    • Löschen Sie all die Quelltext-Artikel, die die Social-Media-Buttons enthalten auf allen Seiten weg
    • Wechseln Sie dann auf die Startseite und fügen Sie am ende der Seite einen Quelltext-Artikel ein
    • Setzen Sie folgenden Quelltext (ohne Überschrift und ohne Zeilennummern – am besten über das Dokumente-Icon rechts oben im Quellcode-Kasten kopieren) in den Artikel ein:
    • Klicken Sie im Quelltext-Artikel unten links auf das Mischpult-Icon und aktivieren Sie die Option "Auf allen Seiten anzeigen"
    • Veröffentlichen Sie die Seiten neu


    Hier handelt es sich lediglich um verschiedene Artikel mit fehlerhaftem HTML-Code und nicht um eine Fehlfunktion in Zeta Producer.

    Ok danke schön, aber wie kommt den das nur auf bestimmet Seiten und auf anderen nicht? der Quellcode bwurde über die Wurzelseite vererbt...
    Auch egal, wenn das dann hilft bin ich zufrieden..aber nicht desto trotz besten Dank für ihre Mühe....ach so...ich finde Zeta Producer gut... :love: :love: :love: :thumbsup: :thumbsup: :thumbsup:

  • Sie vererben es von der Wurzelseite aus (das meinte ich mit auf der Startseite einfügen und "auf allen Seiten anzeigen" markieren). Auf den Seiten auf denen es nicht auftauchen soll, löschen Sie den vererbten Artikel einfach weg.

  • Sie vererben es von der Wurzelseite aus (das meinte ich mit auf der Startseite einfügen und "auf allen Seiten anzeigen" markieren). Auf den Seiten auf denen es nicht auftauchen soll, löschen Sie den vererbten Artikel einfach weg.


    in der Tat das hatte ich auch so gemacht....als ich das Code reinsetzte war ich begeister bis auf....mal wieder zwei Seiten wo der Abstand zwischen den Icons doppelt so gross war wie normal...Die Positionierung stimmte schon mal...ich war am überlegen welche Verwirrtheit mich zu solche Entschlüsse geführt haben sollte... also fing ich mit systematische Logik an und vergliech die Seiten..und siehe da der Fehler war ech banal...natürlich durch Unwissenheit produziert - an dieser Stelle möchte ich sagen ich arbeite erst seit ca einer Woche so richtig mit dem System und ist mein erster WEB Prjekt-..... Die Atributte waren auf mancher Seite sehr unterschiedlich und zum Teil mit Codesüberrest aus vorherigen Versuche.
    Nach der Bereinigung läuft es wunderbar. Danke!


    Eine Frage noch zu dem geschriebenen Code, wenn man die Funktion des URL in einem neuen Fenster öffnen lassen möchte, ist es zu viel Arbeit/ bzw. zu aufwändig das Ganze?


    Hallo Tomi,
    der verwendete Code stammt von mir. Ich bin allerdings zur Zeit in Singnapur und nur mit Smartphone bewaffnet.
    Ich bin am Montag wieder zurück. Allerdings stürzt nach 2 Wochen Abstinenz so einiges auf mich ein. Schreib mich einfach Anfang der Woche nochmal an, am besten mit Link zu diesem Beitrag. Dann versuche ich gern das auszumerzen.


    Es müsste dann allerdings eine Seite mit dem Fehler vorhanden sein.

    Ach so Mario, besten dank für deine Hilfsbereitschaft! Deine Codes sind echt klasse, nur die Anwender müssen da noch was machen...ich weis...ich bilde mich noch weite... 8o 8o 8o


    Bis bald...