Fehlermeldung bei Absenden eines Formulars

  • Hallo Zeta-Community,


    beim Test meines neu eingerichteten Formulars habe ich folgendes Problem:
    Nach Ausfüllen, ReCaptcha-Prüfung und "Absenden" erscheint


    http://panoramaferienwohnung-g…er/SendEmailReCaptcha.php


    mit dem Inhalt:


    ZUGRIFF NICHT ERLAUBT
    Die angeforderte Seite darf nicht angezeigt werden.


    Versand des Formulars erfolgt nicht.


    Mein Hoster: 1und1


    Zum Testen: Die Seite ist derzeit über die Sitemap>Kontakt>Reservierungsanfrage.... zugänglich



    Was mache ich falsch? ?(

  • Ok, dann kontrolliere mal mit einem FTP-Programm, wie z.B. www.filezilla.de ob du auch wirklich die Berechtigungen für das erwähnte Verzeichnis hast.


    Wenn nicht, dann stelle diese mal dementsprechend um.
    Ich meine müsste "777" sein.

  • Guten Morgen @OpaPit & @Jochen,


    ich bin selbst bei 1&1 und habe für das php Verzeichnis die Rechte 705. Probeweise eben geändert auf 755, wie von @OpaPit beschrieben, Kontaktformular mit neuem Recaptcha läuft, getestet auf PHP 5.6 bei 1&1 Unlimited pro.


    @OpaPit: Du hast ja einige Widgets von @ThM mit integriert. Deaktiviere diese mal probeweise für die Kontaktseite. Poste dann hier bitte noch, welchen Tarif Du bei 1&1 hast.

  • Hallo,


    "SendEmailReCaptcha.php" weist darauf hin, dass hier das neue, benutzerfreundlichere Captcha im Formular eingestellt wurde. Es kann vorkommen, dass die dazu benötigten Dateien noch nicht alle veröffentlicht sind und dann könnte ein solcher Fehler auftreten. Um sicherzustellen, dass alles veröffentlicht ist, entweder prüfen, ob "SendEmailReCaptcha.php" auf dem Server unter "/assets/php/formmailer/" vorhanden ist, oder einfach proaktiv "Erweitert > Erstellen > Alle Seiten erstellen" und dann "Veröffentlichen".

  • Hallo,

    prüfen, ob "SendEmailReCaptcha.php" auf dem Server unter "/assets/php/formmailer/" vorhanden ist

    > ist in diesem Verzeichnis vorhanden.



    Du hast ja einige Widgets von @ThM mit integriert. Deaktiviere diese mal probeweise für die Kontaktseite

    Widget ZPW-Google-Translate für die Formularseite gelöscht, die anderen erstmal nicht, weil sie keine externen Verbindungen nutzen.



    Habe dann "alle Seiten erstellt", komplette Seite veröffentlicht.
    Ergebnis: Im ersten Beitrag beschriebene Fehlermeldung bleibt.


    Beim Veröffentlichen gibt ZETA folgende Fehlermeldung aus:


    Script error
    Zeile 0
    https/www.gstatic.com/recaptcha/api2/r20160411084021/recaptcha_de.js


    Da liegt wohl der Hase im Pfeffer...


    Ich habe auf
    https://developers.google.com/…-site-key-whats-happening
    recherchiert.


    Dort heißt es:


    The reason you are seeing this error is because you referenced an obsolete reCaptcha JS code exampled below:
    /* DO NOT include the following in your code! */
    (function() {
    if (!window['___grecaptcha_cfg']) {
    window['___grecaptcha_cfg'] = {};
    };
    if (!window['___grecaptcha_cfg']['render']) {
    window['___grecaptcha_cfg']['render'] = 'onload';
    };
    window['__google_recaptcha_client'] = true;
    var po = document.createElement('script');
    po.type = 'text/javascript';
    po.async = true;
    po.src = 'https://www.gstatic.com/recaptcha/api2/r20150114143013/recaptcha__en.js';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(po, s);
    })();
    Instead, you should only include this line in your code:


    <script src="https://www.google.com/recaptcha/api.js"></script>



    Letzteren Script habe ich unter "Einstellungen>CSS" eingegeben.
    Ergebnis: Gleiche Fehlermeldung wie ganz oben beschrieben


    Was kann ich tun?

  • Hallo,


    haben Sie in den Formulareinstellungen auch die beiden Schlüssel für das neue reCaptcha eingetragen? Diese sind unbedingt erforderlich. Ich würde auch mal vorschlagen, dass Sie zunächst Stufenweise vorgehen, und erst mal das ganz normale Formular (ohne Captcha) verwenden (Skript: Via PHP), damit können wir mehr andere Fehler ausschließen und wenn das dann läuft, kann man ja weiter ändern…

  • Hallo,
    Problem gelöst.


    Meine Inklusiv-Domain bei meinem bisherigen DSL-Paket bei 1und1 bietet keine php-Option. Das sagte mir der 1&1-Support.


    Warum zeta-producer unter "Optionen>Aktionen>Websitesfeatures prüfen" trotzdem OK gegeben hat, wäre von ZETA zu überprüfen.


    Ich habe jedenfalls das Hosting-Paket "1&1 Unlimited Plus" dazugebucht.
    Jetzt läuft die Formularversendung.
    Danke für Euer Engagement

  • Hallo OpaPit,


    sehr gut :thumbup:
    Jetzt komme ich auch auf die PHP-Seite, die davor blockiert worden ist.


    Was mir aufgefallen ist: Ich würde an deiner Stelle, die Punkte "Erfolgreich versendet" und "Konnte nicht zugestellt werden" aus deiner Sitemap entfernen.
    Die haben da eigentlich nichts zu suchen, oder?