Selbst erstelltes Navigationsmenü wird von Slider überdeckt

  • Guten Morgen liebes Support-Team,


    ich habe über das Widget "Navigationsmenü" eine Navigation erstellt, welche die aus der Vorlage ersetzen soll. Nun habe ich aber gesehen, dass die Untermenüs, nicht komplett angezeigt werden. Die Menüs werden von dem Slider versteckt. Gibt es eine Möglichkeit, die Navigation in den Vordergrund bzw. den Slider in den Hintergrund zu stellen?


    Hier der Link, der Seite: https://hosting.zeta-producer.…a-Radweg-individuell.html


    Vielen Dank schon im Voraus für Eure Hilfe!


    Mit freundlichen Grüßen
    Guido S.

  • Hallo,


    das werden wir im Widget-Code beheben. Bis dahin habe ich aber einen einfachen Workaround für Sie:


    • Klicken Sie im Menü Website auf "Einstellungen"
    • Klicken Sie auf CSS
    • Fügen Sie folgende Textzeilen (ohne Überschrift und ohne Zeilennummern – am besten über das Dokumente-Icon rechts oben im Quellcode-Kasten kopieren) in das Feld "CSS" ein und schließen Sie den Dialog dann mit Klick auf "OK"
    CSS
    1. <style>
    2. .zpnavcontainer{
    3. position: relative;
    4. z-index: 10;
    5. }
    6. </style>


    Anschließend müssen Sie evtl. Ihre Seiten neu erstellen (Erweitert > Erstellen > Alle Seiten erstellen) und ggf. veröffentlichen.

  • Hallo - nun, habe ich doch nochmal eine Frage...



    Ich hatte zuvor das Clean Style Responsive Design und habe nun die Vorlage auf allen Seiten entfernt, sodass alle Seiten "leer" sind. Dann habe ich den Code, wie oben beschrieben eingefügt und die Seiten neu erstellt. Nun wird mir die Navigation aber nicht überall angezeigt und ich muss Sie manuell in jede Seite kopieren. Ich dachte, dass der Code im CSS-Quellcode für alle Seiten gilt - stimmt das oder liege ich da falsch?


    Viele Grüße und besten Dank schon im Voraus für Ihre Hilfe
    Gudio S.

  • Hallo Guido,


    der CSS -Code ist für alle Seiten gültig.
    Das Widget selbst musst du "vererben" das es auf allen Seiten angezeigt wird.
    Das Widget besteht ja aus 2 "Einzelteilen" Logo und "Menü".
    Da in beiden reingehen, dann unten links auf den "Schiebregler" und dann "Auf allen Seiten anzeigen" aktivieren.
    Dies muss du nur auf der "Wuerzelseite" (in der Regel die Startseite) durchführen.
    Es kann aber sein, das du da ein wenig "Nacharbeit" (durch verschieben evtl.) machen musst, wenn die Darstellung nicht stimmen sollte.

  • Guten Morgen Jochen,


    vielen Dank für deine Antwort. Habe nun wirklich alles versucht, aber ich bekomme die Navigation einfach nicht auf die anderen Seiten übertragen. Die Wurzelseite ist die Startseite (musste ich allerdings noch manuell eingeben) und dort habe ich die Navigation, das Logo und die "Überschrift" so eingestellt, wie du es beschrieben hattest - trotzdem funktioniert es nicht.
    Muss ich evtl. bei dem "Schieberegler" nicht nur "Auf allen Seiten anzeigen" aktivieren, sondern bei den Einstellungen die "CSS-Klasse" und/oder "Inline-CSS" auch etwas eingeben?


    Bin langsam echt am Verzweifeln...


    Viele Grüße
    Guido S.


    EDIT:
    Hat sich erledigt - ich habe es nun endlich geschafft :-)
    Vielen Dank!!!

  • Hallo,


    ich habe das gleiche Problem wie Guido jedoch beim Layout "Modern Responsive".
    Habe es wie oben beschrieben mit dme CSS probiert aber funktioniert leider nicht.


    Muss ich bei meinem Layout evtl einen anderen Wert beim z-index angeben oder andere Angabe bei .zpnavcontainer machen?

  • Wenn wir das online nicht sehen, ist es schwierig zu reproduzieren. Bitte die Website dann einfach in eine Testumgebung veröffentlichen.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Das sollte gehen:

    Code
    1. <style>
    2. .zpnavcontainer {
    3. position: relative;
    4. z-index: 999 !important;
    5. }
    6. </style>

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)