CSS-Fehler laut Seitenreport

  • Hi Users,


    bei der Analyse meiner Homepage werden folgende CSS-Fehler angezeigt.


    Frage vorab: kann ich Die irgendwie selbst korrigieren... Wenn ja, wie? Und sind alle Fehler wirklich gravierend?


    .zphyphenate Die Eigenschaft hyphenate-limit-lines existiert nicht : 2 ; Die Eigenschaft hyphenate-limit-chars existiert nicht : auto 3



    .zpgrid[data-numcolumns="6"] .zpColumnItem.c3, .zparea[data-numcolumns="6"] .zpColumnItem.c3, .zpgrid[data-numcolumns="6"] div.zpRow .zpColumn.c4, .zparea[data-numcolumns="6"] div.zpRow .zpColumn.c4, .zpgrid[data-numcolumns="6"] .zpColumnItem.c4, .zparea[data-numcolumns="6"] .zpColumnItem.c4 Einlese-Fehler [ 3 div.zpRow .zpColumn.c3]



    .zp13sliderWidget Die Eigenschaft zoom existiert nicht : 1



    Leider ist die At-Regel @-webkit-keyframes nicht implementiert.



    body Die Eigenschaft text-rendering existiert nicht : optimizeLegibility



    #submenu Ungültige Nummer : background top ist kein color-Wert )


    Versuche ein Semikolon vor dem Eigenschaftsnamen zu finden. Füge es hinzu.


    Die Eigenschaft progid existiert nicht : DXImageTransform


    Einlese-Fehler DXImageTransform.Microsoft.gradient(startColorstr='#fefefd',endColorstr='#f4f2ee',GradientType=0);


    Einlese-Fehler [:1px solid #acd352}ul.submenu]



    #header Ungültige Nummer : background top ist kein color-Wert )


    Versuche ein Semikolon vor dem Eigenschaftsnamen zu finden. Füge es hinzu.


    Die Eigenschaft progid existiert nicht : DXImageTransform


    Einlese-Fehler DXImageTransform.Microsoft.gradient(startColorstr='#f3f3f3',endColorstr='#D9D9D9',GradientType=0);


    Einlese-Fehler [:1px solid #ccc}.flexslider]


    Einlese-Fehler }@page{margin:2cm}


    Einlese-Fehler }}



    .navi


    Ungültige Nummer : display fixed ist kein display-Wert : fixed


    Ungültige Nummer : background-attachment Einlese-Fehler 418


    Ungültige Nummer : background-attachment Einlese-Fehler 431




    Für mich ist das beunruhigend, aber überhaupt nicht zu verstehen... :/



    :(


    Außerdem habe ich angeblich ganz viele Spaghetti-Codes... Ungenügend sagt Seitenreport. Und bei den RSS-Feeds 10 Fehler. Eine gültige Fehlerseite gebe es nicht. Und Summe der ResponseBytes: 3241.22 Kilobytes. Angeblich viel zu viel...



    Besten Dank für Rat, Tat oder sonstige Hilfe!

  • Hallo Heidemann,


    um welche URL geht es denn?


    Grundsätzlich solltest Du dir um Spaghetti und CSS-Fehler erst Gedanken machen, wenn auch Besucher das sind, die die Fehler sehen könnten. CSS-Fehler und Spaghetti haben verschwindend geringen Einfluss auf das Ranking bei Google.

  • Hallo Thomas (ich habe jetzt mal bei Euch ins Impressum geschaut),


    da dürften einige von den angezeigten Fehlern direkt mit bplaced zusammenhängen. Die nachfolgenden Bemerkungen bitte immer unter dem Vorbehalt sehen, dass da bplaced eventuell störend dazwischen funkt:


    1. korrigiere im Control-Center des Providers die Verwendung Deiner Webadresse. Momentan ist diese auf das Rootverzeichnis gerichtet, also " / ". Richtig wäre " /htdocs/ "
    Der Fehler wird sichtbar, wenn Du http://libelle.blaced.net eingibst


    2. Die Meta-Description der Startseite ist zu lang (mehr als 170 Zeichen)


    3. Es fehlt eine H1-Überschrift


    4. die Textlänge ist mit 227 Wörtern zu kurz


    5. Die Bilder haben keinen Alt-Text sowie wenig aussagefähige Dateinamen


    6. Es fehlt eine eigene Fehlerseite


    unter www.nutzrad-studio.de habt ihr ja bereits eine Seite. Aus meiner Sicht solltet ihr mit dieser Seite weitermachen, da sie bereits bei Google gelistet ist und auch zumindest 26 Backlinks auf diese Seite verweisen. Bei Alexa seid ihr mit dieser Seite auf Platz 8.317.674 weltweit. Mit der bplaced-Seite steht ihr auf Rang 18.180.669, also 10 Millionen Plätze weiter hinten.


    Letztlich zählt bei Google nur Content, aber einzigartiger Content. Wir sind inzwischen bei rund 56.000 Wörtern, die Google finden kann, dazu kommen rund 7000 Bilder, größtenteils mit Alt-Text.


    Zur Suchmaschinenoptimierung gibt es in meiner Signatur einen Link auf einen Blogbeitrag von mir. Der ist zwar schon einige Monate alt, aber ich bin noch nicht dazu gekommen, diesen zu überarbeiten. Außer SSL-Verschlüsselung ist aber im Prinzip im letzten Jahr nichts neues hinzugekommen, was Rankingfaktoren betrifft.


    Ranking spielt überhaupt nur eine Rolle, wenn zwei Seiten relativ gleichwertigen Content bieten. Wörter, die auf der eigenen Seite fehlen, führen immer dazu, dass Google eben genau diese Wörter nicht finden kann und die Seite deshalb nicht in den Suchergebnissen auftaucht. Es geht also nicht darum, eine möglichst schnelle Seite oder eine Seite mit möglichst wenig CSS-Fehlern zu haben, es geht immer nur darum gefunden zu werden. Dies geht nur über Inhalt.

  • Guten Morgen!


    Alles klar, Thomas.


    Herzlichen Dank, Dir. Dann versuche ich die Dinge zu korrigieren, die Du angesprochen hast.


    56.000 Wörter und 7000 Bilder werde ich wohl nicht schaffen :) :).


    Kann ich manuell in den html Text den ALT-Text eingeben zu den Bildern?


    Viele Grüße!!

  • Hallo Thomas,


    den Alt-Text kannst Du in der Bilderverwaltung ("Erweitert" -> "Bilder") bei den Bildeigenschaften eingeben. Beim Widget "Bild" kannst Du auch über "erweitert / Mischpult" den Alt-Text eingeben, bei allen Widgets mit mehreren Bildern (Album, Carousel, Slider) geht es nur über die Bilderverwaltung.