Verlinkung von Sidebar und Logo-Implementierung

  • Hi,


    ich habe ein kleines Problem.


    In meiner Sidebar (sowohl Slider als auch "Kontakt" Feld) funktioniert nicht der Link zum Kontakt, obwohl der Link korrekt eingefügt ist (meines Wissens nach). Jedes Mal leitet T-Online mich um.

    Außerdem erscheint beim herunterscrollen der Seite nicht mein Logo links oben, sondern lediglich eine Platzhalterschriftzug "Logo". (Obwohl die Datei auf den FTP Server hochgeladen wurde... assets/logo2.png)


    Es geht um die folgende Seite: http://www.libelle-lastenrad.de/ .


    Bin um jeden Rat dankbar und wünsche Frohe Ostern!!:thumbsup:

  • Hallo Tobias,


    das Info-Feld auf der Linken Seite (sieht aus wie einer von Mario 's Codeschnipseln) ist verlinkt mit http://www.nutzrad-studio.de/Kontakt.php. Bei Aufruf dieser Seite kommt dann aber eine Fehlermeldung, weil die Seite http://www.libelle-lastenrad.dekontakt.php/ nicht erreichbar wäre. Ich nehme an, dass Du unter http://www.nutzrad-studio.de eine .htaccess zu stehen hast mit Weiterleitungsregeln. Bei der Regel für "Kontakt" fehlt der / zwischen ...lastenrad.de und kontakt.php.

  • Außerdem erscheint beim herunterscrollen der Seite nicht mein Logo links oben, sondern lediglich eine Platzhalterschriftzug "Logo". (Obwohl die Datei auf den FTP Server hochgeladen wurde... assets/logo2.png)


    Es geht um die folgende Seite: http://www.libelle-lastenrad.de/ .

    Hallo Tobias,

    die Verlinkung für dein Logo ist nicht korrekt.

  • Hallo,


    die Seite stellt sich responsive eigentlich so dar, wie das gedacht ist. Dass Sie Container-Hintergrundbilder nutzen, die auch Text enthalten ist natürlich für die Darstellung ggf. nicht optimal. Um ihnen konkret helfen zu können, müssten Sie uns konkret beschreiben, was falsch ist, bzw. fehlerhaft aussieht. "geht gar nicht" ist für uns etwas schwer zu verstehen.


    Um Ihnen helfen zu können, benötigen wir mehr Informationen.


    Wenn Sie Fehler / Probleme melden oder Fragen haben, seien Sie bitte so spezifisch wie möglich. "Funktioniert nicht" ist für uns sehr schwer einzuschätzen. Wir wissen nicht, was Sie erwarten haben und was Sie getan haben, um das Erwartete zu erreichen. Es ist daher notwendig, alles genau zu beschreiben:


    1. Welche Zeta Producer Version nutzen Sie?
    2. Welches Layout nutzen Sie? Z.B.: "Smart Responsive"
    3. Was möchten Sie erreichen?
    4. Was haben Sie gemacht? Beschreiben Sie Schritt für Schritt, welche Vorgänge Sie in Zeta Producer durchgeführt haben.
    5. Welches Resultat haben Sie erwartet?
    6. Was ist stattdessen passiert?
    7. Falls etwas falsch aussieht, zeigen Sie uns das anhand eines Screenshot und teilen Sie uns die URL der Website mit.
  • Guten Tag,

    1. Zeta Producer Version 13. 14 wird bald heruntergeladen.

    2. Layout: (wo kann ich das schnell sehen?)

    3. Ziel: korrekte Darstellung / Platzierung von Bildern und Text auf dem Smartphone oder im Hochkantformat eines Tablets. Insbesondere das erste Bild soll vollständig zu sehen sein.

    Die Sidebar „Datenschutz“ soll auf dem Smartphone nicht oben links erscheinen.

    4. Contents mit Code-Schnipsel von Mario eingefügt via CSS und Quellcode, Hintergrundbild mit Textfeld im Vordergrund. Das erste Bild hat kein Textfeld, wurde aber als Content (container100) eingefügt.

    5. Natürlich habe ich eine Anpassung der normalen Version erwartet, aber die Bilder und Textfeld sollten alle erkennbar sein.

    6. Startseite: das erste Bild ist abgeschnitten. Weißer Rand nach dem Menü, die Hintergrundbilder sind unterschiedlich groß. Datenschutz erscheint oben links.

    7. URL: libelle-lastenrad.de  bitte via Smartphone oder Tablet ausprobieren (Im Hochkantformat, dann wird das o. a. Problem ersichtlich).

  • Hallo,


    ich habe mir die Seite eben nochmal angesehen. Da ist so viel Fremdcode bzw. angepasstes CSS etc. drin und auch Quellcode mit Syntaxfehlern, dass es sehr schwer fällt hier die Ursache für ein Fehlverhalten sauber zu ermitteln.


    Zum Beispiel das 1. Bild. Hier arbeiten Sie mit einem Container mit der CSS-Klasse .container-top. Über die Klasse setzen Sie die Höhe auf 100vh. Das sieht dann auf dem Desktop gut aus. Das Bild hat dann 100% der Fensterhöne (Viewport-Height).

    Ab einer Fensterbreite von 920px oder schmäler, überschreiben Sie diese Regel aber mit Höhe 100% was eine relative Höhenangabe ist und hier zur nicht korrekten Darstellung führt.


    Hier ist also schlicht das selbst angepasste CSS die Ursache für die Fehldarstellung. Da sehr viel angepasst wurde, können wie da im Rahmen des kostenlosen Supports auch nicht wirklich viel helfen, da es sehr, sehr Zeitaufwändig wäre uns in Ihren Code einzulesen…

  • Zum Beispiel das 1. Bild. Hier arbeiten Sie mit einem Container mit der CSS-Klasse .container-top. Über die Klasse setzen Sie die Höhe auf 100vh. Das sieht dann auf dem Desktop gut aus. Das Bild hat dann 100% der Fensterhöne (Viewport-Height).

    Ab einer Fensterbreite von 920px oder schmäler, überschreiben Sie diese Regel aber mit Höhe 100% was eine relative Höhenangabe ist und hier zur nicht korrekten Darstellung führt.

    Hallo Stefan S ,

    dieser Code sieht ganz nach meiner Handschrift aus ;)


    Ziel war es für die mobile Ansicht wieder die ursprüngliche Darstellung zurück zu setzen damit bei längerem Inhalt nichts abgeschnitten wird. Bei meinen Tests hatte das mit "Höhe 100%" eigentlich immer gut funktioniert.


    Ich weiß das ist eigentlich nicht ihre Aufgabe. Aber eventuell haben Sie ja einen Tipp mit welcher Angabe ich die "100vh" widerrufen kann um die ursprüngliche Angabe von Zeta für die Mobile Ansicht zurück zu setzen.

  • Ich habe das gerade noch einmal intensiv getestet "height:100%;" funktioniert bei mir zuverlässig. Alternativ "height:auto;" funktioniert ebenso.


    Dazu eine Testseite: LINK

    Ab einer Bildschirmbreite von 820 Pixeln also ungefähr dann wenn der Text unter dem Bild hinaus ragen würde wird die Bildschirmfüllende Darstellung aufgehoben.





    PS: Tobias Heidemann

    Ich habe mir jetzt kurz deine Seite angesehen. Da steht:

    So stammt der Code ganz bestimmt nicht von mir.

    Das ganze bewirkt das ab einer Bildschirmbreite von 620 Pixeln das Bild den Bildschirm zu 45% ausfüllen wird.