Beiträge von Drcymbal

    Hallo Markus,


    funktionieren tut es bei mir nur, wenn das Projekt zwei- oder mehrsprachig ist. Dann hast Du "echte" Projektordner "DE" und bspw. "EN", die Du anklicken kannst, und die Anzeige erscheint. Gehe ich in ein rein deutsches Projekt, habe ich genau wie Du keinen Ordner und kann die gewünschte Ansicht dann auch nicht aufrufen.


    Viele Grüße


    Tom

    Hallo Thomas,


    wie immer vielen Dank!


    Eine zweite .htaccess im Ordner /en mit absoluter Pfadangabe


    # Beginn Fehlerdokument

    ErrorDocument 404 https://www.trpercussion.com/en/page-not-found.html

    # Ende Fehlerdokument


    führt zum gewünschten Erfolg.


    Hier aber noch eine Verständnisfrage. In der englischen .htaccess habe ich testweise keine Weiterleitungen bzgl. www und https eingerichtet. Wie es scheint, funktionieren die Weiterleitungen aber weiterhin einwandfrei. Daraus schließe ich, dass die tiefer liegende .htaccess nur die entsprechenden Abschnitte, hier das Fehlerdokument, der globalen .htaccess überschreibt, nicht aber die übrigen Abschnitte. Liege ich da richtig?


    Vielen Dank und viele Grüße


    Tom

    Hallo allerseits,


    mir gelingt es nicht, meine englische 404-Seite bei einem fehlerhaften Link der englischen Seiten anzeigen zu lassen. Statt der in ZP konfigurierten englischen 404-Seite, die sich ansonsten korrekt über https://www.trpercussion.com/en/page-not-found.html aufrufen lässt, erscheint die deutsche 404-Seite.


    Im Stammverzeichnis liegt eine .htaccess, in der die deutsche 404-Seite und Weiterleitungen bezüglich www und https konfiguriert sind. Das funktioniert.


    Dem Projektordner „EN“ ist auch die englische 404-Seite zugewiesen. Gemäß Beiträgen hier im Forum habe ich auch sowohl der deutschen als auch der englischen 404-Seite das Attribut "make-all-rendered-urls-absolute" zugewiesen und auf „true“ gesetzt, wobei das ja wohl nur eine korrekte Darstellung des Layouts garantiert.


    Wo mache ich einen Gedankenfehler?


    Muss ich der .htaccess vielleicht einen weiteren Eintrag hinzufügen oder eine weitere .htaccess im Unterorder „en“ anlegen?


    ZP 15.4.1 Business, Top Responsive


    Wie immer vielen Dank und viele Grüße


    Tom

    Ich würde mir wünschen, dass man dem Website-Logo bei einer mehrsprachigen Website die Index-Datei der jeweiligen Sprache zuweisen könnte.


    Hintergrund: Ich nutze Top Responsive, und um das Menü auf deutscher und englischer Seite überschaubar zu halten, würde ich „Start“ bzw. „Home“ auf den Seiten gerne ausblenden und den Besucher nötigen, das Logo anzuklicken, sofern er wieder zur Startseite gelangen möchte. Auf der deutschen Seite ist das kein Problem, auf der englischen Seite landet man dann allerdings auch auf der deutschen Start-Seite.


    Natürlich kann man jetzt argumentieren, dass man auch andere Wege findet, auf die Start-Seite zurückzukehren bzw. dass es dafür fast keine Veranlassung gibt, da die wichtigen Dinge ohnehin nicht auf der Start-Seite stehen. Richtig. Für mich wäre es halt das absolute i-Tüpfelchen auf der genialen Umsetzung der Mehrsprachigkeit in ZP.


    Viele Grüße


    Tom

    Hallo allerseits,


    ich habe meine Seite heute in die Zweisprachigkeit (DE/EN) geführt. Ich bin schwer beeindruckt, wie reibungslos das alles lief. Ein kleines Problem bleibt allerdings noch. Wie bringe ich dem Cookie-Consent bei, auf der englischen Seite auch in Englisch zu erscheinen?


    Im Widget sind die deutschen und englischen Texte und Links zu den entsprechenden Seiten hinterlegt, allerdings erscheint das Widget auf der englischen Seite weiterhin in Deutsch. Ein zweites Einfügen des Widgets ist ja nicht möglich.


    ZP 15.4.1 Business Top Responsive


    www.trpercussion.com


    Vielen Dank und viele Grüße


    Tom

    Hallo Carla,


    schau mal hier, vielleicht hilft das bereits: Problem bei der Aktualisierung eines Projekts

    Außerdem ist es meiner Meinung nach von Bedeutung, was für Änderungen Du vorgenommen hast. Wenn Du nur eine Textpassage auf einer bestimmten Seite änderst, sollte eigentlich auch nur die entsprechende Seite publiziert werden. Hast Du aber bspw. Änderungen an einem mit mehreren Seiten verknüpften Artikel vorgenommen, dann müssen natürlich alle Seiten publiziert werden, die von der Verknüpfung betroffen sind.


    Viele Grüße


    Tom

    Hallo Mirco,


    Glückwunsch! Wieder eine sehr gelungene Seite, an der es nichts zu bekritteln gibt.


    Ein paar kleine Rechtschreibfehler sind mir allerdings über den Weg gelaufen.


    dEERbrands music&media UG ist ein Label und Verlag, das(s) sich nicht nur auf die deutsche Musikindustrie …


    Geschäftsführer Mirco Clapier ist studierter Multimedia-Designer und Dipl. Betriebswirt …


    Bei der Vielzahl an professionellen Dienstleistungen sind Ihre "Finanzen" im Fokus.

    Vielleicht besser: „Trotz der Vielzahl an professionellen Dienstleistungen bleiben Ihre "Finanzen" stets im Fokus.


    Mit Kreativität und Leidenschaft, gespickt mit Fairness und Know-how, werden wir Ihrem Projekt magische Momente bescheren.


    Eine professionelle und ansprechende Homepage ist Ihre Visitenkarte im Netz. Es ist daher wichtig, dass sie sich ansprechend präsentier(s)t.


    Wir bieten Ihnen über unser Label SONIOX MUSIC (LC-53687) eine Vielzahl an Möglichkeiten, dem musikalischen Traum einen Schritt näher zu kommen.


    Dabei arbeiten wir mit der DAW-Softwarelösung Sequoia, eines der führenden digitalen Tonstudioprogramme(n) für renommierte Studios (BR, ZDF) in den Bereichen Audioproduktionen, Postproduktion und Mastering.


    Dabei haben wir alle großen Player wie Spotify, iTunes, Amazon …


    … mehr Streams und Views zu generieren, die Fanbase zu vergrößern, die Reichweite nachhaltig zu erweitern, und wir bemustern via MPN Rundfunkanstalten …


    Viele Grüße

    Tom

    Nur der Vollständigkeit halber: Problem gelöst.


    Natürlich hat der Hoster jegliche Schuld von sich und seinem PHP gewiesen, also habe ich vieles ausprobiert und schließlich Folgendes festgestellt: Ursache war der Eintrag in der .htaccess zu UTF-8.


    # Beginn UTF-8

    AddCharset UTF-8 .html

    AddCharset UTF-8 .php

    # Ende UTF-8


    Wird dieser Eintrag komplett entfernt, funktioniert alles klaglos. Wird nur der PHP-Eintrag entfernt, kommt die Meldung „Nachricht erfolgreich versendet“, die E-Mail kommt aber nicht an.


    Vielleicht hat ja Hanabi oder jemand anderes ein Erklärung. Ich kann aber auch gut ohne Erklärung leben und freue mich, dass es nun funktioniert.


    Viele Grüße


    Tom

    Hallo Maik,


    vielen Dank für Deine Hinweise. Da habe ich mich vielleicht etwas missverständlich ausgedrückt. Natürlich arbeite ich mit dem ZP-Widget "Formular" und die Hinweise im Handbuch habe ich natürlich auch gelesen. Ich denke, dass es ein PHP-Problem ist.


    Viele Grüße


    Tom

    Hallo allerseits,


    ich habe mich heute mal an die testweise Erstellung eines Kontaktformulars gewagt und bin leider kläglichst gescheitert.


    Im Idealfall wird später SMTP und ein unsichtbares reCAPTCHA genutzt. Davon scheine ich noch weit entfernt.


    Ich nutze ZP 15.4.1 Business/Top Responsive


    Testseite innerhalb meines Projekts angelegt, Widget eingefügt, ein paar Formularfelder konfiguriert und SMTP (noch kein reCAPTCHA) aktiviert, veröffentlicht und getestet.


    Es erscheint eine unschöne Fehlerseite mit „404 – Seite nicht gefunden“.


    Hier die entsprechende Testseite mit dem Formular: https://www.trpercussion.com/test.html


    Ich habe jetzt alle angebotenen 7er PHP-Versionen mit Unterstützung von mbstring, openssl bei Domainfactory getestet, an den Berechtigungen des PHP-Ordners rumgespielt. Gleichfalls habe ich die Testeite mal von html auf php gesetzt. Jetzt erscheint obige Fehlermeldung schon beim Aufruf der Testseite zusammen mit dem Hinweis „Sehr geehrter Besucher, leider ist ein Problem aufgetreten. Die angeforderte Seite hat einen Script-Fehler verursacht. Haben Sie sich vielleicht vertippt oder eine alte URL aufgerufen? Wenn nicht, informieren Sie bitte den Webmaster dieser Homepage per Email. Um zu der vorherigen Seite zurück zu kehren, verwenden Sie bitte einfach die "Zurück" - Taste Ihres Browsers.“


    Andere Widgets die PHP benötigen, z. B. das Online-CMS funktionieren natürlich auch nicht.


    Das Überprüfen der Website-Features liefert für Formular und Server-Backend jeweils PHP 0.0. Im Kundenmenü von Domainfactory habe ich wie gesagt alle Versionen getestet und auch den Light-Modus deaktiviert. Ich sehe auch keine Möglichkeit im Kundenmenü PHP irgendwie versehentlich zu deaktivieren. Wie kann ich denn die Aktivität von PHP unabhängig von ZP bzw. Domainfactory feststellen?


    Ich habe SSL und TLS mit Port 465 (von Domainfactory empfohlen), Port 25 (von Hanabi empfohlen) und diverse weitere mit meinem SMTP-Server als auch mit sslout.df.eu probiert.


    Ich denke, dass das Problem außerhalb von ZP zu suchen ist, aber vielleicht hat ja einer noch ein paar Anregungen, was ich noch überprüfen kann, bevor ich mich morgen in die telefonische Wartschlange bei Domainfactory einreihe.


    Vielen Dank und viele Grüße


    Tom

    Hallo Hellingx,


    wenn ich obigem Link folge, sehe ich den Verfügbarkeitskalender in horizontaler Darstellung wie in Bild 1 gezeigt. Hast Du mal den Browser-Cache geleert?


    Viele Grüße


    Tom

    Hallo Mirco,


    ich kann mich Michael nur anschließen: Respekt! Es ist immer wieder schön zu sehen, was man mit ZP anstellen kann.


    Ein paar Kleinigkeiten, die mir aufgefallen sind:


    Dass die Startseite ein Untermenü hat, scheint mir sehr gewöhnungsbedürftig. Nach Fotos oder einem CV würde ich überall suchen, nur nicht unter „Start“.


    Im Impressum sollte es heißen: „Diese Website ist ein klimaneutrales Produkt.“ Ferner: „Urheberrechte und sonstige Sonderschutzrechte“.


    Die Genitivbildung mittels Apostrophs („Paul Meek’s Bücher“, „Paul Meek’s CD/DVD“, „Paul Meek's Mediale High School®“ usw.) ist im Englischen korrekt, im Deutschen aber falsch.


    Viele Grüße


    Tom

    Hallo Thomas,


    ein paar kleine Hinweise zu „Top Responsive“:


    Website-Name: müsste JA heißen (wenn Logo deaktiviert)


    Website-Slogan: müsste JA heißen (wenn Logo deaktiviert)


    Es gilt also, entweder Website-Name/Website-Slogan oder Logo. Vielleicht könnte man das unter „Besonderheiten“ vermerken.


    Navigationspfad: müsste JA heißen (erscheint im Footer)


    Position Suchfeld: müsste eher „oben mittig“ heißen


    Viele Grüße


    Tom

    Hallo M’Otto,


    mit Einführung des neuen Editors in 15.4.0 ist die Pipette weggefallen. Über die Wiedereinführung ist ja bereits an anderer Stelle diskutiert worden. Gegenwärtig werden Dir somit nur die bereits im Layout verwendeten Farben angeboten. Weitere Farben können nur durch manuelle Eingabe des hexadezimalen Farbwerts dargestellt werden. Du müsstest also in die Layout-Einstellungen Deines Projekts gehen und hier in einer beliebigen Farb-Einstellung die gewünschte Farbe mittels Pipette auswählen. Nun kopierst Du den angezeigten Farbwert und fügst diesen dann im Text-Editor unter „Textfarbe“ wieder ein.


    Viele Grüße


    Tom

    Hallo Mario,


    vielen Dank für Deine Hinweise. Ich bewundere Dein Engagement für ZP ungemein, sei es hier im Forum oder in Form der Codeschnipsel. Ich habe auch viele Deiner Widgets heruntergeladen und testweise installiert. Letztlich bin ich aber von deren Verwendung immer wieder abgerückt, weil ich mein Layout so sauber als möglich gestalten wollte.


    Meine Sorge ist schlicht, dass sich ein zukünftiges ZP-Update einfach nicht mit einem Deiner Widgets verträgt. Die Seite funktioniert plötzlich nicht mehr wie gewünscht und S. und S. werden - völlig zurecht - sagen, dass sie Fremd-Code nicht supporten können.


    Meine Wünsche hinsichtlich des Akkordons sind ja recht bescheiden, so dass ich denke, dass sich das vielleicht sogar relativ zeitnah ohne viel Aufwand realisieren lässt.


    An dieser Stelle aber nochmals ganz, ganz herzlichen Dank für die Unterstützung, die Du jedem in diesem Forum zukommen lässt. Chapeau!


    Viele Grüße


    Tom

    Liebes ZP-Team,


    vielleicht ließe sich in einer zukünftigen Version noch ein Hover-Effekt für die Akkordeon-Ansicht einbauen.


    Bei der Tab-Ansicht ist es naheliegend, dass man die Registerkarten anklicken kann, und sich neuer Inhalt präsentiert. Bei der (geschlossenen) Akkordeon-Ansicht hingegen könnte man annehmen, dass es sich schlicht um eine tabellarische Übersicht handelt, wenn man seinen Cursor nicht beobachtet. In meinem Fall habe ich jetzt Pfeile eingefügt, um den „Link“ zu verdeutlichen. Vielleicht wäre Letzteres ebenfalls eine Anregung.


    Siehe: https://www.trpercussion.com/schlaginstrumentenverleih.html


    Die Krönung wäre noch eine individuelle Hintergrundfarbe für die Überschrift des Tabs in geöffnetem Zustand.


    Viele Grüße


    Tom

    Hallo Thomas, hallo Tobias,


    vielen Dank für Eure Hinweise. Ich habe jetzt mal ein geschlossenes Akkordeon angelegt. Die in diesem gemachten Einträge sind im Seitenquelltext der Vorschau (bei weiterhin geschlossenem Akkordeon) sichtbar. Sie sollten somit indexiert werden können.


    Vielleicht kann der Support hierzu aber noch kurz abschließend Stellung beziehen.


    Vielen Dank und viele Grüße


    Tom

    Hallo Jochen,


    in einem frisch angelegten Projekt mit „Athmosphere Responsive“ und auch mit „Top Responsive“ verhält sich mein Editor genau wie von Dir beschrieben: „Ein kurzes "Aufblitzen" und die Tabelle wird geschlossen, ohne dass das Bild eingefügt wurde.“ Das sieht somit nach einem Fehler im Widget bzw. im Editor aus.


    Viele Grüße


    Tom

    Hallo Thomas,


    saubere Arbeit! Vielleicht könntest Du rechts noch leere Spalten einfügen, damit man auch das letzte Layout („Tweet“) ganz nach links bis zu ersten Spalte verschieben kann. Anderenfalls sehe ich die Gefahr, beim Bearbeiten eventuell in der Zeile zu verrutschen.


    Viele Grüße


    Tom

    Hallo Stefan,


    Du darfst das Backup nicht selber entpacken, vielmehr musst Du die Zip-Datei unter „Backup“ > „Backup wiederherstellen“ auswählen. Des Weiteren könnte es nötig sein, nochmals alle Seiten neu zu erstellen.


    Viele Grüße


    Tom

    Hallo allerseits,


    ich würde gerne zur Strukturierung das Widget „Tabs/Akkordeon“ einsetzen. Ich meine aber gelesen zu haben, dass Google die Verwendung von Tabellen/Tabs nicht sonderlich schätzt und somit abstraft.


    Ich kann mir nicht vorstellen, dass ZP Widgets nutzt, die das Ranking negativ beeinflussen; ich wollte dennoch mal nachfragen.


    Ein kurzer Hinweis wie „Da musst Du Dir keinen Kopf machen!“ käme mir sehr gelegen.


    Vielen Dank und viele Grüße


    Tom

    Hallo Stefan,


    das ist richtig, mit Version 15.4.0 wird zwingend SQL-Server-CE als Datenbankformat genutzt.


    Ob Dein Projekt für dieses Datenbankformat zu groß ist, kann ich nicht beurteilen. Ich will hier auch keine Mutmaßungen anstellen. Wenn Dir der ZP-Support nahegelegt hat, das Projekt aufgrund seiner Größe bei Version 15.2.0 zu belassen, dann kann ich mir durchaus vorstellen, dass Dir der Support einen Link für diese Version zur Verfügung stellt.


    Viele Grüße


    Tom

    Hallo Stefan,


    als Download steht immer nur das aktuelle bzw. letzte Release zur Verfügung und das ist auch gut so, denn die aktuelle Version bringt ja nicht nur neue Funktionen mit sich, sondern, viel wichtiger, auch Fehlerkorrekturen. In berechtigten Ausnahmefällen stellt der Support auch ein älteres Release zur Verfügung, so habe ich es zumindest vor kurzen in einem anderen Thread gelesen. Dies muss dann aber schon sehr triftige Gründe haben.


    Was spricht denn Deiner Meinung nach gegen die Verwendung der aktuellen Version 15.4.0?


    Viele Grüße


    Tom

    Hallo Günter,

    zum angesprochenen Problem kann ich zunächst wenig beitragen. Festzuhalten bleibt aber, dass die deutsche Seite, wie von Dir beschrieben, bei mir kurzzeitig das Hauptmenü einblendet und dann erst in den mobilen Modus verfällt. Folge ich dem grün hinterlegten Link für die CH-Edition, wird mir das mobile Menü erst angezeigt, wenn ich kurzzeitig nach unten scrolle.


    Soweit ich das überblicke, sieht das verwendete Layout von Hause auch keine Einstellung vor, das mobile Menü in der Desktop-Ansicht einzublenden.


    Vielleicht wäre es somit doch sinnvoller, das Menü zu überarbeiten, sprich zu kürzen.


    Meine Ideen:


    Kontakt, Datenschutz und Impressum würde ich aus dem Menü entfernen, da ein Zugriff auf diese Seiten ja bereits im Footer gegeben ist.


    „Startseite“ > „Start“


    „Über AIRVI und über uns“ > „AIRVI“ (Hauptmenü) und das „Über uns“ in den Footer


    „Sauerstoff …“ > „Sauerstoff“ oder „O2“

    "Das Vegetative Nervensystem (VNS)“ > „Vegetatives Nervensystem“

    „testen – mieten -kaufen“ > „Testen/kaufen“ (Mieten ist ja derzeit ohnehin nicht möglich.)


    Usw.


    Vielleicht lässt sich mit diesen Reduzierungen ein ansprechendes ein- oder zweizeiliges Hauptmenü für die Desktop-Ansicht generieren.


    Viele Grüße


    Tom

    Hallo Stefan,


    vielen Dank für diesen konstruktiven Hinweis. Ich habe eingangs vielleicht etwas geflunkert. Diese Seite ist wohl mehr für Google denn für den Endkunden gedacht, und ich erwarte somit auch nicht, dass man die Seite von Anfang bis Ende liest.


    Sehr gerne würde ich aber mehr Struktur in diese Seite bringen. Ich hatte hier auch schon mit „Tabs / Akkordeon“ experimentiert, was mir persönlich als die praktikabelste Lösung erscheint. Allerdings bin ich davon schnell wieder abgerückt, da ich meine gelesen zu haben, dass Google die Verwendung von Tabellen und Tabs weniger schön findet.


    Wenn Sie oder einer der Mitlesenden mir sagen, dass das Google ziemlich egal ist, dann freue ich mich auf den Einsatz von „Tabs / Akkordeon“.


    Vielen Dank und viele Grüße


    Tom

    Hallo Stefan,


    vielen Dank für die Rückmeldung. Schön zu lesen, dass das Problem hinter der Topline sitzt und nicht davor.


    Ich hatte gehofft, mittels eines Attributs nur das mobile Menü der manuellen Navigationsleiste umzubenennen, nicht jedoch das mobile Menü der Hauptnavigation. Offensichtlich ist dies nicht möglich, denn die Umbenennung von "mobile_menu_title" führt zur Umbenennung beider Menüs. Es gibt Schlimmeres.


    Viele Grüße


    Tom

    Hallo Ombaba,


    Du versuchst innerhalb eines Artikels zu verlinken. Das wäre wohl nur mit Marios Ansatz möglich.


    Eine mögliche Abhilfe wäre den Absatz „Mittelpaläolithische Industrien“ als einen eigenständigen Text-Artikel unterhalb von „Geschichte des subindischen Kontinents“ anzulegen. Dann kannst Du auch verlinken.


    Generell empfiehlt es sich daher vielleicht, für jeden Absatz einen eigenen Artikel anzulegen.


    Laut Bild hast Du ferner auch die falsche Seite als Ziel ausgewählt: „Home“. Daher werden Dir hier nur die Artikel der Startseite als Ziel angeboten. Du müsstest natürlich „Geschichte Indiens“ auswählen und dann im Ausklappmenü „Mittelpaläolithische Industrien“ wählen, was natürlich nur geht, wenn dies ein eigenständiger Artikel ist.


    Viele Grüße


    Tom

    Hallo Thomas,

    vielleicht könnte man die Übersicht auch noch um eine Spalte „Bemerkungen/Alternativen“ o. ä. erweitern. Ein Beispiel:

    Layout: Top Responsive, Header randlos: Nein, Bemerkung/Alternative: Slider verwenden.

    Viele Grüße

    Tom