ZP Formularanfragen landen im Spam Ordner

  • Hallo liebe Community,


    ich arbeite mit ZP 14.1 und habe seit längerem ein Problem mit den Formularanfragen meiner Webseiten die im Spamordner landen. Da ich mit Outlook Exchange arbeite habe ich beim Dienstanbieter SPF Einträge gemacht welche die Server meines Dienstanbieters und der absendenden Mailserver erfassen. Sinn wäre, dass nun Microsoft diese Server als valid und nicht als Spoofing erkennt.

    "v=spf1 ip4:172.16.50.71/4 ip4:193.246.38.125 include:spf.protection.outlook.com -all"


    Weil das nicht funktioniert, habe ich nun den Versuch mit der SMTP Option in ZP gemacht. Allerdings werden die Mails nach wie vor in den SPAM Ordner gesendet. Es gibt keine Fehlermeldungen, weil meine Eingaben korrekt sind. Meine Frage ist nun, wenn eine SMTP Message gesendet wird, ob die den selben Weg geht,

    Woran könnte das Problem noch liegen. Mein Problem ist, dass mein Dienstanbieter Swisscom sich nicht um das Problem kümmert, weil ich meine Webseite bei ihm und den Exchange Server bei Microsoft gehostet habe. Nun will mir niemand behilflich sein, weil jeder vom anderen sagt geht mich nichts an. Kennt jemand von der Community dieses Problem? Wie könnte man dies lösen?


    Danke für Hinweise diesbezüglich :)


    André

  • Der Unterschied zwischen Formularen mit und ohne "SMTP" Einstellung ist:


    dass ohne SMTP-Option der Webserver die Nachricht direkt oder über einen anderen Relay-Server versendet und dieser befindet sich oft nicht in Ihrer SPF-Liste und kann von Ihnen nicht kontrolliert werden.


    Formulare mit SMTP-Option werden von dem in den SMTP-Einstellungen eingetragenen Server versendet (bzw. direkt darauf zugestellt). Da dies in der Regel ein Server unter Ihrer Kontrolle ist, kann er auch entsprechend in die SPF-Liste mit aufgenommen werden (bzw. ist eh schon darin enthalten)…


    Ich würde in Ihrem Fall raten, dass Sie Ihren eigenen SMTP-Server für die Formulare nutzen, dann haben Sie mehr Kontrolle.


    Um Ihr Problem zu lösen, müsste man genau wissen, warum der SPAM-Filter die Mails als SPAM erkennt. Viele Spam-Filter bieten dazu detaillierte berichte bzw. Header in der Mail.

  • Guten Tag,

    ich habe nun auf ihre Empfehlung die SMTP Konfiguration vorgenommen und sende nun die Formulare auf diesem Weg. Allerdings ändert sich daran nichts was SPAM betrifft. Im Mail Header sehe ich immer die gleichen involvierten IP Adressen. Dies sind auch im SFP Record hinterlegt. Wenn ich im ZP Mailformular Debug in den Optionen einschalte, dann sehe ich auch keine Fehlermeldungen. Also kann ich davon ausgehen, dass die Nachricht via SMTP versandt wird? Ein Microsoft Techniker will genau wissen wo die Nachricht durchläuft aber ich kann nur die IP Adressen meines Providers herauslesen. Selbst wenn ich die Nachricht an den Exchange Server via SMTP sende landet diese im Spam Ordner.

    Der Spam Level im Message Analyzer zeigt Spam Level 5. Für mich ist es schwierig herauszufinden was Microsoft daran stört.

    Microsoft prüft so wie ich das verstehe eine Header ID die den Absender genau identifiziert. Das ist offensichtlich über den Formularversand nicht gewährleistet. Das wäre dann aber ein Thema für Euch von Zetaproducer das codemässig sicherzustellen.

    Ich möchte Lösungen finden, aber ich weis momentan nicht wie weiter vorgehen. Gibt es andere Microsoft Exchange Anwender die mit ZP Formularen ähnliche Probleme haben?


    Danke für weitere Hilfe, damit ich das Problem endlich lösen kann.


    André von feedin

  • Ohne die Internas des Spamfilters zu kennen und z.B. Zu wissen um was für eine Header-ID es sich handelt, fällt uns eine Hilfe aber sehr schwer. Ob die Mails tatsächlich über Ihren Server per SMTP versandt werden, sollten Sie ja an den IP-Adressen im Header erkennen können. Ich bin aber relativ sicher, dass dies der Fall ist, wenn die SMTP Option im Formular aktiviert ist und die Mail auch ankommt.

  • PS: bietet der Spamfilter denn keine Whitelists an, mit Hilfe derer Sie den Formular-Absender von der Spamprüfung ausschließen könnten?