Navigationspfad nur auf Unterseiten anzeigen (Flat Responsive)

  • Hallo!

    Ich verwende ZP 14.3.3 mit Layout Flat Responsive.

    Da die gewählten Hauptseiten ohnehin über das sichtbare Menü erkennbar sind ist (für mich) bei Hauptseiten ein Navigationspfad überflüssig und unerwünscht.

    Wunsch: Den Navigationspfad nur auf Unterseiten einblenden (lassen/wählbar?).

  • Hallo Walter,


    das lässt sich über das Attribut "breadcrumb" steuern. Einfach auf die entsprechende Seite gehen, "Seite bearbeiten" -> "Attribute" und dort nach "breadcrumb" suchen. Dann den Wert bei "show_breadcrumb" auf "false" setzen. Speichern, Fertig. Zur Wiederanzeige einfach "true" eintragen oder das seitenbezogene Attribut löschen, es wird dann automatisch wieder das globale Attribut verwendet.

  • Zum Verständnis: Wenn Sie "Einstellungen > Links > Navigationspfad anzeigen" verändern, wird im Hintergrund einfach das entsprechende (von Thomas erwähnte Attribut) gesetzt. Dieses Attribut kann natürlich auch direkt bearbeitet werden.

  • Danke für die Informationen!

    Damit müsste ich in den Einstellungen "Navigationspfad" auf anzegen stellen und danach auf allen Hauptseiten das Attribut ändern.

    Eine automatisierte Lösung, die den Navigationspfad nur auf Unterseiten anzeigt, wäre sicher einfacher und übersichtlicher.

  • Es ist ja eher unüblich einen Navigationspfad nur manchmal zu zeigen. Ich kenne das eigentlich nur als "entweder oder". Daher bieten wir hier auch keine automatisierte Lösung an. Solche "Ausnahme-Logik" verlangsamt das Erstellen von Projekten und muss gut bedacht werden.

    Wieviele Hauptseiten haben Sie denn, auf denen Sie das einstellen müssten? Normalerweise hat man ja ggf. weniger Hauptseiten als Unterseiten…

  • Danke, es war eine Überlegung und ein Vorschlag für die Zukunft.

    Es ist richtig, die Anzahl der Hauptseiten soll sich in Grenzen halten, weil sonst das Hauptmenü zu lang (breit) wird.

    Die oben beschriebene Lösung ist für mich verständlich, machbar und kein Problem.

  • Danke!

    Habe das jetzt so gemacht und funktioniert wunschgemäß.

    Ergänzung:

    Hallo Walter,


    das lässt sich über das Attribut "breadcrumb" steuern. Einfach auf die entsprechende Seite gehen, "Seite bearbeiten" -> "Attribute" und dort nach "breadcrumb" suchen. Dann den Wert bei "show_breadcrumb" auf "false" setzen. Speichern, Fertig. Zur Wiederanzeige einfach "true" eintragen oder das seitenbezogene Attribut löschen, es wird dann automatisch wieder das globale Attribut verwendet.


    Ich habe das hier auf den Hauptseiten so gändert, allerdings anfangs vergessen die automatisch gesetzte Option "Attribut auf Unterseiten anzeigen" zu deaktivieren.



    Im zweiten Anlauf alles bestens. Danke für alle Hilfen!