.htaccess-Datei fehlt

  • Hallo ZP-Support


    Stelle fest, dass auf dem Server die .htaccess-Datei fehlt.

    Habe unter Einstellungen, Optionen usw. geschaut ob ich sie einschalten oder erstellen lassen kann.

    Komme aber leider nicht weiter.


    Was muss wo eingestellt werden damit die .htaccess-Datei erstellt wird und was für Einträge sind ein MUSS?


    Vielen Dank.

    G. Cantone

  • Hallo,

    wieso "fehlt"? Die Datei gibt es nur, wenn man die auch mal angelegt hat. Das ist auch kein muss und damit kann man auch sehr viel kaputt machen. Sie sollten uns also ggf. sagen, was Sie überhaupt erreichen möchten.

  • Hallo,


    Wenn ich im Browser http://www.sysint.ch oder sysint.ch eingebe, dann wird nicht auf https umgeleitet.

    Gem. meinem Hoster muss ein Eintrag in der .htcaccess gemacht werden und ich würde sie im Verzeichnis htdocs finden.

    Welcher Eintrag gehört in die Datei?


    Vielen Dank.



    Freundliche Grüsse

    G. Cantone

  • Hallo Cantone!


    Wie bereits oben bemerkt.


    Gem. meinem Hoster muss ein Eintrag in der .htcaccess gemacht werden und ich würde sie im Verzeichnis htdocs finden.


    Den Eintrag sollte der Hoster haben. die .htcaccess mit einen Editor erstellen und auf den Server ins das Verzeichnis htdocs hochladen. Mit FTP FileZilla.

    LG
    Andi


    --------------------------------------------------
    Ich verwende den Zeta Producer V15.X.X Express

    und bin sehr zufrieden. :)

  • Hallo


    Der Eintrag in die .htaccess-Datei für http://www.sysint.ch ist vom Hoster gemacht worden und die Webseite wird richtig angezeigt.


    Nun habe ich aber ein ander Problem.

    Unter http://www.sysint.ch habe ich eine weitere Webseite im Verzeichnis "surveillancesolutions".

    Wenn ich https://www.sysint.ch/surveillancesolutions eingebe, dann wird die Webseite richtig angezeigt.

    Gebe ich hingegen http://www.sysint.ch/surveillancesolutions, dann wird zwar die Webseite angezeigt aber sämtliche Bilder nicht.

    Ausserdem anstelle vom Firmen-Logo wird oben links "index.html" angezeigt (s. Bild unten).


    Vom Hoster habe ich folgende Antwort erhalten:

    Da es sich bei der Webseite um eine komplexere Eigenentwicklung handelt können wir Ihnen leider nicht weiter bei dieser Problematik behilflich sein.

    Grundsätzlich übersteigen solche Anfragen unseren gewährleisteten Supportbereich, bei kleineren Anpassungen können wir ggf. denoch helfen.


    Im Verzeichnis "surveillancesolutions" habe ich eine weitere .htaccess-Datei.

    Mir scheinen die Einträge richtig zu sein, stehe aber nun an und weiss nicht weiter.

    Hoffentlich kann mir jemand im Forum weiterhelfen.


    Vielen Dank jetzt schon für eure Unterstützung.

    G. Cantone

  • Hallo,


    Sie möchten doch, dass alle Seiten ausschließlich über eine sichere SSL-Verbindung aufgerufen werden. Also müssen Sie eine entsprechende Weiterleitung auf die verschlüsselte Verbindung in der .htaccess konfigurieren. Siehe beispielsweise hier https://jweiland.net/know-how/…-konfigurieren.html#c2756


    Der nicht sicherer Aufruf http://www.sysint.ch/surveillancesolutions/ wird dann auf die sichere Verbindung https://www.sysint.ch/surveillancesolutions/ weitergeleitet.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Ergänzend dazu. Ihre jetzige Umleitung ist nicht optimal. Aktuell leiten Sie jegliche URL, die nicht mit HTTPS beginnt auf Ihre Startseite um, daher werden auch Bilder auf die Startseite umgeleitet und da eine Startseite kein Bild ist, können die Bilder nicht geladen werden.


    Aktuell wird z.B.: http://www.sysint.ch/surveillancesolutions/assets/logo.png zu https://www.sysint.ch umgeleitet.

    Besser wäre, wenn http://www.sysint.ch/surveillancesolutions/assets/logo.png zu https://www.sysint.ch/surveillancesolutions/assets/logo.png umgeleitet würde.


    Wenn aktuell in der URL keine Seite spezifiziert ist, die URL also mit einem / endet, scheint gar keine Umleitung stattzufinden.


    Ihr Provider kann sicher die Umleitung entsprechend anpassen.