Fehlermeldung "The search key was not found in any record." / Plötzlich diverse Fehlfunktionen bei einem Webprojekt

  • Hallo,


    ich hatte kurzzeitig bei einem neuen Webprojekt (ZP 15.2.0 Business / Layout: Campfire Responsive / OS: Windows 10) das Widget "Suchfeld" ausprobiert, aber anschließend wieder entfernt.


    Seitdem erhalte ich nun regelmäßig die Fehlermeldung "The search key was not found in any record." wenn ich entweder einen Snapshot anlegen möchte (der aber nicht erstellt wird) oder ein Backup starte, dass aber ebenfalls nicht final ausgeführt wird.


    Das Webprojekt möchte ich hier im Forum nicht nennen, ohne dies vorher mit dem Auftraggeber abgesprochen zu haben. Dieser befindet sich derzeit aber im Auslandsurlaub.


    Hatte mir überlegt, Zeta Producer neu zu installieren. Aber vorher wollte ich ein weiteres Backup des aktuellen Projekts anlegen, was aber, wie bereits erwähnt, nicht möglich ist.


    Dennoch habe ich in der Zwischenzeit Zeta Producer 15.2 deinstalliert, weil hinzu kam, dass die Software immer wieder "hängen" blieb. Beispielsweise, wenn ich ein Widget auswählen wollte.


    Außerdem lässt sich nach wie vor der Bereich "Layout" zwar aufrufen, aber es wird quasi eine "weiße Seite" angezeigt (siehe Screenshot), und anschließend wechselt der ZP nach einigen Sekunden selbständig auf die Programmoberfläche, in der man an der Website arbeitet.


    Die Fehlermeldung "The search key was not found in any record." wird selbst nach der Neuinstallation auch sofort nach Programmstart angezeigt, wobei sich die gesamte Problematik augenscheinlich auf dieses Projekt bezieht, denn bei Auswahl anderer Webprojekte machen sich die genannten Fehler nicht bemerkbar.

    Am maßgeblichen Projekt kann ich derzeit nicht vernünftig weiterarbeiten...





    Detailangaben (Fehlermeldung) bei "Snapshot":


    System.Data.OleDb.OleDbException


    -----------------


    The search key was not found in any record.


    -----------------


    bei System.Data.OleDb.OleDbCommand.ExecuteCommandTextErrorHandling(OleDbHResult hr)

    bei System.Data.OleDb.OleDbCommand.ExecuteCommandTextForSingleResult(tagDBPARAMS dbParams, Object& executeResult)

    bei System.Data.OleDb.OleDbCommand.ExecuteCommandText(Object& executeResult)

    bei System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior behavior, String method)

    bei System.Data.OleDb.OleDbCommand.ExecuteNonQuery()

    bei Zeta.VoyagerLibrary.Data.Base.AdoNetBaseQuerier`4.ExecuteNonQuery(TConnection connection, String sql, DataCacheInformation dataCacheInformation) in c:\P\ZP\15.2\ZetaProducerReferences\Externals\ZetaVoyagerLibrary\Source\Data\Base\AdoNetBaseQuerier.cs:Zeile 2845.

    bei ZetaProducer.RuntimeBusinessLogic.Webbing.Projects.Settings.WebProjectSettingsDynamic.<>c__DisplayClass43_0.<writeToDatabase>b__0() in c:\P\ZP\15.2\ZetaProducerMain\Source\Core\RuntimeBusinessLogic\Webbing\Projects\Settings\WebProjectSettingsDynamic.cs:Zeile 465.

    bei ZetaLongPaths.ZlpSimpleFileAccessProtector.Protect(Action action, ZlpSimpleFileAccessProtectorInformation info) in c:\P\ZP\15.2\ZetaProducerReferences\Externals\ZetaVoyagerLibrary\Externals\ZetaLongPaths\Source\RuntimeNetCore\ZlpSimpleFileAccessProtector.cs:Zeile 88.


    OleDbException

    {

    ErrorCode=-2147467259,

    Errors=OleDbErrorCollection

    {

    Count=1,

    },

    Message="The search key was not found in any record.",

    Data=

    [

    ]

    ,

    InnerException=null,

    TargetSite=RuntimeMethodInfo: ExecuteCommandTextErrorHandling,

    StackTrace=" bei System.Data.OleDb.OleDbCommand.ExecuteCommandTextErrorHandling(OleDbHResult hr)\\r\\n bei System.Data.OleDb.OleDbCommand.ExecuteCommandTextForSingleResult(tagDBPARAMS dbParams, Object& executeResult)\\r\\n bei System.Data.OleDb.OleDbCommand.ExecuteCommandText(Object& executeResult)\\r\\n bei System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior behavior, String method)\\r\\n bei System.Data.OleDb.OleDbCommand.ExecuteNonQuery()\\r\\n bei Zeta.VoyagerLibrary.Data.Base.AdoNetBaseQuerier`4.ExecuteNonQuery(TConnection connection, String sql, DataCacheInformation dataCacheInformation) in c:\\P\\ZP\\15.2\\ZetaProducerReferences\\Externals\\ZetaVoyagerLibrary\\Source\\Data\\Base\\AdoNetBaseQuerier.cs:Zeile 2845.\\r\\n bei ZetaProducer.RuntimeBusinessLogic.Webbing.Projects.Settings.WebProjectSettingsDynamic.<>c__DisplayClass43_0.<writeToDatabase>b__0() in c:\\P\\ZP\\15.2\\ZetaProducerMain\\Source\\Core\\RuntimeBusinessLogic\\Webbing\\Projects\\Settings\\WebProjectSettingsDynamic.cs:Zeile 465.\\r\\n bei ZetaLongPaths.ZlpSimpleFileAccessProtector.Protect(Action action, ZlpSimpleFileAccessProtectorInformation info) in c:\\P\\ZP\\15.2\\ZetaProducerReferences\\Externals\\ZetaVoyagerLibrary\\Externals\\ZetaLongPaths\\Source\\RuntimeNetCore\\ZlpSimpleFileAccessProtector.cs:Zeile 88.",

    HelpLink=null,

    Source="Microsoft Access Database Engine",

    HResult=-2147467259

    }





    Detailangaben (Fehlermeldung) bei "Backup":


    System.Data.OleDb.OleDbException


    -----------------


    The search key was not found in any record.


    -----------------


    bei System.Data.OleDb.OleDbCommand.ExecuteCommandTextErrorHandling(OleDbHResult hr)

    bei System.Data.OleDb.OleDbCommand.ExecuteCommandTextForSingleResult(tagDBPARAMS dbParams, Object& executeResult)

    bei System.Data.OleDb.OleDbCommand.ExecuteCommandText(Object& executeResult)

    bei System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior behavior, String method)

    bei System.Data.OleDb.OleDbCommand.ExecuteNonQuery()

    bei Zeta.VoyagerLibrary.Data.Base.AdoNetBaseQuerier`4.ExecuteNonQuery(TConnection connection, String sql, DataCacheInformation dataCacheInformation) in c:\P\ZP\15.2\ZetaProducerReferences\Externals\ZetaVoyagerLibrary\Source\Data\Base\AdoNetBaseQuerier.cs:Zeile 2845.

    bei ZetaProducer.RuntimeBusinessLogic.Webbing.Projects.Settings.WebProjectSettingsDynamic.<>c__DisplayClass43_0.<writeToDatabase>b__0() in c:\P\ZP\15.2\ZetaProducerMain\Source\Core\RuntimeBusinessLogic\Webbing\Projects\Settings\WebProjectSettingsDynamic.cs:Zeile 465.

    bei ZetaLongPaths.ZlpSimpleFileAccessProtector.Protect(Action action, ZlpSimpleFileAccessProtectorInformation info) in c:\P\ZP\15.2\ZetaProducerReferences\Externals\ZetaVoyagerLibrary\Externals\ZetaLongPaths\Source\RuntimeNetCore\ZlpSimpleFileAccessProtector.cs:Zeile 88.


    OleDbException

    {

    ErrorCode=-2147467259,

    Errors=OleDbErrorCollection

    {

    Count=1,

    },

    Message="The search key was not found in any record.",

    Data=

    [

    ]

    ,

    InnerException=null,

    TargetSite=RuntimeMethodInfo: ExecuteCommandTextErrorHandling,

    StackTrace=" bei System.Data.OleDb.OleDbCommand.ExecuteCommandTextErrorHandling(OleDbHResult hr)\\r\\n bei System.Data.OleDb.OleDbCommand.ExecuteCommandTextForSingleResult(tagDBPARAMS dbParams, Object& executeResult)\\r\\n bei System.Data.OleDb.OleDbCommand.ExecuteCommandText(Object& executeResult)\\r\\n bei System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior behavior, String method)\\r\\n bei System.Data.OleDb.OleDbCommand.ExecuteNonQuery()\\r\\n bei Zeta.VoyagerLibrary.Data.Base.AdoNetBaseQuerier`4.ExecuteNonQuery(TConnection connection, String sql, DataCacheInformation dataCacheInformation) in c:\\P\\ZP\\15.2\\ZetaProducerReferences\\Externals\\ZetaVoyagerLibrary\\Source\\Data\\Base\\AdoNetBaseQuerier.cs:Zeile 2845.\\r\\n bei ZetaProducer.RuntimeBusinessLogic.Webbing.Projects.Settings.WebProjectSettingsDynamic.<>c__DisplayClass43_0.<writeToDatabase>b__0() in c:\\P\\ZP\\15.2\\ZetaProducerMain\\Source\\Core\\RuntimeBusinessLogic\\Webbing\\Projects\\Settings\\WebProjectSettingsDynamic.cs:Zeile 465.\\r\\n bei ZetaLongPaths.ZlpSimpleFileAccessProtector.Protect(Action action, ZlpSimpleFileAccessProtectorInformation info) in c:\\P\\ZP\\15.2\\ZetaProducerReferences\\Externals\\ZetaVoyagerLibrary\\Externals\\ZetaLongPaths\\Source\\RuntimeNetCore\\ZlpSimpleFileAccessProtector.cs:Zeile 88.",

    HelpLink=null,

    Source="Microsoft Access Database Engine",

    HResult=-2147467259

    }





    Screenshot Bereich "Layout":





    Den Fehlerbericht habe ich via ZP bereits an den Support gesendet.

    Bleibt gesund! #stayathome


    Beste Grüße
    Jörg




    ---
    Ich nutze Zeta Producer 15.3.0 Business / Windows 10

  • Hallo Jörg,


    der Fehler ist uns bisher leider unbekannt.


    Hast Du mal probiert das Suche-Widget (Seite System > Suche) zu löschen und dann wieder neu einzufügen?


    Du kannst uns das Projekt auch gerne mal zusenden. Am besten aber noch heute Vormittag, wenn möglich.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Steffen T. Hallo, habe die Seite "Suche" gerade gelöscht und neu eingefügt. Keine Veränderung...

    Eine Zusendung des Projekts über den ZP ist mir nicht möglich, da die Übertragung abbricht - und zwar wieder mit der Fehlermeldung "The search key was not found in any record." :(

    Welche weitere Möglichkeit habe ich, das Projekt an Euch zu senden?

    Problem ist nämlich: Auf Basis dieses Webprojekts sollen noch in diesem Jahr weitere Websites für andere Auftraggeber erfolgen, die dann entsprechend inhaltlich angepasst werden, da wird die Zeit echt knapp... :/

    Bleibt gesund! #stayathome


    Beste Grüße
    Jörg




    ---
    Ich nutze Zeta Producer 15.3.0 Business / Windows 10

  • Hallo Steffen,

    der Sendevorgang läuft noch...

    Nachtrag: Upload ist erfolgt.

    Bleibt gesund! #stayathome


    Beste Grüße
    Jörg




    ---
    Ich nutze Zeta Producer 15.3.0 Business / Windows 10

  • Hallo Jörg,


    konnte das beheben. War wohl irgendwas mit der Layout-Variante oder der Datenbank beschädigt.


    Habe Dir gerade eine E-Mail mit allen Infos und Download gesendet.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Hallo Steffen T. ,

    vielen Dank! :thumbup:

    Habe es nun eingespielt in den ZP. Im Bereich "Datenschutzerklärung" ist die Textformatierung einigermaßen durcheinander geraten (Abstände etc.) aber das kann ich schnell beheben.

    Seltsam ist aber, dass in der Vorschau im Browser die diversen Weblinks in der Datenschutzerklärung (Google, Facebook etc.) nicht mehr zum eigentlichen Ziel führen. :rolleyes:

    Auch ist Impressum eine Logo-Grafik nicht mehr vorhanden (kann ich aber schnell nachtragen).

    Die vier Logografiken im unteren Bereich der Seiten ("Unsere Partner:") sowie die Grafik "up-arrow" werden innerhalb es ZP angezeigt, bei der Browser-Voransicht jedoch nicht. Und zwar in keinem verwendeten Browser (Chrome, FF, Edge).

    Ich arbeite das nach und teste dann nochmals auf dem Webserver des Kunden.

    Hoffe, es stimmt aber ansonsten alles, denn wie gesagt wird diese Website als Grundlage für weitere derselben Auftraggeber-Gruppe dienen sollen und ich möchte vermeiden, dass sich evtl. doch noch vorhandene Fehler potenzieren...

    Bleibt gesund! #stayathome


    Beste Grüße
    Jörg




    ---
    Ich nutze Zeta Producer 15.3.0 Business / Windows 10

  • Guten Morgen,

    ich habe ebenfalls die Fehlermeldung "The search key was not found in any record". Auch manuelles Neueinfügen der Suchfunktion brachte keine Veränderung.

    Zeta Business 15.2.0

    Projektvorlage: Top Responsive - Campfire

    Was kann ich tun? denn ich kann derzeit nicht in den Layout Designer wechseln, auch nicht bei völligem Löschen des Suchwidgets

    Besten Dank

    Tobias

  • Hallo tjess wann tritt denn die Fehlermeldung bei Ihnen genau auf. Welche Funktion führen Sie im Programm aus, bevor die Fehlermeldung auftritt?

  • PS: ich bezweifle, dass dies etwas mit dem Suchfeld zu tun hat. Versuche in diese Richtung können sich Nutzer, bei denen der Fehler auftritt, getrost sparen.

  • Hallo Stefan,


    vielen Dank für die schnelle Rückmeldung. Die Fehlermeldung tritt beim Start des Projekts auf sowie beim Versuch, den Layout-Designer zu öffnen. Dies ist dann auch nicht möglich.

    Ich habe gerade die 32 Bit Variante von Zeta erstellt und Zeta wie angewiesen neu gestartet. Leider ohne Erfolg

    Ich habe auch gar kein MS Office auf diesem PC, jedoch auf meinem Laptop, auf dem ich das Projekt ursprünglich angelegt habe. Dort ist die Meldung auch anzutreffen. Glaube, dort bereits den 32 Patch angewendet zu haben, kann ich das irgendwo in zeta sehen? Auf dem Laptop erscheint bei dem Projekt die gleiche Fehlermeldung und der Layout-Designer lässt sich nicht öffnen.
    Bbesten Dank

    Tobias

  • Hallo tjess dann senden Sie mir bitte das Projekt wie folgt zu, damit ich mir das mal ansehen kann:


    1. Öffnen Sie Ihr Projekt in Zeta Producer
    2. Gehen Sie auf das Menü "Extras"
    3. Klicken Sie auf den Button "Optionen"
    4. Klicken Sie auf "Aktionen"
    5. Klicken Sie rechts auf die Aktion "Projekt Senden" damit diese Markiert ist
    6. Klicken Sie unten auf den Button "Ausführen"
    7. Geben Sie im 1. Feld Ihre E-Mail-Adresse ein, damit wir Sie für Rückfragen kontaktieren können
    8. Geben Sie als Referenz ins Feld Bemerkungen den Link zu diesem Forum-Artikel ein (per Kopieren und Einfügen)
    9. Klicken Sie auf den Button "Senden"
  • Hallo Stefan,

    das geht leider nicht aufgrund der Fehlermeldung. Ich habe es soeben manuell versendet.

    Besten Dank schonmal

    Viele Grüße

    Tobias

  • Hallo,


    besten Dank. Ich konnte das Projekt mit MS-Access per "Datenbank komprimieren/reparieren" reparieren. Der Fehler trat jetzt bei mir zumindest nicht mehr auf.