Web-Artikelübersicht

  • Hallo, eine Frage zur Web-Artikelübersicht. Ich muss das Modul öffnen und wieder schließen, damit alle neuen Seiten angezeigt werden. Ist das so gedacht oder gibt es eine Einstellung damit das automatisch passiert?

  • Hallo Franz,


    es gibt bei der Seite eine Möglichkeit, dass sie immer automatisch mit erstellt wird:


    RMK auf die Seite -> Eigenschaften (bei ZP10 in der linken unteren Ecke einen Doppelklick machen) -> Erweiterte Eigenschaften - > Diese Seite jedes Mal erstellen aktivieren


    Nun müsste die Seite immer mit erstellt werden.


    Gruß Robert

  • Hallo Franz,


    was meinst du mit, das Modul wird nicht aktualisiert? Webartikel sind eine kurze Auflistung (Vorschau) von den bestehenden Artikeln eines definerten Bereichs und einer gewissen Anzahl an Ergebnissen (bei dir 5 Ergebnisse vom Bereich Standard). Das Ergebnis wird dann auf der Seite generiert. Das Fenster im Modul selber dient, dass du vor dem Ergebnis noch einen Text einfügen kannst (z.B. Wir bieten hier Ihnen eine kleine Vorschau der letzten Meldungen............) und nicht der Webartikel-Vorschau.


    Gruß Robert

  • Hallo Robert, ich habe auf einigen Seiten das Modul eingefügt um dort jeweils eine kurze Übersicht der aktuellsten 5 Artikel zu zeigen. Wenn ich nun neue Artikel/Seiten hinzufüge, wird das in den erwähnten Modulen erst angezeigt, wenn ich sie öffne und wieder schließe.

  • Genau hier liegt ja das Problem, die Änderungen werden nicht übernommen. Auch wenn ich das ganze Projekt neu erstelle, ist in keinem einzigen Modul eine neue Seite zu sehen. Erst wenn ich das/die Modul(e) öffne und wieder schliesse, wird es aktualisiert.


    Wenn man das auf mehreren Seiten einfügt, um z.b. eine News Übersicht darzustellen, ist das recht mühsam.

    Aus meiner Sicht müsste es sich hier um einen Softwarefehler handeln oder es ist so programmiert. Das ist ja die Frage, ist das so gewollt oder eben ein Fehler?

  • Was versteht du eigentlich unter Modul? Meinst du die Seite? Wenn du die Seite meinst, dann ist das normal, dass sie neu erstellt werden musst. Damit du dies nicht bei jeder Seite machen musst, wo du das "Aktive Objekt" bzw. den "Artikel" "Webartikel Übersicht" eingefügt hast habe ich dir bereits folgenden Rat gegeben:


    Rechten Maus Klick (RMK) auf die Seite -> Eigenschaften (bei ZP10 in der linken unteren Ecke einen Doppelklick machen) -> Erweiterte Eigenschaften - > Diese Seite jedes Mal erstellen aktivieren



    Wenn dies alles nicht greift, so bleibt leider nichts übrig, dass du die Seiten mittels RMK neu erstellst. Habe so ein ähnliches Problem bei einem großen Webprojekt in ZP9 das nicht alle Seiten korrekt erstellt werden, obwohl ich das Projekt neu erstelle. Es handelt sich anscheinend um ein Problem mit dem Cache des Programms, wobei aber versprochen wurde, dass das Caching in ZP10 verbessert wurde.


    Gruß Robert

  • Zuerst mal danke für Deine Ausdauer. Es ist schon interessant wie schwierig es sein kann etwas zu vermitteln.


    Es hat nichts mit dem Seitenerstellen zu tun. Mit Modul meine ich das eingefügte Element "Web-Artikelübersicht". Das habe ich auf einigen Seiten eingefügt damit jeweils die letzten 5 Beiträge aus einem Bereich zu sehen sind. Und das funktioniert nicht.


    Folgendes habe ich versucht:


    Zitat

    Rechten Maus Klick (RMK) auf die Seite -> Eigenschaften (bei ZP10 in der linken unteren Ecke einen Doppelklick machen) -> Erweiterte Eigenschaften - > Diese Seite jedes Mal erstellen aktivieren


    Ich muss auf jeder Seite in der das Element "Web-Artikelübersicht" eingefügt ist das Element ("Web-Artikelübersicht") öffnen und wieder schließen, damit der aktuelle Stand angezeigt wird. Sonst zeigt das Element ("Web-Artikelübersicht") nur den Stand vom letzten Mal öffnen/schließen an.


    Am besten warten wir ob sich das Zeta-Producer Team dazu äußert.

  • Hallo Franz,


    haben eben die "Web-Artikelübersicht" getestet. Habe das Objekt im Layout "Lime" in den Newsbereich eingefügt (also genau wie bei Dir auch). Die Seite, welches das Objekt beinhaltet, habe ich so eingestellt, dass diese Seite immer erstellt wird (hat Robert ja schon erklärt). Dann habe ich neue Artikel eingefügt und die Website Erstellt bzw. Veröffentlicht. Die Web-Artikelübersicht hat immer alles korrekt angezeigt.


    Die integrierte Vorschau zeigt die Web-Artikelübersicht übrigens erst aktualisiert an, wenn Du unter "Website" auf "Website Erstellen" oder "Website veröffentlichen" klickst an. Vielleicht ist das ja die Ursache.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)