Hintergrund feststellen

  • Hallo,


    wenn du dich auskennst mit dem editieren der css.Datei deines Layouts, dann ergänze den Bodyeintrag zum schluß mit folgendem:


    background-attachment:fixed; padding:0px;


    Gruß
    Jochen

  • Hallo.


    das vorgehen zu richtigen Handhabung der css Datei ist hier beschrieben: Version 11 - Geändertes Handling von Layouts


    Wichtiger Hinweis dazu: Für manuelle Änderungen in der Layoutvorlage, übernehmen Zeta Software (und auch ich) keine Garantie auf die weitere Lauffähigkeit deines Projektes!!!


    Also aufpassen, was du da machst und am besten vorher eine Sicherheitskopie machen.


    Gruß
    Jochen

  • hallo
    hätte auch so gern den hintergrund fest ? was mach ich verkehrt.
    -ich gehe in mein projektordner zum projekt
    -media -styles und dann trage ich wie oben beschrieben -background-attachment:fixed; padding:0px;- ein und speichere!
    aber es passiert nichts ?


    Gruß
    DaKe

  • Hallo DaKe,


    du bearbeitest mit ziemlicher Sicherheit, die falsche Styles.css Datei.


    Diese musst du erst, wie folgend beschrieben in deinem Projekordner dazu "bereitstellen".


    Ich versuchs mit Hilfe eines Bilder vom Stefan (danke), das du in der Anlage findest.


    - Im oberen Teil des Bildes ist der Pfad, wo sich die Orginallayouts des ZP befinden (ist ein versteckter Order, daher bitte auf Sichtbar umstellen)


    - Im unteren Teil des Bildes ist der Pfad, wohin du das Originallayout kopieren musst.


    Also:


    1. Erstelle in deinem Projekordner einen Order namens "Layouts" (wie im unteren Teil des Bildes)
    2. Kopiere dir nun den Originalorder des Layouts, wie z.B. "Golf" in den erstellten Ordner "Layouts" rein. (Originallayout liegt, wie im oberen Teil des Bildes zu sehen)
    3. Nun hast du dort eine Kopie des Layouts drin, das du bearbeiten kannst.
    4. Dieses Layout hat nun Priorität, wenn du dein Projekt im ZP öffnest.
    5. Jetzt entweder die Tastenkombination STRG-SHIFT-T drücken, oder kurz in den Layoutdesigner gehen um die Änderungen einzulesen.


    Gruß
    Jochen


    P.s.: Bitte um Rückmeldung, ob diese Beschreibung einfach zu verstehen war, und zum Erfolg geführt hat?

  • Hallo Jochen


    Danke für deine schnelle Antwort.Müssen allerdings jetzt auf eine Hochzeitsfeier.Ich tüfftle morgen weiter.Danke dir schon mal.Melde mich dann morgen nochmal.Danke schon mal


    Gruß
    DaKe

  • Hallo Jochen


    Mit dem Bild ist verständlich.Aber es funktioniert trozdem nicht ? Irgendwie steh ich auf dem Schlauch ??


    also alles da so rein kopiert wie auf dem Bild angezeigt nur in dem Falle layout Travel
    -dann öffne ich den ordner Travel - media-styles und ergänze den bodyeintrag ? dann speichere ich und schließe die Datei
    -dann gehe ich in ZP öffne normal mein Projeckt aber es passiert nichts ?



    Gruß
    DaKe

  • Hallo DaKe,


    hast du auch den Punkt 5 meiner Beschreibung beachtet und durchgeführt?
    Denn erst dadurch, werden die Änderungen auf dein Layout eingelesen und übernommen.


    Gruß
    Jochen

  • Hallo DaKe,


    hast du auch den Punkt 5 meiner Beschreibung beachtet und durchgeführt?
    Denn erst dadurch, werden die Änderungen auf dein Layout eingelesen und übernommen.


    Gruß
    Jochen

    Ja auch die tastenkombi hatte ich gedrückt.ich versuch alles nochmal zu machen

  • Hallo DaKe,


    wir machen das jetzt mal anders rum.


    Beschreibe mal bitte ganz genau wie du vorgehst, schritt für schritt.
    Also was kopierst du von wo > nach wo, und welche Datei editierst du, und was machst du dann?


    Dann werden wir bestimmt den Fehler finden.


    Gruß
    Jochen

  • hallo
    schwiegermutter hatte noch geburtstag... hatte ich vergessen.
    ich benutze ZP 11.2 und Windows 7


    1.ich erstelle einen ordener layout in meinem project
    documente>ZP 11> Project>mein Projeckt öffnen>dort erstelle ich den layoutordner.


    2.orginal LayoutTravel kopieren und in den erstellten Layout Ordner kopieren


    C:\Users\DaKe-Laptop\AppData\Local\Zeta Producer 11\Packaging\Layouts\de\


    3.kopiertes layout in dem fall travel in den zu 1. erstellten ordner kopieren
    4.dann
    öffne ich das project>gehe auf mein
    projekt>layout>travel>media>styles>ergänze den
    bodyeintrag wie auf der seite beschrieben und speicher dies
    C:\Users\DaKe-Laptop\Documents\Zeta Producer 11\Projects\mein project\Layout\Travel\_media und dann styles


    danach
    öffne ich ZP und mache die tastenkombie die du mir geschrieben hast und
    habe auch schon versucht in den layoutbereich noch mal auf travel
    klicken und in beiden fällen arbeitet er dann und dann scrollt das
    hintergrundbild immer noch mit ?


    Hoffe du blickst halbwegs durch ,von dem was ich hier geschrieben habe ??


    Gruß
    Daniel

  • Hallo Daniel,


    sehr gut.... habe den Fehler schon gefunden:


    Der Layoutordner, den du in deinem Projektordner erstellen sollst muss "Layouts" lauten und nicht "Layout"!


    Bitte das noch ändern, und dann wirds gehen!


    Gruß
    Jochen

  • Ja, dein Schritt 2 und 3 ist auch noch falsch, ist mir eben beim 2ten mal lesen aufgefallen!


    Deinen Projekorder musst du nicht kopieren!!!


    Ich habe das Gefühl, du bringst da ein wenig was durcheinander.


    Lies dir bitte nochmal ganz genau in ruhe meine anleitung von oben durch.

  • Ok, wenn du deinen Layoutordner, jetzt auch schon umbenannt hast in "Layouts", dann sieht das ganze erstmal so richtig aus.
    Dann läuft vermutlich was beim editieren, styles.css Datei falsch.


    1. Editierst du auch die richtige styles.css, oder eine andere sytles.css Datei, die es durchaus auch geben kann, aber ein wenig anders heißt.
    2. Poste hier mal bitte den Oberen Teil der styles.css datei, so das ich sehen kann, ob da passt.


    Gruß
    Jochen

  • /*
    * Layout: Travel
    * $Id: styles.css 21281 2013-03-14 16:36:03Z sseiz $
    * Copyright Zeta Software GmbH 2012
    */
    /***** TAGS *****/
    html {
    overflow-y: scroll;
    }
    body {
    font-family: #text(global-font-family);
    margin: 0;
    padding: 0;
    font-size: #text(articletext-font-size);
    color: #text(articletext-font-color);
    background-color: #text(footer-background-color);
    background-image: url(stock-images/noise.png);
    background-attachment:fixed; padding:0px;
    }
    h1 {
    margin: 0 20px 20px 0;
    padding: 0 0 20px 0;
    font-size: #text(pagetitle-font-size);

  • Ok, das stimmt auch.....


    Einzige vermutung von mir, ist jetzt immer noch, das der Ordner "Layout" heißt und nicht "Layouts" mit s!


    Kann es das noch sein?

  • hallo


    danke für deine geduld.pass auf... ich hatte noch ein paar andere projecktversuche und da habe ich das layout boxes. da habe ich es genau nach deiner beschreibung gemacht und es funktioniert !!!
    nur brauch ich es da nicht ?
    habe aber gesehen das in dem ordner boxes nur eine styles datei ist ! in meinem aktuellen sind noch so zwei komische andere dabei ?? wo ich natürlich nichts mit mache ! kopiere sie mal ? vielleicht sagt es dir ja was ?

  • die eine heist styles-je7
    drin steht :/***** TAGS *****/
    ul, ol {
    margin: 0 0 #text(paragraph-spacing) 30px;
    }
    /***** DROPDOWN *****/
    ul.mainmenu ul span.row-separator, ul.mainmenu ul span.row-separator:hover {
    display: none;
    }
    ul.mainmenu ul li span a {
    display: inline-block;
    background-image: url(stock-images/t.gif);
    }
    /***** WEBBOX *****/
    #webbox, #webboxplus {
    position: static;
    }


    und einmal styles je8


    mit : /***** SEARCH *****/
    #searchfield {
    padding: 3px 5px 0 23px;
    height: 20px;
    }


    sagt dir das was ?
    ist bei boxes jedenfalls nicht dabei ?

  • Diese 2 css Dateien, kannst du ignorieren.
    Diese beinhalten zusatzanweisungen für die Layoutanzeige, wenn jemand noch mit dem IE 7 und IE8 unterwegs ist.


    Es muss nur die styles.css Datei editiert werden.


    Vorschlag:


    Jetzt erstmal ne Nacht drüber schlafen und morgen mit frischem Kopf nochmal an die Sache rangehen.
    Meistens klappt es dann ganz plötzlich...


    Ich werde morgen das ganze auch mal mit dem Layout "Travel" testen, es könnte ja sein, das es ausgerechnet bei diesem nicht gehen sollte.


    Glaub ich jetzt zwar nicht so ganz, aber wer weiß....


    Also wir lesen dann morgen wieder voneinander, das wird schon noch klappen!.


    Gruß
    Jochen

  • Hi Daniel,


    jetzt hat es mir eben doch keine Ruhe gelassen, und ich habe das eben mal überprüft....


    Und tatsächlich, in diesem Layout geht das so nicht!


    Aber ich habe auch schon die Lösung parat...............


    Du musst den Eintrag im Abschnitt "Body-Box" machen, dann passt es!


    Also so :
    /***** BODYBOX *****/
    #bodybox {
    margin: 0;
    padding: 0;
    min-width: 1080px;
    background-color: #text(global-background-color);
    background-image: url(#text(global-background-image));
    background-attachment:fixed; padding:0px;


    ................
    Gut zu wissen, das also manches nicht mit jedem Layout im Body-Abschnitt zu regeln ist.
    (Man lernt ja nie aus :-)


    Aber so geht es ja jetzt!


    Gruß
    Jochen

  • Ja genau da, in der normalen styles.css Datei, nur etwas weiter unten wie der Body-Eintrag.


    Du bist jetzt ganz kurz vor dem Ziel ;-)

  • hallo,


    das mit dem bearbeiten der css funktioniert jetzt wunderbar, AAAAABER... wenn ich jetzt zB. ein anderes Hintergrundbild über den Layout-Modus einfüge, wird es auch in der Vorschau angezeigt, aber nicht auf dem Server aktuallisiert. bzw. die Dateien werden nicht im LAYOUTS-Ordner aktuallisiert, sondern nur im "normalen" -media Ordner. Ist das so?


    Habe gerade festgestellt, dass das Hochladen mit ZP irgendwie gar nicht mehr geht.... er verarbeit und nichts passiert....

  • Habe gerade festgestellt, dass das Hochladen mit ZP irgendwie gar nicht mehr geht.... er verarbeit und nichts passiert....


    Das ist das Problem, da das andere einwandfrei geht und man da auch nichts weiteres dann beachten muss.
    (Auch nach dem wechseln einer Hintergrundgrafik)


    Hat das veröffentlichen bei diesem Projekt schon über den ZP funktioniert?
    Was sagt denn der FTP-Test dazu?


    Gruß
    Jochen

  • es sieht aber mit festem Hintergrund einfach besser aus ... bitte liebe programmierer baut den css tag doch standardmäßig mit ein.
    ...also, habe jetzt alles vom anderen rechner hochgeladen und es geht jetzt auch. der ftp test war bei beiden IO.
    Im Moment ist die siete aktuell, werde nochmal beobachten.danke trotzdem.