Konvertierungsproblem

  • Hallo Zeta-Team,


    wenn mal Zeit vorhanden sein sollte, dann mal bitte folgendes nachstellen bzw. überprüfen:


    1. Im ZP 12 ein neues Projekt mit dem Layout Stripe Responsive erstellen (ohne Header).
    2. Diese Projekt dann in den ZP12.5 konvertieren.


    Ergebnis bei ZP 12: http://hosting.zeta-producer.com/2829977267/index.html


    Ergebnis nach Konvertierung im ZP 12.5: http://hosting.zeta-producer.com/2829981627/index.html


    Es geht um den Abstand zwischen Logo und dem Inhaltsbereich.


    Im ZP 12 ist im Quelltext für den Body folgendes drin: padding-top: 65px;
    Der ZP 12.5 macht daraus einen Body von: padding-top: 125px;
    (Diese Angaben sind nicht von mir manuell eingefügt worden)


    Warum? ?(

  • Hallo Jochen,


    das Layout "Stripe Responsive" wurde für Zeta Producer 12.5 hier wohl etwas angepasst. Sieht im ZP 12.5 mit Abstand doch viel besser aus ;)

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Hi Steffen,


    sowas hab ich vermutet.


    Es ist nur so, das es in meinem fall nicht mehr gut ausssieht.
    Und wenn ich es manuell ändere (egal im CSS oder Attribute) dann sieht es zwar online richtig aus, aber leider in der internen Vorschau des ZPs nicht ?(
    Vermutlich weil es so schon fest im Layout drin ist.
    Oder hast du gerade eine Idee, wie man das korrigieren könnte?

  • Wie sieht es in der internen Vorschau denn aus?


    Wie sieht es in der lokalen externen Vorschau aus? Wie online?

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Interne Vorschau und lokale Vorschau, sind fehlerhaft (es ist ein Rand über den Logobereich zu sehen)
    Onlineversion hingegen stimmt....
    (Gleicher Browser)


    Der gute alte "Trick" mit dem Layout kopieren (aus dem AppData), scheint ja nicht mehr in der 12.5 zu funktionieren, so wie ich das bis jetzt gesehen habe?
    Die neue Funktion mit dem Layout Kopieren und bearbeiten hab ich jetzt noch nicht versucht.

  • Nochmal kurz erwärmt :P


    Bild 1 zeigt die interne Ansicht im ZP.
    Wenn ich mir dort den Quelltext anzeigen lasse, gibt es den oben erwähnte Body-Eintrag nicht.


    Bild 2 zeigt dann die lokale Ansicht, in der es dann plötzlich den Body-Eintrag gibt.


    Was kann das denn sein?....


    Alles ein Standardlayout, das sogar das Problem zeigt, wenn man es ganz frisch und neu in der 12.5 erstellt.



    P.s.: Diverse Bild-Darstellungsprobleme in der 12.5 Version habe ich mittlerweile auch feststellen können/müssen.

  • Hallo,


    in 12.5 wird, wenn kein Header angezeigt wird, 60px mehr top-padding an den Body angefügt weil die Abstände zwischen Menü und Breadcrumbs bzw. Inhalt sonst viel zu gering waren. Dass es hier eine Diskrepanz zwischen interner Vorschau und Browser-Vorschau gab, war ein Fehler, den ich intern bereits behoben habe.


    Um diesen Wert zu kompensieren kannst Du folgendes CSS nutzen:


    .contentcontainer {
    margin-top: -60px;
    }