Konvertierung von Version 9 nach Version 10 funktioniert nicht

  • Hallo!


    Bei der Konvertierung eines Webprojectes von Version 9 in Version 10 kam folgende Fehlermeldung:


    Die Datei 'template.xml' konnte am Speicherort 'C:\Dokumente und Einstellungen\köpke\Desktop\Backup - Koepke - 2009-11-29 22_35_48\web\Vorlage Standard\template.xml' nicht gefunden werden.


    Wo kriege ich die Datei her oder habe ich einen Fehler gemacht? :?:

  • Weil die Freewareversion von ZP9 nur 10 Seiten anbietet.
    Bei der Erweiterung auf die damalige Desktopversion konnte man 80 Seiten erstellen.


    Die jetzige ZP10 Freeware-Version bietet stattdessen 50 Seiten an.


    Wie sich das natürlich jetzt mit deinem Projekt von Version 8 verhält, das du über die 9 auf die 10 updaten willst, da bin ich mir gerade
    nicht so sicher.


    Ich denke es sollte aber dennoch klappen.


    Gruß
    Jochen


    P.S.: Ich gehe davon aus, dass das andere somit geklappt hat?

  • Alles andere hat so geklappt. Aber wie soll ich ein Projekt über 9 auf auf die 10er Version konvertieren, wenn ich in der 8. Version schon mehr Seiten habe als die 9er überhaupt zulässt?

  • Es genügt das Projekt in der Freeware 9 zu öffnen so dass die Datenbank aktualisiert wird. Erstellen musst Du das Projekt nicht.

    Freundliche Grüße
    Steffen T. (Zeta Producer-Support)

  • Leider funktioniert die Konvertierung von der 9 auf die 10er Version nicht. Fehlermeldung siehe oben. Könnte das dran liegen, dass bei mir der Projektordner auf dem Desktop und nicht unter dem in der Konvertierungsanleitung angegeben Pfad liegt.? Zudem scheint die Konvertierung nach 9 geklappt zu haben, denn ich kann das Projekt in der 8 Version nicht mehr bearbeiten. Zumindest funktioniert die Vorschau nicht mehr( Sicherheitskopie ist aber vorhanden). Allerdings tut sie das auch nicht in Version 9, die nur 10 Seiten ermöglicht. Das Projekt hat aber 25 Seiten. Vielleicht hilft mir eine Anleitung für die Konvertierung von 8 nach 9. Und bitte nicht auf die Anleitung von 9 nach 10 verweisen.

  • Hallo,


    es tut mir ja leid, aber mich muss wieder auf die Anleitung verweisen und insbesondere die Punkt 3 und 4 erwähnen, denn da wird deine Frage schon beantwortet.


    JA, dein Projekt und Layoutordner müssen in dem Pfad liegen, der in der Anleitung beschrieben ist, und zwar die jeweiligen Ordner von der 9` einfach in die die 10 kopieren.


    Und nicht versuchen von einem anderen Pfad, oder aus einem Backupordner, ein Projekt zu öffnen, das geht leider so nicht.


    Das setzt natürlich voraus, das du dein Projekt von der Version 8, unter der 9 öffnen konntest, und das hat ja anscheinend bei dir geklappt.


    Egal, ob dein Projekt 25 Seiten hat und die 9` Freewareverson nur 10 Seiten zur Verfügung stehen.


    Steffen hat ja dazu geschrieben, das es reicht, das Projekt unter der 9 zu öffnen, und dann hast du unter der 10`er, wieder 50 Seiten zur Verfügung.


    Gruß
    Jochen


    P.S.: Ein Projekt, das mit einer höheren Version geöffnet worden ist, kannst du mit einer älteren Version nicht mehr öffnen!

  • Es tut mir leid, aber obwohl ich mich an die Anleitung gehalten habe funktioniert die Konvertierung von 9 nach 10 immer noch nicht. Zudem konnte ich den Punkt "Webprojekt öffnen" in der 10er Version nicht finden. Dort gibt es nur den Punkt "Zeta Producer Website öffnen" und es erscheint immer wieder die Meldung:
    Die Datei 'template.xml' konnte am Speicherort 'C:\Dokumente und Einstellungen\köpke\Desktop\Backup - Koepke - 2009-11-29 22_35_48\web\Vorlage Standard\template.xml' nicht gefunden werden.
    Wer kann mir helfen das Problem zu lösen? In dem Ordner in dem die fehlende Datei liegen soll ist nur die Datei "default.html" aber nicht die Datei "template.xml" drin :(

  • Hallo,


    wenn du dich an die Punkte 3 und 4 gehalten hast, musst du unter ZP10, links oben auf das Symbol mit dem Pfeil nach unten anklicken und dort dann „Website öffnen“ und dann sollte dein Projekt erscheinen, wenn nicht dann musst du unten bei Pfad auf die Pünktchen klicken und dann dein zu öffnendes projekt auswählen.


    Dies sollte ich normalerweise wie in der Anleitung auf Punkt 4 erwähnt, befinden.


    Alternativ kannst du auch unter ZP10 auf Website > Website öffnen und dann auch wieder wie oben beschrieben dein Projekt auswählen.


    Und ansonsten gilt das, was ich in meinem letzten Beitrag geschrieben habe.


    Und ja, bei der Anleitung ist der Punkt 5 nicht ganz richtig geschrieben!
    Es heisst "Website öffnen" und nicht "Webprojekt öffnen".


    Ausser das kommt beim erstmaligen Starten von ZP10 nach einer Neuinstallation, das weiß ich jetzt gerade nicht.
    Werde ich demnächst mal testen, und wenn das nicht so sein sollte, werden ich das dem Zeta-Team mitteilen, das dies geändert werden sollte.


    Gruß
    Jochen

  • Das ist ja alles schön und gut. Aber es hilft mir nicht. Wie oben erwähnt lässt sich das Webprojekt nicht konvertieren obwohl ich mich Schritt für Schritt an die Anleitung gehalten habe (Fehlermeldung siehe oben). Also wo ist der Fehler? Eine Template - Datei gibt es dort, aber die hat die Endung mdb, ist also eine Microsoft Access Datei und keine XML - Datei. Das muss ich korrekterweise richtigstellen. ?(

  • Hallo,


    deine Fehlermeldung "Die Datei 'template.xml' konnte am Speicherort 'C:\Dokumente und Einstellungen\köpke\Desktop\Backup - Koepke - 2009-11-29 22_35_48\web\Vorlage Standard\template.xml' nicht gefunden werden." kommt deshalb, weil du versuchst dein projekt aus einem Backup-Ordner zu öffnen, und das geht so nicht!!!


    Dein Projekt muss sich als Projekt und Layout, im Projekt-, und Layoutordner im jeweiligen Verzeichnis liegen, das du von der 9 rauskopiert hast!


    Windows Vista und Windows 7:


    C:\Benutzer\IhrName\Dokumente\Zeta Producer 10\Projects
    C:\Benutzer\IhrName\Dokumente\Zeta Producer 10\Projects\Projektname\Layouts


    Windows XP:


    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer 10\Projects
    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer 10\Projects\Projektname\Layouts


    Hast du das schon so gemacht?


    Gruß
    Jochen

  • Genauso und nicht anders. In dem Backupordner liegen die Unterordner " Ausgabe", "Layouts", "Temp", " Vorlage Standard" und "web". Müssen die als Einzelordner unter "Projekte" liegen? Und muss ich dann das ganze schon unter der Version 9 machen? Denn die Datei "Template.xml" müsste ja eigentlich schon bei der Konvertierung von Version 8 nach Version 9 angelegt werden.

  • Ok, ich versuche dir jetzt mal Schritt für schritt zu helfen.


    Ich sollte dazu wissen, ob du folgende Voraussetzung hast:


    Hast du dein Zeta Producer 9 noch auf dem selben Rechner wie jetzt die 10`er Version installiert und lässt sich dein Projekt auch fehlerfrei unter der 9`er Version öffnen?


    Und bitte beachten, das du die jeweils aktuellste Version vom Zeta Producer drauf hast.
    Zeta Producer 9.5.0.0
    Zeta Producer 10.6.0.24


    Falls das so ist, dann schreibe wieder, und es geht weiter mit dem nächsten Schritt.

  • Also, das Projekt wurde nicht von mir sondern einer anderen Person erstellt. Ich habe dann den Backup - Ordner von dem Autor erhalten. Dieser Ordner lag von Beginn nicht unter Zetaproducer 8 Desktop, sondern auf dem Desktop meines Computers. In der 8er Version konnte das Projekt immer problemlos öffnen. Ich habe dann vor ein paar Tagen, die 9 er Version installiert, das auf dem Desktop liegende Projekt konvertiert und die nötigen Ordner in die 10er Version k opiert und das Projekt geöffnet., ohne Erfolg. Ich habe dann das Projekt nach Zeta Producer 8 in den Projects - Ordner kopiert, in der 8 Version geöffnet und erstellt, entsprechend der Anleitung in die Ordner der 9er Version (frisch runtergeladen von Zeta Producer) kopiert und geöffnet. Dann habe ich den Project - Ordner und die Layouts in die in der Anleitung angegebenen Ordner kopiert und das Projekt geöffnet, ohne Erfolg. Und ja die 9 er Version liegt auf dem gleichen Rechner wie die 8 er und die 10er Version (ebenfalls frisch runtergeladen). In Version 9 wird mir zwar der Bearbeitungsmodus angezeigt, aber die Vorschau funktioniert nicht, will sagen,das Erstellen der Seiten funktioniert nicht. Da das Projekt 25 Seiten umfasst, kann ich die 8er Version erst dann löschen wenn das Projekt in der 10er Version funktioniert, da ich sonst keine Aktualisierung mehr vornehmen kann. Könnte es sein, dass ich für die korrekte Konvertierung Administrator - Rechte benötige und, dass der Ordner in dem die Dateien des Projektes liegen den Namen des Projektes tragen muss und nicht als Backup Ordner benannt sein darf? Zusatz: Ich habe den Backup Ordner in den Namen des Projektes umbenannt. Dann habe ich den Konvertierungsprozess unter Administratorrechten wiederholt, erneut ohne Erfolg. Die Datei " template.xml wird einfach nicht erstellt.

  • Ok, wenn ich das jetzt richtig verstanden habe, befindet sich nun dein Projekt und das dazugehörige Layout (ganz wichtig!!!) unter:


    Windows Vista und Windows 7:


    C:\Benutzer\IhrName\Dokumente\Zeta Producer Desktop 9\Projects
    C:\Benutzer\IhrName\Dokumente\Zeta Producer Desktop 9\Layouts\DEU


    oder Windows XP:


    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer Desktop 9\Projects
    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer Desktop 9\Layouts\DEU


    Und du kannst unter Version 9 das Projekt auch öffnen, und hast auch dort zugriff auf das dazugehörige Layout, nur kannst du halt nicht erstellen, wegen der Seitenbegrenzung, ist das so????


    Wenn das gegeben ist, dann kopiere bitte am besten den KOMPLETTEN Inhalt Ordner Laoyuts/DEU und Projects nach:


    Windows Vista und Windows 7:


    C:\Benutzer\IhrName\Dokumente\Zeta Producer 10\Projects
    C:\Benutzer\IhrName\Dokumente\Zeta Producer 10\Projects\Projektname\Layouts


    Windows XP:


    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer 10\Projects
    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer 10\Projects\Projektname\Layouts


    Und bitte bitte nicht aus einem von Zeta-Producer erstellten Backup-Ordner versuchen das Projekt zu öffnen!


    Wenn du so vorgehst, sollte eigentlich alles Problemlos gehen!


    Gruß
    Jochen

  • Um dir weiterhelfen zu können, bitte ich dich folgendes mal zu beantworten:


    Ok, wenn ich das jetzt richtig verstanden habe, befindet sich nun dein Projekt und das dazugehörige Layout (ganz wichtig!!!) unter:


    Windows Vista und Windows 7:


    C:\Benutzer\IhrName\Dokumente\Zeta Producer Desktop 9\Projects
    C:\Benutzer\IhrName\Dokumente\Zeta Producer Desktop 9\Layouts\DEU


    oder Windows XP:


    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer Desktop 9\Projects
    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer Desktop 9\Layouts\DEU


    Und du kannst unter Version 9 das Projekt auch öffnen, und hast auch dort zugriff auf das dazugehörige Layout (also erscheint das richtige Layout deines Projektes unter den Layouts), nur kannst du halt nicht erstellen, wegen der Seitenbegrenzung, ist das so??????????

  • Ja, das ist so. Ich bin allerdings gerade dabei die 10er Version neu zu installieren, da ich nicht mehr weiß ob ich es das erste Mal unter Admin - Rechten gemacht habe. Möglicherweise ist deshalb die Installation fehlerhaft.

  • Wenn das so ist, dann ist das doch schon mal die richtige Voraussetzung.


    Und du hast dann auch den "KOMPLETTEN" Inhalt der Ordner Projects und Layouts in die richtigen Ordner von ZP10 kopiert?

  • Ok, nächste Frage dazu:


    Und wenn du nun unter ZP10 unter:


    WinXP:


    C:\Dokumente und Einstellungen\IhrName\Eigene Dateien\Zeta Producer 10\Projects


    oder Win7/Vista:


    C:\Benutzer\IhrName\Dokumente\Zeta Producer 10\Projects


    öffnen willst, kommt die Fehlermeldung?

  • Bitte überprüfe mal, ob in folgendem Verzeichnis eine Datei "template.xml" vorhanden ist:
    C:\Users\name\Documents\Zeta Producer 10\Projects\projektname\Vorlage Standard


    Wenn ja, dann kopiere diese Datei und fügen sie in folgendes Verzeichnis ein:
    C:\Users\name\Documents\Zeta Producer 10\Projects\projektname\Layouts\layoutname


    Öffnen dann dein Projekt unter ZP10 und dann Daumen drücken.

  • Genau so ist es. Auch die Neuinstallation der Version 10 hat daran nichts geändert. Da liegt zwar eine template - Datei, aber die ist kein xml - Dokument Sie hat die Endung .mdb. Und das andere C:\Users\name\Documents\Zeta Producer 10\Projects\projektname\Layouts\layoutname gibt es nicht. Dort liegt nur der Ordner Deu.

  • Dann vermute ich mal, das schon ein Fehler vorliegt bei der Konvertierung von ZP8 auf die 9´er Version.


    Ich kann dir jetzt nur noch folgendes anbieten, wenn du das möchtest.


    Schick mir dein Projekt und den Layout Ordner von der ZP8 Version per E-Mail zu, und ich versuche mal das die nächsten Tage
    für dich hinzubekommen.


    Wenn du das nicht möchtest, dann musst du mal abwarten, ob noch jemanden anderes was dazu einfällt, oder dich direkt an jemanden von Zeta-Software zu wenden.


    Gruß
    Jochen

  • Nachtrag....


    Hab eben nochmal deinen letzten Eintrag gelesen und da ist mir ein Fehler aufgefallen!!


    Und zwar muss sich im Ordner Layouts/DEU dein Layout befinden!!!!!!


    Also schau mal nach ob, das in der 9`er und 8´Version vorhanden ist!

  • Ja, es ist in beiden Versionen vorhanden. Es liegt sowohl in der 8 wie auch der 9 unter: C:\Dokumente und Einstellungen\admin\Eigene Dateien\zeta producer Desktop 8\Layouts\DEU ( bei der 9er Version muss natürlich anstelle der 8 die 9 stehen).

  • In der 10er Version ist es auch da. Aber liegt es natürlich unter Projects\Namedes Projekts\Layouts\DEU. Allerdings gibt es den anderen Ordner auch noch in der 10er Version also zeta Producer 10\layouts\DEU

  • Also, und in diesem Ordner muss dein Layout rein.


    WIE IN DER ANLEITUNG BESCHRIEBEN!!


    Nachtrag:


    So langsam komme ich auch durcheinander, in der Anleitung ist, das anders beschrieben, wie ich das sonst immer gemacht habe...........

  • Hallo Jochen!


    Trotz aller Bemühungen auch des Kollegen, der die Seite erstellt hat funktioniert die Konvertierung nicht. Auch der Kollgen erhält immer die Meldung mit der fehlenden template.xml - Datei. Ich würde deshalb gern auf dein Angebot zurückkommen wenn es noch steht.


    Gruß


    osradioman

  • Würde mich interessieren, wie das ausgegangen ist.


    Ich kann Projekte problemlos von 9 auf 10 konvertieren, das geht "nach Vorschrft" wie weiter oben beschrieben oder einfach durch Öffnen des 9er-Projekts aus 10 heraus. Aber egal, wie ich es mache, ich kann in 10 dann das Layout (konkret mit 'on-air' und 'business' aus 9) nicht ändern. Ich kassiere dabei jedesmal eine Fehlermeldung, die das Fehlen einer template.xml aus einem völlig anderen Projekt bemängelt, s.u.


    Die Datei 'template.xml' konnte am Speicherort 'M:\Zeta Producer 10\Layouts\DEU\anderes_Projekt\template.xml' nicht gefunden werden.

  • Hallo,


    wir sind bei der Sache einen schritt weitergekommen.


    Das projekt lässt sich nun unter ZP10 öffnen und bearbeiten (zumindest bei mir)-


    Nur mit dem jetzt noch "Schönheitsfehler", das so vermutlich mit deinem Problem auch zusammen hängt, das man das Layout nicht bearbeiten kann.


    Aber mal abwarten, evtl. gibt es da auch bald eine Lösung dazu....


    Gruß
    Jochen

  • Hallo zusammen,


    die Fehlermeldung deutet auf ein veraltetes Vorlagenprojekt hin. Zeta Producer 10 speichert Vorlagendaten im XML-Format, bei früheren Versionen wurde das MDB-Format verwendet. Damit ein solches Vorlagenprojekt in Version 10 verwendet werden kann muss es zuerst konvertiert werden, was normalerweise automatisch geschieht. Dies scheint nicht funktioniert zu haben (Eventuell Absturz während des Vorgangs o. ä.). Möglicherweise fehlt auch die MDB-Datei. Dies bitte prüfen.


    Sollte die MDB-Datei existieren könnt Ihr die Konvertierung auch manuell vornehmen. Zeta Producer bietet hierfür eine integrierte Konvertierungsfunktion an. Ihr erreicht diese unter:


    Website -> Einstellungen konfigurieren -> Aktionen -> Vorlagenprojekt von MDB nach XML konvertieren


    Achtung: Diese Funktion sollte nur von erfahrenen Anwendern verwendet werden und es gibt keinen Garantie auf Funktion bzw. darauf dass sich das Projekt nachher fehlerfrei öffnen lässt. Außerdem sollte VOR der Benutzung ein Backup des Vorlagenprojektes erstellt werden.

  • Ich hatte gestern schlicht irgendeine template.xml in den angezeigten Ordner kopiert. Seitdem ist die Fehlermeldung weg und auch der Layoutwechsel geht.

  • Hallo zusammen,


    für alle die diesen Thread mitverfolgt haben und wissen möchten wie es nun ausgegangen ist.


    -Zum einen wurde die "web.producer" Datei im Project-Ordner nicht richtig erstellt, und deshalb konnte man
    das Projekt erstmal gar nicht öffnen.


    Abhilfe: Einfach eine "web.producer" Datei von einem anderen Projekt von ZP10 in den Projectordner reinkopieren und dann
    ging erstmal das öffnen des Projekts.


    Dann ließ sich zwar endlich mal das Projekt öffen, aber der Punkt "Layout bearbeiten" war nicht anwählbar.


    Abhilfe hier:


    Man musste den Layout-Ordner von der 9`er Version in den Globalen-Layoutordner von ZP10
    reinkopieren und nicht in den Layoutordner des Projects, zusätzlich musste man hier dann noch eine template.xml Datei von einem anderen bereits von ZP10 erzeugten Projekt reinkopieren (so wie es auch rhuber gemacht hat).


    Warum und wieso, das nicht "normal" lief > Keine Ahnung, aber hautpsache es geht jetzt!


    Gruß
    Jochen