Beiträge von Hanabi

    Hallo Norbert,


    der Link auf den Thread zu "Projekt kopieren" erfolgte nur, weil dort das grundsätzliche Verfahren zum Umbenennen eines Projektes erfolgte, betraf also nur Frage 1.


    Frage 2 habe ich losgelöst davon beantwortet. Im Ergebnis des Importes einer mit Zeta erstellten Webseite sollte verstanden worden sein, warum dieses möglich, aber nicht sinnvoll ist (solange man das Ursprungsprojekt hat).


    PS: Threads werden geschlossen, sofern Administratoren/Moderaten dieses Forums der Auffassung sind, dass zur gestellten Frage eine hinreichend erschöpfende Antwort gegeben wurde und weitere Beiträge den fragenden User (oder andere Forumsteilnehmer) nur verwirren würden. Dabei fließt auch ein, dass wir nahezu täglich neue User im Forum begrüßen, die sich mit der gesamten Thematik Zeta erst vertraut machen müssen und denen mit "Zerfaserungen" oder "ja aber..." in Beitrag 20 nicht unbedingt geholfen ist, wenn die Lösung des Problems bereits in Beitrag 10 steht. Diese eröffnen dann vor lauter Angst, etwas falsch verstanden zu haben, einen neuen Thread, in dem wir Moderatoren/Administratoren dann wieder auf einzelne Antworten in einem bereits vorhandenen Thread verweisen. Das ist unnötiger Aufwand, der vermieden werden sollte (genauso, wie der umstand, das dieses PS: schon wieder länger ist als die eigentliche Antwort).

    Hallo WIRMD ,


    Bei Aufruf von http://www.wirsindmd.de/news-aus-magdeburg.php Im Samsung Galaxy fällt auf, dass die Bilder zu allen anderen Beiträgen in voller Bildschirmbreite erscheinen, lediglich das Bild zu "Lemsdorfer Hofkultur" hat einen freien Bereich rechts. Dieses Bild wird auch auf dem Laptop mit einer geringeren Breite als die anderen Bilder angezeigt. Alle anderen Bilder sind 1920x1280, das "Lemsdorfer" ist 1728x1157. Ändere mal in der Bilderverwaltung die Größe des Bildes auf auf 1920x1280. Ich habe jetzt nicht umgerechnet, ob 1920x1280 das gleiche Seitenverhältnis hat wie 1728x1157. Wen Du die 1920x1280 nicht erreichst, muss das Bild (beispielsweise über irfanview) extern auf dieses Pixelmaß zugeschnitten und neu importiert werden.

    Hallo rummy,


    wenn es mit Zeta 12.5 läuft, gibt es vermutlich einen Zusammenhang mit der verwendeten/veralteten PHP-Version. Zu Zeiten von Zeta 12.5 war ja noch PHP 5.6 aktuell, welche vermutlich momentan auf dem Server aktiviert ist.


    Da es mit 12.5 und der aktuell verwendeten PHP-Version läuft, wäre der nächste Schritt, eine Subdomain für den Test Zeta 15 + PHP 7.2 einzurichten.

    Hallo Ingo,


    gehe mal, bevor Du die Artikelverwaltung öffnest, ganz unten rechts auf den nach unten gerichteten Pfeil und dann auf "Protokoll". Dieses öffnet sich in einem neuen Fenster. Danach in die Artikelverwaltung, nochmals versuchen, die Bilder einzufügen, mit OK bestätigen und die Artikelverwaltung schließen. Jetzt das Protokollfenster öffnen, ob dort irgendwelche Fehler angezeigt werden.

    Kroatische Adria, 33°C, Sonnenschein und ebenfalls Sonntag :). Der Versatz kommt tatsächlich durch die unterschiedlich langen Überschriften zustande ("Veranstaltungen in der Festung..." bereits bei Desktop-Ansicht - Notebook zweizeilig) zustande, ansonsten sind keine Darstellungsfehler erkennbar.

    Hallo Roland,


    die Shop-Navigation wird über

    Code
    1. <p class="categories">
    2. <!-- Parent-Gruppen -->
    3. <a href="shop.php?id=8-junge-mode">
    4. Junge Mode </a>»
    5. <!-- Aktuelle Gruppe -->
    6. <a class="currentCategory" href="shop.php?id=6-schuhe">
    7. Schuhe </a>
    8. </p>

    angezeigt, wir müssen also die class "categories" über CSS ausblenden.


    Dies erfolgt über "Website" -> "Einstellungen" ->"CSS" mittels:

    Code
    1. <style>.categories {
    2. display: none;
    3. }
    4. </style>

    Danach neu veröffentlichen.

    Hallo Gaspare ,


    die PHP-Version wird direkt beim Hoster aktiviert. Dieser bietet über eine entsprechende Konsole / Control-Center die Möglichkeit, für jede registrierte Domain eine bestimmte PHP-Version festzulegen. Die betroffene Webseite ist mit Zeta 15.0.1 erstellt. Hierfür ist vorzugsweise PHP 7.2 zu verwenden. Sollte der beim Hoster vorliegende Vertrag kein PHP enthalten, müsste ein entsprechendes Upgrade beim Hoster erfolgen. Die Konfiguration des Servers, der zur Veröffentlichung genutzt wird, liegt aber grundsätzlich außerhalb des Software-Supportes für Zeta, weitergehende Hilfe kann nur gegeben werden, wenn zumindest der Hoster und das entsprechende Hosting-Paket bekannt sind.

    Hallo Ottmar,


    siehe z. B. https://www.html.de/threads/da…rewrite.45863/post-323676. Grundlegende Infos zur .htaccess findest Du auch in meinem Blog-Beitrag (siehe Signatur). Eine komplette beispielhafte .htaccess habe ich im Thread htaccess ausblenden von .index als Anhang beigefügt, dort dann den Abschnitt "Aufruf auch ohne .html" suchen, kopieren und anpassen (der Abschnitt ist in meinen Muster - glaube ich - auskommentiert).

    Hallo Iwab,


    Du bist genau im passenden Thread. Zu den Gründen, weshalb die Vererbung weggefallen ist, hatte Steffen bereits in Beitrag #10 was gesagt. Beim Konvertieren i die 15 wurden bestehende Vererbungen in Verknüpfungen umgewandelt. Das Vorgehen ist daher jetzt etwas anders, als bisher mit vererbten Artikeln. Wir haben jetzt sozusagen einen Masterartikel, bei dem sich Änderungen auf alle verknüpften Artikel auswirken. Wenn Du nur für eine einzelne Seite oder eine Gruppe von Unterseiten einen anderen Header gestalten möchtest, muss zunächst der über Verknüpfung vorhandene Artikel gelöscht werden, da dieser zwar individuell geändert werden kann, aber durch die Verknüpfung bei einer Änderung des Masterartikels mit diesem überschrieben wird. Wenn also Deine Seite aus den Themen A-E besteht und zu jedem Thema mehrere Unterseiten existieren, lösche zunächst den auf den Seiten A1-A10 vorhandenen Header. Lege dann auf A1 einen neuen Header an, kopiere diesen und füge ihn dann auf A2-A10 über "Verknüpfung einfügen" ein. Der Header auf A1 ist dann der Master, dessen Änderungen sich auf A2-A10 auswirken.


    PS: In anderen Forenbeiträgen wurde bereits angedeutet, dass die Funktionalität der Verknüpfung noch erweitert wird.

    Guten Morgen,


    das scheint unabhängig vom Browser zu passieren, ist jedenfalls in Chrome und IE nachvollziehbar. Mir fällt dabei auf, dass die Objekt-ID im Quelltext erst hinter der H1-Überschrift steht, während zum Vergleich (unsere Startseite) die Objekt-ID über der Überschrift steht. Dies würde das unterschiedliche Sprungverhalten erklären.

    Code: Top (André)
    1. <h1>Blog</h1>
    2. <div id="bloglist9325" class="bloglist incols">
    Code: Clean-Style (Thomas)
    1. <div id="a30915" data-article-id="30915" data-zpleid="30915" class="articlearea zpwText">
    2. <h1>Aktuelle Meldungen des SFV Feuerblume e. V.</h1> </div>

    Da ich an der kroatischen Adria ohne Zeta unterwegs bin, kann ich jetzt nicht testen, ob dies nun am Layout oder am Widget "Blog" liegt.

    Hallo Helena,


    die FTP-Einstellungen sind schon mal richtig, ich komme zumindest bis auf die Anmeldeseite vor. Normalerweise sollte, da auf https://www.grundschule-langlingen.de/index.php unter "Aktuelles aus der Schule" noch "Für diese Seite wurde noch kein Inhalt erfasst." steht, zumindest eine Schaltfläche da sein "neuen Artikel hinzufügen". Wenn diese fehlt, mal bitte auf den regulären Support am Montag warten. Ich bin momentan ohne Zeta-Rechner im Urlaub und kann da nur eingeschränkt Unterstützung bieten. Es könnte in Richtung falscher oder fehlender Dateiberechtigungen für einzelne Ordner gehen, dass können aber die Jungs vom Support morgen besser prüfen und abklären als ich jetzt nur vom Tablet aus.

    Hallo Suna,


    Dann reicht es aus, die Daten via FTP zu kopieren. Die Daten auf dem alten Server enthalten nur die Webadresse, die ja unverändert bleibt. Es braucht also dort nichts geändert zu werden.

    Hallo Suna,


    da wünsche ich erstmal viel Gesundheit.


    Zu Deiner Frage: Wenn ich mich recht erinnere, veröffentlichst Du nicht über Zeta, sondern über Filezilla unter Nutzung des Ordners /output, da es mit Zeta irgendwelche Probleme gab. In diesem Ausnahmefall brauchst Du, wenn die Webadresse mit umzieht, keine Änderungen an den FTP-Einstellungen in Zeta vornehmen, sondern lediglich "alle Seiten erstellen". Im Ordner /output liegt dann die komplette Seite zur Übertragung per Filezilla auf den neuen Hoster bereit.

    Hinweis für Mitleser: Normalerweise plädiere ich ja für eine Veröffentlichung via Zeta, rauszubekommen, was jetzt das Problem in der Veröffentlichung mit Zeta ist, würde jedoch erheblich mehr Zeit in Anspruch nehmen, die ein gerade erst Genesener auch anders verbringen kann.

    Hallo Heiko,


    da die letzte Veröffentlichung ins "falsche Verzeichnis" am 15.08. noch funktioniert hatte, solltest Du mal alle seitdem vorgenommenen Änderungen kontrollieren. Die Fehlermeldung beinhaltet Hinweise auf fehlerhaftes CSS, also da bitte auch noch einen Blick reinwerfen.

    Hallo Heiko,


    die aktuelle Seite ist über https://www.jh-fotografie.de/jh-fotografie/ aufrufbar (Kontakt und Impressum deutsch). Die Sitemap https://www.jh-fotografie.de/jh-fotografie/sitemap.xml zeigt den 15.08.2019 als Datum der letzten Änderung. Versuche noch einmal, nur mit / im Ordner zu veröffentlichen. Nach dem Ändern der FTP-Einstellungen und vor dem Veröffentlichen klickst Du auf das kleine nach unten gerichtete Dreieck in Zeta ganz unten links und dann auf Protokoll. Dieses öffnet sich in einem neuen Fenster. Nach dem Veröffentlichen kannst Du dann im Protokoll nachsehen, ob es dort Auffälligkeiten gibt.

    Hallo Edo,


    es scheint aber mit Deinem System zusammenzuhängen, da ein gleichartiges Problem bisher nicht im Forum geschildert wurde und die aktuelle V15 inzwischen schon einige Nutzer haben dürfte. Weitere Ursache könnte auch zu wenig Arbeitsspeicher sein. Bei Fehlern, die auf anderen Rechnern nicht reproduzierbar sind, ist es schwierig, eine passende Diagnose zu stellen.

    Hallo Edo,


    der Text ist ein Platzhalter für ein Bild, welches nicht angezeigt werden kann. Üblicherweise könnten es Einstellungen in der Firewall oder ein Virenscanner sein, die da stören. Dann sollten aber eigentlich die Bilder auch nicht veröffentlicht werden können. Bin gerade nur mit Tablet unterwegs, kann das also leider nicht in Zeta nachbauen.

    Hallo Heiko,


    überprüfe mal, ob in Strato die Domain auf den Ordner /jh-fotografie verweist. Vermutlich ist dort direkt das Root-Verzeichnis angegeben, in Zeta sollte also beim Ordner nur / stehen. Wenn Du aber in Zeta den Ordner nicht ändern kannst, wegen "not valid", wäre das zumindest erstmal eine Übergangslösung, damit die Änderungen auch online erscheinen. Das "no valid" muss man dann nochmal genauer anschauen.

    Die Verwendung einer Objekt-ID wird im Handbuch unter https://docs.zeta-producer.com/objekt-ids-verwenden.html beschrieben. Wenn jemand außerhalb dieser Anleitung im HTML-Code rumhantiert, um partout - und entgegen dem Rat aller - Wörter inmitten von Texten anzuspringen, anstatt die Texte in eigene Artikel zu gliedern, dann ist diesem User nicht mehr zu helfen.


    Nachtrag:

    Bei einer sachgemäßen Anwendung werden beim Linktyp "Seite" die auswählbaren Sprungmarken angezeigt im Bereich "Anfang der Seite" (siehe Bild 2), da Zeta die Umsetzung der Objekt-ID in der jeweiligen Artikelüberschrift vornimmt und diese Objekt-ID jeweils für den ganzen Artikel gilt.

    Im vom User Zetahufi vorgetragenen Fall wird die Sprungmarke (ID) via HTML-Quelltext mitten im Text platziert, so dass die neue Sprung-ID mitten in einer bereits vorhandenen Sprung-ID liegt. Die neue Sprungmarke ist aber gleichwohl vorhanden, da anstelle "Anfang der Seite" nunmehr ein TEXTFREIES Feld (siehe Bild 1) angezeigt wird.

    Hallo Polsterfix ,


    1. Wenn Du bereits eine Lizenz für die aktuelle Version 15 hast, diese hier https://www.zeta-producer.com/de/download.html herunterladen. Wenn Du noch im Besitz einer Vorgängerlizenz bist und momentan noch nicht wchseln möchtest, findest Du die zur Lizenz passende Version hier: https://www.zeta-producer.com/de/aeltere-versionen.html
    2. Sollte nach Eingabe der Lizenznummer sich diese nicht aktivieren lassen, muss der Aktivierungszähler erhöht werden. In dem Fall bitte eine E-Mail an support (at) zeta-producer.com , idealerweise von der Mail-Adresse aus, die ursprünglich zum Erwerb der Lizenz verwendet wurde.
    3. Vom alten Rechner benötigst Du aus dem Verzeichnis /Dokumente/Zeta Producer 13(14/15) den Ordner /projects sowie zur Sicherheit auch den Ordner /backup.
    4. Falls Du Widgets kopiert und angepasst hast, öffne das Projekt auf dem alten Rechner und überprüfe, dass das angepasste Widget im Projekt gespeichert ist.
    5. Bevor der alte Rechner gelöscht wird, alle Projekte auf dem neuen Gerät auf Funktionalität prüfen

    Hallo Norbert,


    offizielle Features für die Verlinkung sind ausschließlich die unter "Link" angegebenen Möglichkeiten Extern / Seite / Datei / Bild, wobei ausschließlich bei "Seite" zusätzlich die Möglichkeit besteht, auf einen bestimmten Artikel zu springen.


    Wir bitten um Verständnis, dass Probleme, die durch Verwendung von "Hacks" / "geheimen Funktionen" / "kopierten oder selbstentwickelten Widgets" etc. Support nur dahingehend geleistet werden kann, dass angeraten wird, auf solche "Hacks" zu verzichten.

    Bei "Privat" kann die Videos nur der angemeldete Benutzer "Buch88" sehen. Der richtige Modus wäre "nicht gelistet". Dann taucht das Video nicht in der allgemeinen Youtube-Übersicht und auch in der Suche nicht auf, kann aber durch den Link weiter direkt aufgerufen werden, ohne dass man als Besitzer angemeldet ist. Musste eben auch erst einmal schauen, da die letzte Video-Einbindung auch schon wieder zwei Jahre (EM in Tschechien) zurückliegt.

    Hallo Buch88 ,


    der optimale Weg führt über Youtube oder Vimeo. Zum einen wäre die Frage der Kompatibilität (verschiedene Dateiformate zur Verfügung stellen) ausgelagert, zum anderen kannst Du dann im Blog-Artikel, nachdem der eigentliche Text fertiggestellt ist, auf HTML-Quelltext umschalten und dort den Einbettungscode von Youtube oder Vimeo einfügen. Beide Plattformen unterstützen inzwischen auch einen Einbettungscode mit erweiterten Datenschutzeinstellungen (Übertragung beginnt erst bei PLAY).


    Theoretisch sollte es im Blog-Artikel im HTML-Quellcode-Modus auch über den "object" aufruf gehen, wie unter https://www.mediaevent.de/xhtml/object.html beschrieben, das Video müsste dann aber trotzdem zumindest als .mp4 und .ogg vorhanden sein.

    Hallo Gottfried,


    die vier Jahre alte Seite aus Version 12 bringt uns nicht weiter. Gehe mal bitte auf "Erweitert" -> "Dateien" und kontrolliere, ob die 400 MB große MP4-Datei komplett aus dem Projekt entfernt ist. Wenn nein, dann diese bitte noch löschen. Danach kannst Du ein Backup machen. Wenn dieses fertig ist, öffne den Windows Explorer und suche unter /eigene Dateien/zeta producer 14/backup das eben erstellte Backup. Interessant ist jetzt die Größe, Wenn unter 500 MB, könntest Du es auch über https://www.zeta-uploader.com/de versenden. Mit Ferndiagnose kommen wir, glaube ich, nicht weiter.

    Hallo Ingo,


    willkommen im Forum,


    die Umsetzung von https erfordert insgesamt 3 Schritte:

    1. SSL-Zertifikat beim Hoster aktivieren
    2. Aufruf der Seite mit https erzwingen (vereinzelt direkt beim Hoster einstellbar, ansonsten über die .htaccess -> siehe Blogbeitrag in meiner Signatur)
    3. Ändern der FTP-Einstellungen in Zeta, hierzu in der Webadresse https://www.domain.de eintragen, danach neu veröffentlichen

    Hallo Gottfried,


    jetzt bleibt wirklich nur das Support-Ticket. Seit Beitrag #4 haben wir zwar verschiedene mögliche Fehler gefunden und bereinigt, sind dem tatsächlichen Problem aber nicht wirklich näher gekommen. Da wir inzwischen bei Beitrag #23 sind, fasse ich noch mal zusammen, was wir inzwischen haben:


    Ausgangslage:

    • Die Seite ist mit Version 14.3.3-Express gemacht, verwendet wird das Layout "Boxes" (zur Zeta-Version später mehr)
    • Eine sitemap.xml ist vorhanden, die letzte Aktualisierung einzelner Seiten erfolgte am 14.07.2019, ein Großteil der Seiten wurde zuletzt am 13.11.2018 aktualisiert.
      • Anmerkung: die sitemap.xml wird zeitlich unmittelbar nach der index.html veröffentlicht. Das zu den einzelnen Seiten zugeordnete Datum bezieht sich auf die letzte Änderung im Quelltext der Seite (also die Erstellung durch Zeta), nicht die letzte Veröffentlichung.
    • Bei einzelnen Seiten, so den Pressestimmen sowie den untergeordneten Seiten Bauträger, Erben, Infrastrukturabgabe fehlt das Layout.
      • Diese Seiten weisen im Quelltext Zeta 12.2.0-Express aus.
      • Unter Zeta 12.2 wurden Styles im Ordner /_media abgelegt. Die Chrome-Konsole zeigt auf den betroffenen Seiten an, dass versucht wurde, aus diesem Verzeichnis heraus jquery oder styles.css zu laden, diese aber nicht gefunden wurden.
    • Die weiteren Seiten zeigen sich wieder mit 14.3.3 im Quelltext und korrektem Layout.
    • auf http://nordrandsiedlung.com/info-veranstaltung-2-teil.html fehlen zwei Bilder, die auf dem Server nicht gefunden werden. Diese Seite wurde zuletzt am 01.04.2019 aktualisiert.
    • Unter den zuletzt am 13.11.2018 aktualisierten Seiten (siehe sitemap.xml) befinden sich sowohl Seiten, die mit 14.3.3 ausgeliefert werden, als auch Seiten mit Auslieferung als 12.2.
    • Hoster ist https://all-inkl.com/webhosting/

    Was bisher gemacht wurde:

    • Interne Listen gelöscht - > Protokoll eingeschaltet -> komplette Neuveröffentlichung -> Veröffentlichung bricht ab
    • Protokoll ausgewertet (Hierbei wurden die Angaben zu "erstellt" und "veröffentlicht" verglichen mit dem Ergebnis, dass nicht alles, was erstellt wurde, auch erfolgreich veröffentlicht wurde. Quervergleich mit "Interne Listen -> erstellen" bestätigt, dass ein Veröffentlichungsproblem vorliegt
    • Rücksprache mit Hoster, nur 1 GB von 50 GB belegt
    • Auswertung Protokoll: mehrere PDF-Dateien, die nicht der Namenskonvention entsprechen (mehrere Punkte im Dateinamen), diese umbenannt -> keine Änderung beim Veröffentlichen
    • Screenshot von /output/media/images und /output/media/files liefert lediglich eine auffällige Dateigröße, ein Video mit 400 MB. Entfernen des Videos aus dem Projekt bringt keine Änderung


    Schlussfolgerung:


    Die Lösung hängt mit der Seite Pressestimmen oder einer davon untergeordneten Seite zusammen, da diese Seiten letztmalig mit Zeta 12.2.2 veröffentlicht wurden. Zu klären sind noch folgende Fragen:

    1. Wann erfolgte die Umstellung von Zeta 12.2. auf Zeta 14.3.3?
    2. Beim Wechsel von Zeta 12 auf Zeta 14 wurde das Projekt konvertiert, es wurde also eine Kopie des ursprünglichen Objektes gemacht und diese Kopie in das aktuelle Format überführt. Auf dem Rechner muss unter /user/.../zeta producer 12/projects/ noch das unveränderte Original liegen. Wenn dieses in Zeta 12.2 geöffnet wird, welche Inhalte sind in dem Projekt vorhanden, die auf der Homepage fehlen?