Beiträge von ComputerOASE

    Hallo Zeta und Konsorten,


    ist es im Layout "Poster Responsive" möglich, die Headergrafik so einzustellen, dass diese nicht ganz-, sondern halbseitig angezeigt wird?
    Natürlich ist es optisch ansprechender, das Bild ohne störendes Drumherum zu sehen, doch hat unser Kunde Bedenken:
    Die Seitenbesucher könnten wohl übersehen, dass erst gescrollt werden müsse und infolgedessen die Seite enttäuscht verlassen.


    Aus diesem Grund äußerte er den Wunsch, die Grafik so einzubinden, dass wenigstens die Überschrift des Seiteninhalts sofort ersichtlich ist.
    Nun unsere Frage: Ist es möglich, dies umzusetzen? Gerne auch per HTML-Workaround falls notwendig.



    Mit freundlichen Grüßen,


    Jan Bergmeister,
    Computer OASE Geislingen

    Hallo Herr Thurn,


    weshalb lässt es sich denn nicht verwenden? Welches technische Hindernis steht dabei im Weg?
    Es ist doch bereits in ZP12.5 die Möglichkeit gegeben, ein eigenes Skript zur Formularübermittlung zu verwenden, ließe sich denn damit nicht reCAPTCHA mit einbinden?
    Ein Update für 199,-€ bei nur 5 neuen Funktionen (WebFonts, Artikel-Gruppen, Blank Template, ImageSlider und CarouselWidget), liegt laut Management leider nicht im rechtfertigbaren Budget.


    Mit freundlichen Grüßen,


    Jan Bergmeister
    Computer OASE Geislingen

    Hallo Herr Thurn,


    vielen Dank für die schnelle Antwort.
    Gibt es denn eine Möglichkeit, das neue reCAPTCHA in Version 12 zu verwenden? Schließlich gibt es ja die Möglichkeit "eigenes Skript verwenden" - wie müsste das denn dort eingebunden werden?


    Die Überlegung bzgl. Formulareignung für Zielgruppe ist bereits seit längerer Zeit abgeschlossen, E-Mail und Telefon sind bereits seit mehreren Monaten als Alternative verfügbar. Da E-Mail und Telefon allerdings (aufgrund fehlender Normierung der Form) nicht automatisiert elektronisch auswertbar sind, ist ein Verzicht auf Formulare keine angemessene Lösung.
    Das Prinzip der Formularübermittlung wird von den Patienten bereits rege genutzt und stellt nach der Erfahrung unseres Kunden offensichtlich nur für einen winzigen Bruchteil der Patienten ein Hindernis dar. Nur hat eben in der letzten Zeit der Spam durch von Bots übermittelte Formulare MASSIV zugenommen, weswegen ein Spamschutz unabdingbar geworden ist. Ein Verzicht auf Formulare würde unseren Kunden wieder in die Zeit der heißlaufenden Telefonleitungen und frustrierten Kunden, die nicht durch die Belegten Leitungen durchkommen, zurückwerfen und ist deswegen leider keine Alternative.


    Mit freundlichen Grüßen,


    Jan Bergmeister
    Computer OASE Geislingen

    Hallo Zeta Support,


    da einer unserer Kunden regelmäßig von Bots versendeten Spam über seine Formulare erhält, würden wir gerne ein Captcha verwenden, um dies zukünftig zu unterbinden.


    Unglücklicherweise ist in Zeta Producer 12.5 standardmäßig nur ReCAPTCHA als Sicherheitsprüfung möglich, was an sich kein Problem wäre,
    wenn die Hauptklientel der Website nicht größtenteils aus Senioren mit zum Teil erheblichen visuellen Einschränkungen und ohne Englischkenntnisse bestehen würde.
    (Die Website ist die einer gemeinschaftliche Facharztpraxis)


    In der alltäglichen Praxis äußert sich dies in der Regel ungefähr so:


    1. Formular wird von Nutzer ausgefüllt
    2. Absenden wird von Nutzer versucht, erfolglos -> Bitte Captcha ausfüllen
    3. Nutzer: "Ich kann das nicht lesen" -> ggf. wird auf Reload bzw. Audiocaptcha-Button geklickt, sofern er gesehen wird (VIEL zu klein für Menschen mit Sichtproblemen, die 3 Buttons werden oft als "EIN längliches Rechteck" wahrgenommen
    4. Nutzer: "Ich kann kein Englisch/Ich verstehe kein Wort/Welche Sprache soll das sein?"
    5. Nutzer ist frustriert, ruft an und beschwert sich aufgrund "Falsche Versprechungen, Ihre Website funktioniert nicht"


    Nun ist unsere Frage, ob es eine für Senioren geeignete Alternative zu ReCAPTCHA gibt und was bei einer Einbindung dieser beachtet werden muss.
    Ferner möchten wir Sie darauf hinweisen, dass, sofern 2 oder mehr Formulare auf einer Seite eingebunden sind, nur das ReCAPTCHA des ersten geladen wird und die nachfolgenden Formulare dadurch unbenutzbar werden - das sollte man eventuell patchen ;)



    Mit freundlichen Grüßen,


    Jan Bergmeister
    Computer OASE Geislingen

    Hallo,


    ist es denn möglich, im Layout "Spring" die farbigen Balken, die sich zwischen Menüleiste und Inhaltsbereich befinden, ganz auszublenden?
    Alle Farben auf weiß zu setzen hat leider nicht den gewünschten Effekt, da man weiterhin den Rahmen sehen kann und man für diesen keine Farbe setzen kann - zumindest haben wir keine entsprechende Einstellungsmöglichkeit dafür gefunden.



    Freundliche Grüße aus Geislingen an der Steige,


    Computer OASE Geislingen

    Korrektur:
    Ein kleines Problem ist nun doch aufgetreten - wie auf www.dev.comp-oase.de zu sehen ist, überlappen sich die Schrift von HTML-Widget und Navigationsleiste.
    Außerdem ist die Navigationsleiste nicht "lang" genug, ich würde ja einen Workaround anwenden und die Position auf Pixel im Minusbereich setzen, aber dann verschwindet natürlich die untere Hälfte im Nirvana... Irgendwelche Ideen zur Lösung des Problems?

    Hallo ZP-Team,


    ist es möglich im Layout "Atmosphere Responsive" eine Infobox unter das Navigationsmenü links einzufügen?
    Unser Kunde möchte die Kurzdaten zum Kontakt auf jeder Seite sichtbar haben, ähnlich wie auf unserer Firmenwebsite http://www.comp-oase.de .


    Leider scheint es diese Funktion im genannten Layout nicht zu geben, weiß jemand Rat?


    Mit freundlichen Grüßen
    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Die Methode mit einer zweiten, für Bilder reservierten Artikelspalte funktioniert als Workaround recht gut, nur eines stört mich daran:
    Es ist wohl nicht möglich, die Größe des Thumbnails separat zu setzen bzw. es überhaupt kleiner als das eingebundene Bild darzustellen.
    Ich frage mich, weshalb dann überhaupt die Funktion "Bild beim Klick vergrößern" gibt?


    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Hallo Zetateam und Konsorten,


    könnte mir jemand sagen ob, und wenn ja wie, es möglich ist, Bilder seitlich oder mit Textumlauf als Thumbnail darzustellen, welches sich bei Klick in einer Lightbox öffnet?
    Also im Prinzip wie auf dieser Website, nur eben nicht am Ende vom Artikel, sondern seitlich rechts vom Absatz oder sogar mit Textumlauf.


    Ein Kunde von uns wünscht so eine Funktion auf seiner Website, wir sind uns allerdings nicht sicher, wie dies mit ZP umsetzbar ist.



    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Danke für die Lösungsvorschläge, werde mich unverzüglich mit unserem Provider in Verbindung setzen und abklären,
    ob das Charset auch für PHP umgestellt wurde - bis jetzt sieht es aber tatsächlich danach aus, als ob nur die Kodierung für HTML-Dateien korrigiert wurde.


    Eine Frage hätte ich aber noch:

    Zitat

    Bitte mal prüfen, was unter "Erweitert > Erweiterte Einstellungen > Kodierung" eingestellt ist.


    Dort sollte bei "Kodierung:" utf-8 gewählt sein und der Haken bei der Option "BOM schreiben" sollte entfernt werden.

    Wo finde ich dieses Menü? Ist von einer Einstellung im ZP oder am Server die Rede?



    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Hallo ZP-Supportteam,


    soeben haben wir unsere Homepage auf unserem hauseigenen Testserver veröffentlicht,
    doch leider werden sämtliche Sonderzeichen falsch dargestellt - es stimmt also die Zeichenkodierung nicht.


    Nun wäre meine Frage:
    Wo und wie muss ich die Kodierung ändern, um eine korrekte Zeichendarstellung zu gewährleisten?



    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Genau, Fehlerbericht wurde über ZP12.5 bereits gesendet.


    Genutzt wird der Standard Zeta Producer Testserver.
    Pfad zum Projektordner ist C:\Users\Bergmeister\Documents\Zeta Producer 12.5\projects\Radiologie Filstal.
    Habe auch alle Unterpfade geprüft, nirgends ein Sonderzeichen (vom Leerzeichen im Projektname mal abgesehen).


    Das Projekt ist mit insgesamt 66,2MB recht groß, soll ich es dennoch zur Prüfung übersenden?
    Oder reicht auch ein freigegebener Dropbox-Link mit einem aktuellen Backup des Projekts?


    Freundliche Grüße,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Hallo Supportteam,


    beim Versuch, die aktuelle Website auf den Testserver zu laden, spuckte ZP folgende Fehlermeldung aus:

    Die Fehlermeldung ist eigentlich selbsterklärend und ich würde das entsprechende Zeichen auch gerne durch ein zugelassenes ersetzen,
    nur leider ist für mich in der Fehlermeldung nicht ganz ersichtlich, welcher Pfad denn nun gemeint ist.


    Ich bedanke mich im Voraus,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Hallo Zeta-Supportteam,


    ein Kunde rief uns gestern an und meldete, das Gästebuch seiner Homepage funktioniere nicht mehr.
    Folgende Fehlermeldung erscheint stattdessen am oberen Rand der Homepage:


    Code
    Notice: A session had already been started - ignoring session_start() in /webs/www.motorradfreunde-geislingen.de/gaestebuch/gaestebuch.php on line 22

    Liegt der Fehler nun am Server, am Code des Widgets oder an etwas ganz anderem?
    Und wie kann man ihn beheben?


    Herzlichen Dank im Voraus,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen



    EDIT:
    Konnte den Fehler beheben, indem ich das Online-CMS-Modul von der Gästebuchseite entfernt habe.
    Beide PHP-Module scheinen sich also zu beißen - nachbesserungswürdig.
    Im Fall unseres jetzt nicht überaus tragisch, aber ärgerlich, da der Kunde ein CMS auf jeder öffentlich zugänglichen Seite haben wollte.


    Thema kann geschlossen werden.

    Hallo ZP-Supportteam,


    Ich habe soeben beim Versuch dem Navigationsbereich im Layout "Atmosphere Responsive" den Farbwert #614051 zuzuweisen die folgende Fehlermeldung erhalten:


    Leider werde ich daraus nicht schlau. Dieselbe Fehlermeldung kommt übrigens beim Versuch, den Farbwert der Bereiche zu ändern.
    Besonders ungünstig ist die Situation, da der Entwurf heute noch bei unserem Kunden vorliegen muss.
    Auf den Farbwert der Navigation kann notfalls verzichtet werden, aber zumindest die Transparenz im Artikelbereich sollte auf nahe (wenn nicht sogar komplett) 0% gesetzt sein, da die Besucher der Website unseres Kunden hauptsächlich ältere Menschen mit verminderter Sehkraft sind und ein hoher Kontrast dementsprechend Vorraussetzung ist.


    EDIT:
    Laut Support ist dies wohl ein Programmfehler, der damit zusammenhängt, dass des öfteren Farbwerte getauscht werden.
    Der Lösungsvorschlag, den ZP neu zu starten war leider nicht erfolgreich.


    EDIT 2:
    Die Transparenz der Bereiche ließ sich nun nach mehrmaligem Neustarten des ZP ändern.
    Sobald jedoch zusätzlich auch ein Farbwert geändert wird, schlägt die Änderung fehl und gibt besagte Fehlermeldung aus.
    Auch die Farbe der Hyperlinks lässt sich nun nicht mehr ändern - und weiß auf weiß ist ein denkbar schlechter Kontrast ;)


    Grüße,
    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Habe das Projekt übersendet.
    Genaue Textdatei gibt es keine, da das Problem mittlerweile unabhängig vom einzufügenden Text auftritt.
    Neuerdings übrigens auch ohne das Einfügen eines Bildes, der einzige rote Faden der sich durch das Phänomen zieht scheinen die Tabellen zu sein. Vor einigen Minuten trat das Problem zum ersten mal auch auf, als ich nur 1 Tabelle verwendet habe - es hat sich aufgehängt, als ich im Editor nach unten gescrollt bin.


    Edit:
    Habe die Übersendung abgebrochen, ich habe keine 20min Zeit nur um auf den Upload zu warten, das Projekt soll in 2 Stunde dem Kunden im Erstentwurf vorgelegt werden. Ich übersende das Projekt heute Abend.


    Edit 2:
    Mittlerweile tritt das Problem bei im Schnitt jeder 3. eingefügten Tabelle auf.
    Egal ob Bild im Text eingefügt ist oder gescrollt wurde. Das Erstellen einer 2x1 Tabelle reicht.


    Grüße,
    Jan

    Verwendetes Layout ist "Active" der Artikel wird ganz regulär im Inhaltsbereich eingefügt.


    Sonderlich groß ist das Bild auch nicht gerade, knapp über 70,1kB mit Maßen die 400x600px nicht überschreiten.
    Das Problem tritt außerdem unabhängig vom verwendeten Bild auf, ausschlaggebend scheint ausschließlich das Hinzufügen einer weiteren (2x1) Tabelle im selben Artikel zu sein.


    Das einzige was an dem Bild "zu groß" ist, ist der unsichtbare Rahmen (Bildmargin) den Zeta irgendwie automatisch reinpfriemelt und dadurch die Bildposition "links, Text umfließend" mit einer Funktionalität versieht, deren Bezeichnung besser "vielleicht links/vielleicht auch oben; auf jeden Fall Textformatierung durcheinanderbringend" wäre.


    Abgesehen davon erscheint mir das komplette Layout ungewöhnlich schmal, ist das Absicht?
    Hatte wie vorher schon erwähnt eigentlich vor, dafür einen separaten Thread zu öffnen, aber da wir nun schon mal bei den Layouts sind...


    Grüße,
    Jan

    Hallo Zeta - Support-Team,


    wir gestalten gerade eine Website für eine ärztliche Gemeinschaftspraxis mithilfe eurer Software.


    Leider stoßen wir dabei immer wieder auf Grenzen seitens Zeta Producer 12.5 - dieses mal scheint sich ein Bug ins Programm eingeschlichen zu haben:
    Wenn ich auf einer Subseite das Modul "Text mit Bild" einfüge und dort dann im Artikeltext eine Tabelle zum Einpflegen weiterer Bilder hinzufüge,
    klappt alles (weitgehend, zum anderen aktuell bestehend Problem werden wir wahrscheinlich noch einen separaten Thread verfassen) wunderbar.


    Sobald ich jedoch versuche, eine weitere Tabelle einzufügen, scheint der Producer in einer Endlosschleife festzuhängen:
    Nichts ist anklickbar, Mauszeiger wechselt in rapidem Tempo zwischen "Wartekringel" (das was bei XP noch eine Sanduhr war) und normaler Anzeige.
    Keine Besserung auch nach minutenlangem Warten, beenden lässt sich das Programm nur per Force Stop über den Taskmanager.


    Gibt es einen Workaround?
    Wenn ja, wie sieht der aus?


    Momentan können wir noch an anderen Bereichen der Seite weiterarbeiten, aber eine Lösung wird dringend benötigt.


    Mit freundlichen Grüßen,


    Jan-Frederik Bergmeister
    Computer OASE Geislingen

    Hallo Zeta-Team,


    nach ersten Schwierigkeiten, die Website über FTP online zu stellen (beim Versuch einen Zielordner auszuwählen gab ZP12 die Meldung "Benutzername oder -kennwort falsch" aus. Beim Prüfen der Verbindung hingegen trat diese Meldung nicht bzw. erst nachdem erfolglos versucht wurde, einen Zielordner anzuwählen, auf. Die Sache mit dem Ordner ist jedoch nicht so tragisch, die Website sollte ohnehin im Root verankert werden.) ist der Upload nun geglückt und das nächste Problem steht vor der Tür:
    Die Website wird massiv fehlerhaft dargestellt.


    Leider erschließt sich mir nicht ganz, wodurch dies verursacht wurde - es wäre nett, wenn jemand mir diesbezüglich Rückmeldung und Hilfe zur Behebung des Fehlers geben könnte.


    Liebe Grüße,
    Jan-Frederik Bergmeister
    Computer-OASE Geislingen