Bilder fehlen mal wieder...

  • Hallo,


    zuerst fehlten die Bilder Jägerweiher und Schreiberweiher. Also habe ich den Cache gelöscht, diese Seite neu erstellt und hochgeladen. Danach war der Jägerweiher da, aber der Holtz'sche Weiher und der Schreiberweiher fehlten.


    Die Bilder habe ich zusätzlich nochmal neu eingefügt. Nun habe ich die komplette Webseite erstellt und hochgeladen: Die beiden Bilder fehlen immer noch...


    Das scheint also nicht mein altes Problem zu sein.

  • Hallo,


    wie sollen wir auf Basis dieser Infos helfen können? Ausser mal ins Blaue hinein zu vermuten, dass es an Sonderzeichen im Dateinamen liegen könnte…


    Ich habe Sie schon oft gebeten, detailliertere Berichte abzuliefern, denn schließlich schauen wir Ihnen bei Ihrer Arbeit nicht zu und Sie sind auch nicht der einzige Supportfall, so dass wir uns an jedes Ihrer vergangenen Probleme (oder gemachten Fehler) erinnern könnten.

    Meine Bitten fallen aber offensichtlich auf taube Ohren. Ich werde Sie ggf. auf "Moderation" stellen und Ihre Anfragen nur freigeben, wenn Sie so formuliert sind, wie wir das hier vorschlagen: Support / Unterstützung

  • Hallo Andi,


    Sonderzeichen und Umlaute werden beim Import in Zeta automatisch "ausgemerzt". Der vollständige Link auf das Bild zeigt auch eine regelkonforme Schreibweise.


    Hallo Norbert,


    Öffne mal vor dem nächsten Veröffentlichen das Protokollfenster. Danach veröffentlichen, dann das Protokollfenster wieder aufrufen und nach Fehlern suchen.

  • Stefan S


    Ich erweitere meine Frage insofern, s. fetter Text:


    Zuerst fehlten die Bilder Jägerweiher und Schreiberweiher. Also habe ich den Cache gelöscht, diese Seite neu erstellt und hochgeladen. Danach war der Jägerweiher da, aber der Holtz'sche Weiher und der Schreiberweiher fehlten.


    Die Bilder habe ich zusätzlich nochmal neu eingefügt. Nun habe ich die komplette Webseite erstellt und hochgeladen: Die beiden Bilder fehlen immer noch...


    Das scheint also nicht mein altes Problem zu sein, >>wo es nur am überfüllten Browsercache gelegen hatte; diesen habe ich ja geleert.


    Insofern habe ich sicher mein Vorgehen zum Entdecken des Fehlers aus früheren Hilfestellungen korrekt beschrieben. Deswegen bitte ich um weiteren Rat.<<

    _____


    Selbstverständlich kann ich auch nach den Vorgaben formulieren, wenn Ihnen - und mir - das hilft:


    1. Welche Zeta Producer Version nutzen Sie?

    >>14.3.3 Home


    2. Welches Layout nutzen Sie?

    >>Steht in meiner Signatur


    3. Was möchten Sie erreichen?

    >>Dass Bilder, die ich mein Projekt eingefügt habe, online auf meiner Seite sichtbar sind


    4. Wie sind Sie dazu vorgegangen? Beschreiben Sie Schritt für Schritt, welche Arbeitsschritte Sie in Zeta Producer durchgeführt haben.

    >>Ich habe Bilder in eine Seite des Projekts eingefügt, indem ich im Artikel die Funktion "Bild einfügen" benutzte und damit ein Bild aus einem Ordner meines PCs ausgewählt


    5. Welches Resultat haben Sie erwartet?

    >>Dass das Bild eingefügt wird


    6. Was ist stattdessen passiert?

    >>Das Bild ist sowohl im Bearbeitungsmodus als auch in der Vorschau sichtbar; nach dem Veröffentlichen fehlt es aber auf meiner Webseite


    7. Wie ist die URL zur Website des veröffentlichten Projekts (falls vorhanden)?

    >>Steht im Text meiner Anfrage


    8. Falls etwas falsch aussieht, zeigen Sie uns das anhand eines Screenshot und teilen Sie uns die direkte URL der entsprechenden Seite mit.

    >> s. Screenshot 'Holtzscher Weiher'. Aus dem Text meiner Anfrage nochmals die URL: Dort fehlt das Bild aus dem Screenshot.


    9. Falls Sie eine Fehlermeldung erhalten, nutzen Sie die im Fehlerdialog enthaltene Option uns den Fehler zu berichten (unten links auf den Pfeil klicken). Alternativ klicken Sie die Option "Fehlerdetails" an posten den Text hier. Nur so erhalten wir genügend Details zur Fehlermeldung.

    >>Keine Fehlermeldung vorhanden


    Ich hoffe sehr, dass dies jetzt korrekt und hilfreich ist.

    Gerne werde ich mich künftig an diese Art der Beschreibung halten.

  • andima


    Dankeschön für dein Interesse!


    An diesem Bildnamen ist doch nichts falsch, oder?

    "media/images/holzscher_weiher_30_09_2018-dsc05293.jpg"

    Und im Bildartikel selbst ist dieses Bild mit diesem Dateinamen vorhanden, drittes von Hinten:

    Am Namen kann es also nicht liegen.


    Seltsamerweise wird es aber nicht angezeigt, wenn ich online im source code darauf klicke... Das macht mich heftig stutzig!

  • Mensch Thomas, ich hab's!


    Ich habe das Bild in eine Minimalform umbenannt, neu eingefügt und die Seite hochgeladen; guckst du.

    Völlig unverständlich ist dabei, dass ich mich bei allen Bildbennungen der gleichen Nomenklatur bediene und es immer klappte; und dieses Bild ist ja auch unter dem Originalnamen unter "Bildartikel" zu sehen...


    In diesem Fall ist es also fast mysthisch, was da passiert ist. Und, zum Glück, nicht wieder ein dummer Fehler von mir...


    Ich bin froh, dass ich dir weitere Bemühungen ersparen kann!


    Herzlichen Dank!

  • Hallo Norbert,


    ich äußere mich nur, wenn ich auch einen Lösungsansatz habe. Vielleicht solltest Du mal beschreiben, zu welchem Hoster Du nach den Problemen im letzten Jahr gewechselt bist. Wir hatten ja mal mehrere Veröffentlichungen unter Subdomains von verein.me gemacht (bei 1&1), da gab es keine Probleme.

  • Frage: Wie lang ist der Dateipfad?


    Maximale Antwort: 255 Zeichen!


    Fehlermöglichkeit 1: Bereits der Dateipfad zur Ursprungsdatei ist zu lang.


    Fehlermöglichkeit 2: Der Dateipfad zur zu veröffentlichenden Datei ist zu lang.


    Die Fehlermöglichkeit 1 können wir ausschließen, da anderenfalls ein Import in Zeta gar nicht möglich wäre. Bei Fehlermöglichkeit 2 einfach mal nachzählen und dann entsprechend handeln (Dateiname verkürzen, Projektname verkürzen etc.

  • Habe das ganze jetzt mal mit Treesize Free getestet und rücke vom Verdacht, dass es an der Pfadlänge liegt, etwas ab. Hierzu folgendes Beispiel aus der Vereinspraxis:


    • Vom Stadtlauf 2014 gibt es ein Bild mit Dateinamen 2014-0615-stadtlauf-009.jpg Für sich allein ergeben sich bereits aus dem Dateinamen 27 Zeichen.
    • Dieses Bild wird zum Veröffentlichen im Ordner /output abgelegt. Der vollständige Pad zum Bild lautet: c:\users\wir\documents\zeta producer 14\projects\sfv feuerblume e. v\output\media\images\2014-0615-stadtlauf-009.jpg Die Pfadlänge beträgt hier 116 Zeichen
    • das zugehörige Vorschaubild wird unterhalb von /images im Ordner /thumbnails abgelegt, zusätzlich wird der Dateiname um eine Größenangabe ergänzt. Vollständige Pfad lautet nunmehr: c:\users\wir\documents\zeta producer 14\projects\sfv feuerblume e. v\output\media\images\thumbnails\2014-0615-stadtlauf-009-288x192.jpg Die Pfadlänge beträgt hier 135 Zeichen


    Wenn ich statt "Wir" als Benutzername "Thomas Lilienthal" verwenden würde, wären dies noch 14 Zeichen mehr im Dateipad, das Vorschaubild wäre damit bei einer Pfadlänge von 149 Zeichen. Zu den 255 Zeichen Begrenzung ist dort immer noch jede Menge Platz.


    Ganz ausschließen möchte ich den Dateipfad jedoch nicht, da es abhängig vom einzelnen Benutzer hier noch zu viele Variablen gibt. Die Aussage von Norbert

    Ich habe das Bild in eine Minimalform umbenannt, neu eingefügt und die Seite hochgeladen

    deutet nämlich wiederum genau darauf hin, dass die Urspungsdatei eine Pfadlänge von 237 Zeichen hatte, woraus für das Vorschaubild 256 Zeichen werden, also eines zu viel

  • Da das Problem auch in einer anderen Fragestellung gerade wieder auftaucht, hier eine Anleitung zum Ermitteln der Pfadlänge:


    1. Treesize Free unter https://www.jam-software.de/freeware/ herunterladen und installieren.
    2. In diesem Tool die Projektseite aufrufen und dann bis zum Verzeichnis /output/media/images/thumbnails runtergehen. Dort mit der Maus auf das Vorschaubild gehen, welches auf der Homepage nicht angezeigt wird.
    3. Im Mouseover wird dann ganz unten die Pfadlänge anzeigt, diese bitte hier posten zusammen mit dem kompletten Pfad, damit wir mehr Daten bekommen, um das Problem einzugrenzen
    4. Wenn Ihr den Projektordner nicht kennt, dann in Zeta unter "Erweitert" auf "Ordner anzeigen" gehen.

    Wenn ich die große Suchmaschine benutze, scheinen überlange Dateipfade (und damit verbundene Probleme) kein Einzelfall zu sein. In diesem Sinne möchte ich auch Nutzer bitten, die zwar keine Probleme mit dem Upload haben, aber ihren Projektordner beispielsweise auf einem Netzlaufwerk haben oder sonstige "exotische" Speicherorte verwenden, ihre Ergebnisse hier zu posten.

  • Zetahufi hat sich inzwischen bei mir direkt gemeldet, das Projekt befand sich bei ihm auf einem anderen Laufwerk, dort direkt als Projekt abgelegt. Aus dem übermittelten Screenshot lässt sich bereits ersehen, dass eine Überschreitung der Pfadlänge unwahrscheinlich ist.


    Mit "anderes Laufwerk" kann auch ein mit einem Laufwerksbuchstaben verknüpfter Ordner, ein Netzlaufwerk, USB-Stick oder eine USB-Festplatte gemeint sein, da könnte man jetzt noch weiter schwadronieren über die Speichersicherheit auf USB-Sticks oder Zugriffe von Virenscannern oder oder oder. Fakt ist, dass nach Meldungen der User die Nichtveröffentlichung von Bildern wohl vorwiegend Vorschaubilder betrifft, die im Unterverzeichnis /thumbnails liegen.


    Selbsttest: ich habe ein Standardprojekt genommen und in einen Dateipfad verschoben, der selbst 190 Zeichen lang ist. Dazu kommen noch 7 Zeichen für den Dateinamen. Eingefügt wurde aus den Windows-Beispielbildern das chrysanthemen.jpg in ein Bilderalbum mit der Funktion Vorschaubilder. Beim Veröffentlichen wird hierzu eine Datei chysanthemen-large.jpg im Verzeichnis /images sowie eine chrysanthemen-200x150.jpg im Verzeichnis /thumbnails erstellt. Die Pfadlänge für die letzte Datei beträgt 254 Zeichen. Das Projekt wird veröffentlicht unter https://lang-pfad.zeta-producer.com/index.html und alle Bilder auch angezeigt.

    Unter Windows kopiere ich im Ordner Beispielbilder die Datei und benenne sie um in mehr-chrysanthemen.jpg, importiere diese in ein neues Album. Dies klappt völlig problemlos. Beim Veröffentlichen wird mir jedoch ein Fehler angezeigt, dass der angegebene Pfad zu lang ist. Diese Fehlermeldung hätten also auch die betroffenen User bekommen müssen. Im veröffentlichten Projekt ist das Bild nicht enthalten, die Chrome Console zeigt einen entsprechenden Fehler an.


    Ein zu langer Pfad oder Dateiname führt tatsächlich zum beschriebenen Problem, dass Bilder nicht veröffentlicht werden. Programmseitig wird dies jedoch als Fehler ausgewiesen.


    Andere Reproduktionen des Fehlers sind nicht möglich, weil die genauen Umgebungsbedingungen nicht bekannt sind.