Beiträge von uro

    Hallo. Die neuen Möglichkeiten des "Umbruchs" sind ja wirklich sehr schön (wenn man sie entdeckt hat...). Ich vermisse allerdings die Möglichkeit, die Breite der Eingabefelder individuelle einzustellen (unabhängig vom Grid). Besonders störend wirkt dies bei einem Pulldown, bei dem nur Zahlen angewählt werden sollen (siehe Beispiel). Wenn ich das über das Grid löse, betrifft das auch die auch die Beschreibung – und das soll nicht sein. Ich möchte nur das Eingabefeld verkleinern – so, wie das bis V13 ging mit dem "maximal"-Eintrag. Ist das möglich?


    Herzliche Grüße - Uwe

    Danke für die Erklärung. Noch besser als "Bilder schützen" wäre freilich, die Sache per Projekt grundsätzlich ein- oder ausschalten zu können. Die ZP-"Bilddatenbank" hat ja den Vorteil, dass man die Grafiken da sehr übersichtlich verwalten kann. Deshalb benutze ich sie nach wie vor gerne (sie sollte ja schon mal abgeschafft werden).


    Uwe

    Hallo.

    Schon in der 13 (12?), aber auch in der 14 passiert es immer wieder, dass Bilder, die ich in oder mit einem Artikel lösche, auch aus der Bilder-Datenbank verschwinden.

    Ich meine die "Datenbank", die man unter "Erweitert/Bilder" erreicht. Ich benutze diesen Weg halt immer noch gerne, weil man da Fotos und Grafiken prima sortieren und für ein Projekt zusammenhalten kann.

    Gibt es für das Verschwinden eine Einstellung/Ursache?


    Herzliche Grüße - Uwe

    Hallo.

    Das Layout "Album" verhält sich bei mir merkwürdig: Sobald ich ein neues Logo einbaue, verändern sich die Textfarben im Hauptmenü. Und zwar so, dass man im Menü nichts mehr lesen kann. Ist das ein Bug im Layout oder ein Fehler bei mir? Ich habe die Farben jetzt manuell wieder "zurückgeändert". Doch wie kommt sowas?


    Die Screenshots zeigen einmal die Layout-Settings beim Öffnen (noch alles ok) und nach dem Einfügen einer neuen Grafik.



    [Sorry - der Name des Layouts war eben falsch angegeben]

    Hallo Stefan.


    Den Pragmatismus kann ich nachvollziehen. Dennoch: Ich finde, dass der Verlust dieser Funktion schwerer wiegt als die Tatsache, dass zuvor händisch geänderte Farben nicht global durch den Assistenten angefasst werden. Darauf könnte man mit einem entsprechenden Satz hinweisen.


    Praktisch ist es doch so, dass man, wenn man ZP halbwegs professionell (nicht nur für die eigene Vereinsseite) einsetzt, die Standard-Layouts sehr weit anpasst. Die Farbe ist da meistens das erste. Auch der Kunde will da oft mitreden. Definierte Hausfarben gibt es meistens ja nur dann, wenn der Kunde bereits in sein CD investiert hat. Und mal eben zeigen, wie die Seite so oder so aussieht, geht dann jetzt ohne den Farbassistenten nicht mehr so ohne weiteres.


    Mein ganz pragmatischer Vorschlag: Gebt das doch ab Business wieder frei. Wer die Business-Version bezahlt hat, sollte mit den von Dir genannten Einschränkungen professionell klarkommen.


    Herzliche Grüße - Uwe

    Hm.


    Das wäre dann aber ganz schön blöd. Mal eben sehen, wie ein Layout in einer anderen Farbe aussieht, das geht jetzt gar nicht mehr?
    Da würde ich aber lieber in Kauf nehmen, die endgültigen Farben nachher (wenn die Farbentscheidung gefallen ist) nochmal händisch durchzugehen und kontrollieren zu müssen.
    Diese Funktion (zentrale Farbwahl im Layoutassistenten) halte ich für eine wesentliche Hilfe in der kreativen Layoutphase.


    Uwe

    Hallo Jochen.


    Finde ich ja putzig, dass wkr da anscheinend oft dasselbe denken und/oder wünschen.


    Aber was bedeutet das denn nun in diesem Punkt? Kann ich die Layoutfarben jetzt irgendwo anders zentral einstellen? Ich meine: Wenn ich z.B. ein vorgegebenes Rot etwas dunkler haben möchte, konnte ich das früher in dem Layout-Farbassistenten bequem einstellen, und es war überall geändert (Menüleute, Textfarben,.... wo auch immer das vorkommt).
    Muss ich jetzt wirklich alle Einstellbereiche und dann unten alle Einträge durchgehen und jede Farbe manuell ändern? Das kann, wie ich den ZP kenne, doch eigentlich nicht sein, oder...?


    Herzliche Grüße - Uwe

    Hallo.


    Bisher gab es doch immer die Möglichkeit, beim Klick auf "Layou" zwei verschiedene Modi auszusuchen: einen komplexen, bei dem verschiedenste Details konfiguriert werden können, und einen eifnachen, bei dem quasi nur die Hauptfarben festgelegt werden können. Ist dieser einfache Modus abgeschafft, oder finde ich jetzt gerade vor lauter Bäumen den Schalter nicht mehr...?


    Falls es den einfachen Modus nicht mehr gibt: Wie kann ich Farben zentral verändern? Muss ich wirklich jeden einzelnen Punkt im Layout-Menü durchgehen und überall die gewünschte Farbe eintragen?


    Herzliche Grüße - Uwe

    Hallo.


    Ist es möglich, den Farbwähler in den diversen Text-Editierboxen zu konfigurieren?
    Oder einfacher gesagt: Ich möchte gerne, dass in dem Pulldown der Farben nicht nur die Standard-Farben erscheinen, sondern auch eine, die ich z.B. gerade definiert und verwendet habe. Das ist zurzeit nur durch zwei weitere Klicks möglich: »Weitere Farben« und dann wählen oder editieren.
    Nicht wirklich wichtig, wäre aber schön...


    Herzliche Grüße - Uwe

    Hallo.
    Bei mir kommt es auch mit der 13.3 immer wieder und bei verschiedenen Sites vor, dass schon nach einer kleinen Önderung (Textkorrektur in einem Artikel, einfacher neuer Text-Artikel) de Meldung "Webseite wird erstellt" kommt und dann um die 140 Dateien hochgeladen werden. Das ist vor allem dann blöd, wenn man mit dem Lappi und einer schlechten Verbindung unterwegs ist.
    Ist etwas falsch konfiguriert oder muss das so?


    Herzliche Grüße - Uwe

    Danke für die Tipps. Funktioniert (mit dem Attribut).


    Ich bin immer wieder begeistert, wie flexibel und durchdacht Zeta-Producer doch ist. Entweder lassen sich Extra-Wünsche direkt ber Einstellungen (z.B. im Layout) umsetzen, oder es gibt über Möglichkeiten wie das Attribute-Setup die Chance, auch völlig Spezielles doch noch umzusetzen, ohne das System als ganzes (z.B. Updatefähigkeit) zu beeinträchtigen. "Geht nicht" hat es bei mir in all den Jahren noch nie gegeben. Das ist alles sehr weitsichtig und mit Hand und Fuß – da muss den Programmierern mal ein dickes Lob ausgesprochen werden...


    Uwe

    Also, der Wunsch an den ZP-Support: Im Formular-Widget das Kontrollkästchen auch dann funktionieren lassen, wenn in dem Feld "Bezeichnung" nichts steht.
    Oder – alternativ – die Möglichkein schaffen, dass das Feld "Bezeichnung" online im Formular nicht angezeigt wird.


    Schönes Wochenende - Uwe

    Hei Jochen.


    Ja, mit DA kann man vieles grafisch sehr schön realisieren. Leider muss man dann immer diese Klimmzüge mit dem formmailer.php machen. Und das bequeme neue Robot-Recaptcha kann DA, glaube ich, auch nicht?


    Ich hätte das – auch aus Gründen der Kontinuität – gerne alles in ZP.


    Uwe

    Noch was: Die runden Options-Checkbuttos kann man nur an, nicht mehr abklicken (bei einem Button).
    Die eckige Checkbox geht ja auch eigentlich gut - es fehlt nur der Warnhinweis für den Fall, dass die Box obligat ist.


    Edit: Muss bei dem Kontrollkästchen in dem Feld "Bezeichnung" etwas stehen? Das ist bei mir nämlich leer...


    Edit 2: Ja, daran liegt es...


    Alles gut.

    Hallo Jochen. Es geht um normale Formulare.


    Ok - mit dem "Optionsschaltflächen"-Eintrag geht es.
    Aber was ist mit dem "Kontrollkästchen"? Das hätte ich eigentlich lieber, wei es eine typische quadratische Checkbox ist.
    Welche Funktion hat das "Kontrollkästchen" denn, wenn nicht diese?

    Hallo.
    Meine ZP-Webformulare laufen jetzt prima, nur einen kleinen Schönheitsfehler scheint es zu geben. Ich möchte gerne die berühmte Checkbox" verbindlich bestellen" einbauen.
    Kein Problem. ABER: Während das Formular bei allen anderen Feldern, für die eine EIngabe verbindlich ist, eine rote Fehlermeldung ausgibt (damit der Nutzer auch dieses Feld ausfüllt), passiert bei einer leere Checkbox nichts. Also wirklich nichts: Keine Warnung, keine Reaktion. Checkt man die Checkbox an, wird das Formular bearbeitet.


    Könnte das noch behoben werden? Also dass eine nicht gecheckte obligate Checkbox beim Absendeversuch einen Warnhinweis an den Nutzer ausgibt?


    Herzliche Grüße - UR

    Hallo zusammen.


    Ich frage nicht nach dem Warum – aber nachdem ich nichts gemacht habe, außer eine Tasse Kaffee zu trinken, geht alles, wie es sich gehört. Möglicherweise wieder so eine Sache mit dem PHP und dem Cache.


    Also: GELÖST


    Danke und Entschuldigung für den Sturm im Wasserglas.


    Uwe

    Hallo. Ich habe mich mal wieder mit dem ZP-eigenen Formular-Widget versucht. Recaptcha eingebunden, Felder erstellt – und dann lässt sich das Formular nicht verschicken. Die Fehlermeldung:
    =======================
    Die E-Mail-Adresse des Formularempfängers ist ungültig. Der Betreiber
    der Website sollte die Formularkonfiguration überprüfen.
    The recipient-email of the form is invalid.The owner of this website should verify the form-configuration.
    =======================


    Die eingegebene Adresse st aber meine eigene und definitiv richtig... Sehe ich den Wald vor lauter Bäumen nicht...?


    Uwe

    D.h. bei Desktop-Menü dann kein Hover? - Dann würde ich beim Tablet lieber auf die "Zwei-Klick-Lösung" verzichten... Das Hovern ist schon wichtig, damit man schnell erkennt, dass da noch etwas ist.


    Ich habe für die Tablet-Leute jetzt noch an einer intuitiv wirksamen Stelle das Untermenü-Widget eingebaut, so dass die Sub-Seiten erreichbar sind.


    Optimal wäre also Zwei-Klick-Lösung plus Hovern.


    Was entscheidet eigentlich, wann das Desktop-Menü bleibt und wann nicht? Auf 10"-ipads wird z.B. im Hochformat das mobile Menü eingeblendet, im Querformat das Desktopmenü. Beim Pro bleibt auch hochformatig das Desktop-Menü.


    Uwe

    Hallo.
    Ich habe bei einer Site mit "Poster" jetzt einmal Submenüs (eine Ebene) eingebaut. Klappt in normalen Browsern gut, doch auf Tablets werden die Subeinträge nicht angezeigt. Jedenfalls dann nicht, wenn das Menü (z.B. auf iPadpro) noch "richtig" angezeigt wird, nicht mit dem responsiven Menü-Button (früher Hamburger-Button). Ein Touch auf den Hauptbutton öffnet stets die darunter liegende Seite, das Submenü klappt nicht auf.


    Ist das irgendwo konfigurierbar?


    Uwe

    Prinzipiell: Warum sollte das nicht gehen. Das könnte man ja einfach über eine Navigation lösen, die dann jeweils rechts die entsprechende Seite mit den Boxen einblendet.
    Wie "smart" das aussieht und wie es optisch funktioniert, hängt dann von dem verwendeten Layout ab. Wenn es on-mouse-over-Effekte oder ähnliche Einblendungen sein sollen, könnte man schauen, ob eines der angebotenen "Addons" für Zeta dafür passt. Oder sich selber eins basteln. Oder...


    Uwe

    Lieber Stefan,


    Du hast recht - ohne "www" im ftp-Setup geht es. Ein Rätsel bleibt es trotzdem: Warum ging es dann bis vor einigen Tagen auch mit www problemlos? Der Kunde hat ja auch ganz normal editieren können. Bis dann plötzlich die oben gezeigte Fehlermeldung auftrat und seitdem jedes editieren fehlschug.


    Kann es wirklich sein, dass der Anbieter (der Kunde stellt den ftp-Space selbst zur Verfügung) irgendwas geupdatet oder im Routing oder Domain-Zonefile verändert hat? Oder lassen die Browser plötzlich selbsttätig das www weg? - Wäre schon ein dicker Zufall...


    Na, wie auch immer: Es geht jetzt wieder. Danke für die Mühe.


    Uwe

    Hallo Stefan.


    Ich habe jetzt mal einzelne Artikel, ordner und zum Schluss alles in "CMS-Data" gelöscht. Das Ergebnis ist immer dasselbe: Das Online-Modul lässt sich online nicht aufrufen. Sobald beim Password auf "ok" geklickt wird, ist das Browserfenster eingefroren.


    Was könnte ich sonst noch sinnvoll probehalber austauschen? Da muss doch irgendwas kaputt gegangen sein...


    Uwe

    Liebes Zeta-Team,


    das Upgrade läuft jetzt ja anscheinend soweit (bei mir jedenfalls sehr gut). Vielleicht ist deshalb Zeit für mein kleines Problem, das sich leider auch mit der 13 nicht gelöst hat?


    Es ist nach wie vor so, dass das Online-CMS im Browser sich weghängt, sobald das Password eingegeben und "ok" geklickt wurde. Dann hilft nur noch, das Fenster zu beenden.
    Der Kunde hat zuletzt noch irgendwas editiert und bekam beim Abspeichern die o.g. Meldung angezeigt.


    Online geht noch alles. Wie kann ich das wieder editierfähig machen? Was kann da passiert sein?


    Uwe

    Hallo Jochen.


    Also nochmal im Klartext: Ich kopiere den ganzen Projektordner in den Dropbox-Ordner und öffne die Projekte von dort aus - ja? Alle für die Projektarbeit benötigten/veränderten Dateien werden von ZP in diesem Ordner verwaltet?


    Die Backups etc. werden dann aber weiterhin auf den jeweils lokalen Rechner verwaltet, richtig?


    UWe

    Hallo zusammen.


    Ich habe ZP bisher immer in der Cloud (Dropbox) benutzt (um die Arbeit auch mal auf dem Laptop mitnehmen zu können). Dazu habe ich den gesamten Hauptorder, den Zeta unter "eigene Dokumente" anlegt, per Symlink in die Dropbox geroutet (bzw. ein Junction) . Funktionierte einwandfrei.


    Jetzt nutze ich ZP im Büro aber mit Parallels auf einem Mac, und da geht alles, nur die Einrichtung eines SymlinksJunctions nicht, weil das ganze ja nur eine VM ist. Ich kann natürlich das jeweilige komplette Projekt in die Dropbox schieben und da einfach öffnen. Die entscheidende Frage: Geht das Problemlos, oder werden dann manche Dateien in die Dropbox, manche auf die Platte geschrieben, und endet das ganze dann im Chaos...?


    Über sachkundige Aufklärung würde ich mich freuen - ich sehe gerade den Wald vor lauter Bäumen nicht...


    BTW: ZP13 ist schon schön :) Habt Ihr gut gemacht.



    Grüße - Uwe

    Hallo Stefan.


    Danke erstmal, dass sich heute überhaupt jemand um andere Themen kümmert – sicher habt ihr zurzeit genug zu tun... 8-)


    Mit www geht auch nicht. Vor allem: Es ging ja bisher über Monate - der Fehler ist offenbar aufgetreten in dem Moment, da der Kunde den Artikel editiert und auf "ok" geklickt hat. Was er editiert hat, weiß ich natürlich nicht. Kann sowas passieren?


    Na, ich werde denn jetzt mal versuchen, das letzte Backup der Online-Daten auf den Server zu schaufeln.


    Uwe